Solved

Cannot open web shortcuts created on desktop

Posted on 2001-06-18
3
185 Views
Last Modified: 2010-04-13
Somehow all my web shortcuts and favorites are now displaying a ".url" extension.  The extension is visible from the favorites menu in IE 5.5, and also now on my desktop (Windows 2000 Pro).  Before, I had the shortcuts/favorites without any extension showing.  Now, when I click on a favorite (showing the .url extension) from within IE, it opens fine.  However, if I try to click on one of the shortcuts on the desktop, I get a dialogue box "You have chosen to download a file ...", and I'm prompted to open or save.  If I try to open, it just disappears for a second, then takes me back to the download dialogue box.  If I open the file in notepad, I get a 4 or 5 line file which includes the web address (http:// ...).  The files on the desktop are saved by right-clicking on the page and selecting "Create Shortcut".  The "shortcuts" no longer show a shortcut arrow, but instead seem to have been converted into actual url files.  I'm not that familiar with how it all works to figure this one out.  Any help would be appreciated.  Thanks.
Alan
0
Comment
Question by:afeldsott
  • 2
3 Comments
 
LVL 5

Accepted Solution

by:
djbusychild earned 200 total points
ID: 6204855
I think you lost extension binding.

do this open any folder
Tools->File Types
then look for "URL" under the extensions column

if you see it then click "advanced" then choose the "open" action, then click "edit" and put

rundll32.exe shdocvw.dll,OpenURL %l

in there.

if you don't see it then tell me I'll walk you through creating one
0
 
LVL 5

Expert Comment

by:djbusychild
ID: 6204859
If you don't see it click "NEW" from the "File Types" tab
then type "URL" then click "ADVANCED"

click on "NEW" then type "open" in the Action field

then put

rundll32.exe shdocvw.dll,OpenURL %l

in the "Application used to perform action" field.
0
 

Author Comment

by:afeldsott
ID: 6206435
You got in a couple of minutes before the next response, so you get the points.

Just one point - When I pulled up Tools .. Folder options ... File types for URL, there was no "Advanced" button.  The "Advanced" button had been replaced by a "Restore" button.  The text next to it said that the settings for that extension had been changed, and that clicking on the Restore button would restore the original settings.  I did that, and the button changed back to "Advanced".  I then clicked on that, and verified the settings were correct, matching what you said.  They were, and everything works fine now. Thanks.

Alan
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Adprep 12 85
There is less than 0% available RIDs in the current pool 5 768
unable to search  data in SQL 2000 server 10 309
Terminal 2000 connection RDP 5 140
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Read about why it is more lucrative for an IT company to participate in government projects.
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question