problem hiding known file type extensions

Certain file type extensions (dll and sys for example) continue to appear in explorer despite checking 'hide known file types' in View|Options. I have checked and unchecked and rebooted, but a few such extensions persist. The vast majority of known extensions are hidden as expected.
jhcarverAsked:
Who is Participating?
 
kahleanCommented:
i intent to propose the above as answer.
0
 
Asta CuTechnical consultant & graphic designCommented:
Choose Start > Programs > Windows Explorer.
Choose View > Folder Options.
Click the View tab in the Folder Options dialog box.
Select "Hide File Extensions for Known File Types."
Click OK.

That should work, can you tell us a bit more about your setup?  I can't ever recall seeing dll files or sys files as hidden.  Interesting, will explore further.

Asta

0
 
Asta CuTechnical consultant & graphic designCommented:
I asked what your goal is here, since there is the issue of double extensions. To make your viewing easier, Windows offers the option of turning off the viewing of file extensions. If you do that, however, you can easily be fooled by files with double extensions. Most everyone has been conditioned, for example, that the extension .TXT is safe as it indicates a pure text file. But, with extensions turned off if someone sends you a file named BAD.TXT.VBS you will only see BAD.TXT. If you've forgotten that extensions are actually turned off you might think this is a text file and open it. Instead, this is really an executable VisualBasic Script file and could do serious damage. For now you should always have viewing extensions turned on.   At least that's been my understanding, and another reason I asked about your goal on hiding these.

Asta
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
kahleanCommented:
well there are a few more setting that could be check as well in your view option in additional of the hide file extension of know file types.

1. Do not show hidden files or folders
2. Hide protected operating system file

Check this two option as well

Regards
0
 
jhcarverAuthor Commented:
"Hide File Extensions for Known File Types" is and has been selected all along; only recently have I noticed that a few system related? extensions are appearing in explorer.
Is it possible that extensions such as .dll have always been there and are supposed to be visible despite "hiding"?
"Do not show hidden files or folders" is also selected. I don't find a choice to "Hide protected operating system file".

PS: (to Asta) I run a small program called WatchDog which intercepts scripting files and prompts me to open or not; it would find a file named BAD.txt.vbs

0
 
kahleanCommented:
okay are you running win 98 or win me by the way, the configuration might differ
0
 
NavidCommented:
Have you changed the file attribute to "Hide" ? Because not all system files are automaticly set to hide attribute.
Mark the system files which are not hidden and "Right click"
Choose "Properties" from the menu
Now check the option which says "Hide"
Navid
0
 
NavidCommented:
Also use the same "property" from the menu and check the option which says "Protected"
0
 
NavidCommented:
You can also use Dos to change file attribute.
0
 
jhcarverAuthor Commented:
I have Windows 98 SE. To Navid - I am not trying to hide the file itself, just the extension for known types. I checked another Windows 98 system and found that .dll, ,sys, etc. were also visible despite hiding extensions for known types. Apparently, this is normal behavior in explorer; I just never noticed it before.

To Asta: you suggested this possibility with your first comment. Please confirm your thought that this is normal behavior, and I will assign the points.

Thanks,
John
0
 
kahleanCommented:
you are right, Windows default that some of the system file to be displayed with their extension like the dll file. Now here is a tweak which you can do it manually. Here how it works

1. Run regedit
2. From HKEY_CLASSES_ROOT, search for the desire extension key.For example dll. you will see a default string value called dllfile
3. Using this string value search further down from the HKEY_CLASS_ROOT for this string value.
4. Click the ddlfile key and you will see a string value called AlwaysShowExt. now remove this string.
5. Press F5 to restart. THe changes will take effect imeddiately.

BTW this will work on win95, win98 and win me as well

Regards.  
0
 
Asta CuTechnical consultant & graphic designCommented:
Good morning.

I've configured my primary Windows 98 SE system to show all files, hidden, etc.  Also configured to show all file extensions, quite the reverse of your goal, since I need all this information for all my testing and troubleshooting processes.  Nonetheless, checked most of my sys file extensions and some of my dlls.  All dlls are not hidden, most sys files are not hidden except those in the root directory that are, as examples:  iosys, msdos.

When I've reconfigured to hide all extensions, the same behavior you've experienced results.  Thus, I conclude that the behavior is required.  Personally, I modify my registry as little as possible because of the dynamic nature of my environment and have benefitted from the decision, but that's the beauty of end-user customization options.  I don't know if the registry Proposed Answer solution is what you want to explore, but would definitely recommend backing up the registry first prior to tweaking it.  

If I've misunderstood anything you've said, please advise.

Asta
0
 
jhcarverAuthor Commented:
That did it! Thanks kahlean.

Regards,
John
0
 
NavidCommented:
Good job Kahlean! Very Good call my friend!!!!!!!!!!
This proves that a good comment can always be accepted as answer no matter what.
Thank you for posting a comment and not a proposed answer. Very well suggestion.
We all appreciate good comments instead of proposed answers.
Navid
0
 
MoondancerCommented:
This was posted as a Proposed Answer, but did serve the client's needs.

Moondancer
Community Support Modertor @ Experts Exchange
0
 
kahleanCommented:
thanks everyone for the compliment here
0
 
Asta CuTechnical consultant & graphic designCommented:
Great news, happy you've found the ideal solution.  Great input, kahlean.

":0)  Asta
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.