Solved

DHCP Server does not respond to requests

Posted on 2001-06-19
11
314 Views
Last Modified: 2010-03-18
Hi.  I'm running Redhat 7.1.  I Installed the DHCPD RPM that came with redhat.  I created the dhcpd.conf file, by following the directions on this site: http://www.europe.redhat.com/documentation/mini-HOWTO/DHCP/x369.php3#DHCPSERVER

I also did "route add 255.255.255.0 dev eth1".  

I created the lease file, as instructed.  I then started the server using "/usr/sbin/dhcpd eth1 -d -f".

I then connected the linuxbox to a windows 98 computer, but it would not accept an address, and nothing came up on the linux machines screen indicating that it ever received one.  If anyone has any ideas, they would be greatly appreciated.
0
Comment
Question by:matt51
  • 3
  • 2
  • 2
  • +3
11 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 6209141
How about letting us see your dhcp config file. Also your route statement is wrong. It should be "route add 255.255.255.255 dev eth1" You may also want to be sure that the requests from the win98 box are reaching the server. Check for that by running "tcpdump -n -i eth1" and look for the request packets.
0
 
LVL 3

Expert Comment

by:tdaoud
ID: 6216849

You can also check the /var/log/messages file for any dhcp related failure/problem messages.

Good Luck

Tarik
0
 
LVL 1

Expert Comment

by:vreddypatil
ID: 6232315
why don't you use linuxconf's GUI to set up dhcp
it may ease your problem.

--Vijayapal
0
 

Author Comment

by:matt51
ID: 6233967
This is my dhcpd.conf:

default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option routers 192.168.1.254;
option domain-name-servers xxx.xxx.xxx.xxx;
option domain-name "mydomain.org";

subnet 192.168.1.0 netmask 255.255.255.0 {
   range 192.168.1.10 192.168.1.250;
}

I was mistakened I did in fact use the correct route command: "route add 255.255.255.0 dev eth1"


I responce the the linuxconf gui.  After I configured the server, I installed that module of linuxconf, and everything was setup correctly.  The server runs without error, it just is not responding to a request form a windows machine.

I apologize for the delay in my responce, so I've raised the points to 200.
0
 
LVL 3

Expert Comment

by:tdaoud
ID: 6234038


Is the dhcpd server running (if you check ps -axu)

I think it may not be running becuase you need to define in your dhcpd.conf file a sunbnet block for all of your subnets (ethernet cards).
Try to add empty subnet blocks to all other subnets that your computer is connected to.  Exmaple

subnet 192.176.21.0 netmask 255.255.255.0 {}

I had once the problem that dhcpd will not normally at startup without defining all subnets (even empty ones)  and I used for a couple of days to run it by hand specifying which eth's to listen to.

Good luck,

Tarik
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:matt51
ID: 6235997
I know the dhcpd server is running because I started it in the forground ("usr/sbin/dhcpd eth1 -d -f"), and with debugging, so all dhcp activity is reported to the console.  It starts up without any errors, it just does not display any requests for IP addresses.
0
 
LVL 3

Expert Comment

by:tdaoud
ID: 6236817


In windows 98 run the command "winipcfg" from Start/Run and try to "Release all" and then "Renew All" ips and see if it works.

Make sure that you also not have a fixed IP in windows 98 in the properties of TCPIP.

Good Luck,

Tarik
0
 
LVL 40

Accepted Solution

by:
jlevie earned 200 total points
ID: 6237811
Did you actually use the command "route add 255.255.255.0 dev eth1"? If you did that is the wrong subnet mask for the route command. It must be "route add 255.255.255.255 dev eth1" (note that the last octet of the mask is 255). Also I think your dhcpd invokation command is wrong. Assuming that your config file in in the standard place the command should have been "dhcpd -d eth0". The "-f" argument would be used to specify an alternate config file and if used the command should look like "dhcpd -d -f /path-to/config eth1".

The other question is whether dhcp request are reaching the server. And the way to find that out is to run "tcpdump -n -i eth1" and tell the client to "Renew All" (in winipcfg). You should see the DHCP requests in the tcpdump output.
0
 

Expert Comment

by:CleanupPing
ID: 9078770
matt51:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 9976027
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: jlevie {http:#6237811}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

majorwoo
EE Cleanup Volunteer
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now