FTP Server and Samba Server

Hi all,
I have set up a Linux Server: RedHat 7.1
I want to share resources with other PC (platform Win 9x and Win NT).
I have setup FTP and Samba server but they didn't work properly.
Do you have any step by step set up documents or any idea about this?

Thanks.
NBeeAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
When you set up Samba did you enable encrypted passwords in the smb.conf file? That's required for win98 to talk to the Samba server. And it is necessary to create an SMB compatible copy of the encrypted password with "smbpasswd some-username". Note that root is specifically prohibited from useing the Samba server, only ordinary user accounts are permitted access.

On the windows side you must set up the win98 system so that you are required to login to windows using the same username & password (case sensitive) that you use on Linux. And the win98 box must be in the same Workgroup that Samba is configured to be in (see smb.conf).

0
 
jlevieCommented:
What problems are you having with FTP and Samba?
0
 
NBeeAuthor Commented:
As I said they didn't work properly.
When I sit on server and try to connect to ftp, it ask me to enter name and then password but I always get the error message: Login Incorrect, Login failed.
When I sit on Window98 client and try to connect to server through ftp, i get this:
ftp> open 220.200.150.25
ftp: connect :10071
and then failed.
???????????????

0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jlevieCommented:
Are you trying to connect to the FTP server as an ordinary user or as root. Access to ftp by root is specifically denied for security reasons. Try an ordinary, unprivliged, account and see what happen then. The other place you can get into trouble is if you took the default firewall configuration when installing 7.1. That will essentially lock the system down w/respect to outside connections. In that case you need to modify the firewall rules to allow the inbound connections you wish to allow, or take the firewall down completely. Check for firewall rules being active with "ipchains -L" if all of the rules aren't "ACCEPT", then firewall rules are likely your problem.
0
 
NBeeAuthor Commented:
Yes, I have tried 2 accounts: root and test (but test belong to group root). Does that make anything wrong???
Do you have any step by step configuration guide about those???
Thankx
0
 
jlevieCommented:
Okay, you say that you've set up FTP. Lets see if it is actually set up correctly. If the server is installed you should be able to do:

wilowisp> rpm -q wu-ftpd
wu-ftpd-2.6.1-16

You need xinetd installed to be able to use FTP and you can check that with:

wilowisp> rpm -q xinetd
xinetd-2.1.8.9pre15-2

And xinetd needs to configured to enable FTP and that means that /etc/xinetd.d/wu-ftpd should look like:

service ftp
{
        socket_type             = stream
        wait                    = no
        user                    = root
        server                  = /usr/sbin/in.ftpd
        server_args             = -l -a
        log_on_success          += DURATION USERID
        log_on_failure          += USERID
        nice                    = 10
        disable                 = yes
}

I'm going to assume that you haven't messed with the various /etc/ftp* files and they are still "as installed". Now we need an ordinary user account to test with and that means that the UID and GID must be 100 or greater. While on the server try "ftp localhost" and see if you can connect.

If that works we can see if a connection can be made from the windows box. First we want to check basic network connectivity with a "ping -n IP--of-windows" from the server and a corresponding "ping IP-of-server" from the windows box. Next we want to check to see that we won't run afoul of any firewall rules by looking at the rulesets with "ipchains -L". If all are the rules are not "ACCEPT" the firewall need adjusting before FTP or Samba will work. If that looks okay try an ftp connection from the windows box to the server.
0
 
NBeeAuthor Commented:
Yeah, right! The main problem is the firewall. Thanks so much.
But what about the Samba Server? After configuring the Samba Server on RedHat 7.1, I use Window 98 to connect to Linux Server to get share things. but it shows this dialog:

Enter network password
You must supply a password to make this connection:
Resource: \\XSDG1\IPC$
Password:


XSDG1 is my Linux Server's name. I have entered many passwords (include root password) but it still prompt invalid password.
Anything's wrong????
0
 
NBeeAuthor Commented:
I got it! Thanks so much!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.