Solved

Win 2000 connecting to Win98/95 through Novell 3.12

Posted on 2001-06-21
20
275 Views
Last Modified: 2013-11-29
Hello Experts

I have just purchased 2 Win2k pro machines and wont them to be connected to my server.  I have a Novell 3.12 server, I have linked all my PC's using tcp/ip and have given the new PC's IP address's.  I have added the Client for Novell server's and added a prefered server and enabled log in script.

My problem is that i can see the whole network from my new machines, I can access folders etc but i cant access the new machines from my win 98/95 machines, i get the message:  

\\Lucy is not accessible
No permission to access resource

what have i missed I have done all the stuff i usually do when setting up a new 98 machine.

I have given all users all rights so this should not be a problem.

Help me please

Cheers

Plaster
0
Comment
Question by:plaster
  • 7
  • 3
  • 3
  • +5
20 Comments
 
LVL 12

Expert Comment

by:Nenadic
Comment Utility
You should install File and Print Services on your Win 2000 Pro computers in order to let other MS clients connect to it.

Then, of course, set up shares and permissions on them and you're done.
0
 
LVL 1

Expert Comment

by:Jez
Comment Utility
I'm pretty sure you need to have the windows machines accessing the same domain from the 2k boxes to recognise them as clients... but... you don't have one...
0
 
LVL 1

Author Comment

by:plaster
Comment Utility
I have file and print set up already and shares I have set up as everybody with rights to all functions. I still cant access the w2k machines from my win98 ones??

Domains whats this all about?? I dont have one just a workgroup and thats on my Novell server. could you explain more??

Plaster
0
 
LVL 12

Expert Comment

by:Nenadic
Comment Utility
On your 98 computer, add Microsoft Client for Microsoft Networks.

You probably only have a client for Netware networks at the moment, which allows you to connect to your Netware server. But, to connect to other Windows operating systems, you need a Microsoft client.
0
 
LVL 17

Expert Comment

by:mikecr
Comment Utility
Nenadic is correct, if you have file and print sharing already installed and set up, then you need to add the Microsoft client and give each computer the same workgroup name so that they can access each other.This will fix your problem. Make sure that you have all the updates and patches on the Windows 95/98 boxes because there is an issue with connecting to NT/2K machines but I can't remember exactly what it was.
0
 
LVL 1

Expert Comment

by:Michaelc
Comment Utility
You need to add the same user on the W2k machines as a local user as you use to logon to the W95/98 machines.
0
 
LVL 63

Accepted Solution

by:
SysExpert earned 200 total points
Comment Utility
In addition to all the above, It may be easier to enable the win2k guest account.

Also - in win2k , you have to ADD NEW SHARES  rather than use the existing administration shares ( C$ etc, Use the add button on the permissions tab.

----------
First make sure that all computers are using the same Workgroup name. No one should be using a Domain setup.
Next, you have to setup your shares on the win2k machines based on the users you have defined. Unless you defined a Domain controller, I assume you have workgroup sharing only. this means that you have to setup users.
I would add a new user on each win2k machine called user1 with a password.
When this is done, you have to give the user rights on the local machine.
If this is just you, then add user1 to the administrators group.
This is all done thru the user manager of Win2k in the admin tools of the control panel.
Next step is to set up NEW shares and give full rights to administrators only.

reboot your win98 machine and try logging in as user1. You should be able to access your
win2k shares.
Make sure you create a new user and do not try to use an existing user for all the above steps.
-------------
 1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

                   right click on the drive/file, choose properties - security - permissions. Give the person/goup full
                   access.

3) delete all the *.pwl files in the \windows dir on win98. Your next login will recreate them. reboot
                   !!
OK, you need to add a new share rather than the default administrative share.
                   Add the new share -( there is a new share buton at the bottom )  call it C-drv, set the permissions,
                   and that should solve the problem.
------------------------

I hope this helps !

0
 
LVL 1

Expert Comment

by:Jez
Comment Utility
W2k does'nt work the same way that 98 does. From my experiences so far.

If you do a non-server install on you computer of w2k. You need to add the Win98 computers to the security profile. Since you have no domain, ie. You are not a server. (workgroup is not good enough). You cannot browse the W2k Domain to add trusted computers.

There may be ways around it. I can't say. I have the same setup at home. And have not been able to get 98 -> W2k communication, only W2k -> 98. This is via shares.
0
 
LVL 1

Author Comment

by:plaster
Comment Utility
Right i have 20 computers 17 of which are win98/win95 they work fine connected to my netware 3.12 server they can all see each other and access each others files.

I dont want to change the win98 settings as they work i just need a workaround for the W2k machines so that thay can be accessed by the win98 ones.

Why do i need to change the logins for my win98 machines. surely its a security issue on the w2k machines Cant this just be disabled.

all i want is to be able to share everything.

imcclell yo mentioned adding the Win98 computers to the security profile. Where and how do i do this?

Sysexpert i read your post it was interesting up until you started messing with the win98 side of my network. this i will not be changing.

When i look at these machines on network neibourhood and right click on the w2k machines it says :  the server \\compname could not be found on the network.

this suggests to me that these machines are in some sort of server mode?? yes/no ???

I am mainly a Delphi programmer and intend one of these machines to be my development machine i need to be able to get access to it from my win98 boxes.

I have no Domain and i already have Novell client and print & file sharing enabled.  as i have done this lots of times with my win 98 machines i didnt expect any major differences in functionality

Can anyone help

Plaster



0
 
LVL 1

Author Comment

by:plaster
Comment Utility
ive just discovered that the 2 w2k machines have a file system of NTFS instead of FAT32 does this make any difference.

I tried all the add user and privaliges stuff and it didnt work

Help
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
1) Have you enabled the guest account  on win2k??

2) Did you try to add the NEW share for the drive, or use a share for a subdirectory, rather than a whole drive ?

NTFS allows stricter permissions than FAT, but the problem is win2k in general and not the file system.

I hope this helps !
0
 
LVL 5

Expert Comment

by:dcgames
Comment Utility
The WIN2K machine has access permissions one very file, folder, etc. For each of them it has a list of the people that can read, write, exeucte, etc.

When mixing 9x and 2K without a 2k Server (like you are), there has to be SOMETHING that tells the Win2K server when an external user is to be granted access.

One way to do this is to have all the macines in the same WORKGROUP. In the Pre-2K world the workgroup is a name for a group of machines. In 2K world the workgroup identifies a set of machines that comprise a "security group" in the sense that someone logged as UserX in a machine in the workgroup can be TRUSTED to be UserX and not some "other UserX".

Hence sysexperts recommendation that the workgroup be set on the Win98 machines.

If you don't want to do this, then you can try opening up all the security, but that means anyone can do anything on your Win2K system. If you are willing to do this, it's probably better to remove Win2K and install Win98.

Personal opinion aside, if setting the workgroup on the WIn98 PCs is too much, try this (which boils down to what sysexpert said):

a) On the Win2K machines, under Control Panel, Users & Passwords, un-click "users must enter a name and password to use this machine" (why bother if you don't need security".

b) In the same place, make sure the "guest" account is defined. Select it and look at the properties. I don't remember the details but I think you need to activate the account before "guests" are allowed. Set the permission level for guests. Set them to the same as "Power Users" or "Users" instead of the regular "restricted" setting if you want to give them full access.

b) Open my computer and right click on the C: drive, select sharing and select "new share".  GIve it a name (that's the name you will see in network neighborhood, say CDrive, for example. Click on permissions. The default should be that "EVERYONE" has "full control". However, this is not enough because EVERYONE means everyone that is recognized, and people outside the workgroup are NOT included in "EVERYONE".

Click on ADD and select "Guest" from the list of users and groups. This means EVERYONE that ISNT recognized. Make the permissions "FULL CONTROL".

You can do the same for folders ( you don't have to share the whole C: drive) and for things like printers or your CD-ROM, etc.

I'm not 100% sure this is all you have to do, or even if it will work. In partciular, I'm not sure you need to un-check the "users must log in to use this computer" box.

Let us know if this works. I'm sure sysexpert can elaborate on how to un-secure a Win2K pro machine.

Dave
0
 
LVL 17

Expert Comment

by:xema
Comment Utility
The way I see your problem is that Win 9x can not read NTFS partitions.   In order to share information from Win 2K TO win 9x you need a FAT partition on the Win 2K box and put the information you want to share there.

Win 2K can read FAT that's why you can access win 9x machines from win 2K but Win 9x can not read NTFS so you won't be able to access Win 2K from the Wi 9x boxes.
0
 
LVL 1

Expert Comment

by:Jez
Comment Utility
Under the security tab for a share folder, you will notice that you can add users to the share list. You can also add users from other computers. At the top you will see your computer name listed. And further more listed are any Workgroups/Domains, or computers attached to the Domain/Workgroup. Since you are not a server, 98 boxes will not be listed. Thou viewable and accessable from your w2k box to the 98 box.

From the 98 box. You may well see your w2k box listed under Network neigbourhood. But trying to access will bring up a IPC$ logon connect. This indicates that the w2k box cannot verify the 98 box and allow it the security access to gain entry to the w2k box.

I have recreated your scenario at home. So I will try and get a work around. I'm rather curious now...
0
 
LVL 1

Author Comment

by:plaster
Comment Utility
Yes I have had that IPC$ logon connect a few times but mostly it just says No permission to access this resource, will try some of the other suggestions and get back to you all.

Im so glad there is somewhere like this where i can pick peoples brains, without this place i would be very stuck.

Cheers so far
Plaster
0
 
LVL 1

Author Comment

by:plaster
Comment Utility
Yes I have had that IPC$ logon connect a few times but mostly it just says No permission to access this resource, will try some of the other suggestions and get back to you all.

Im so glad there is somewhere like this where i can pick peoples brains, without this place i would be very stuck.

Cheers so far
Plaster
0
 
LVL 1

Author Comment

by:plaster
Comment Utility
i tried reformating to FAT32 made no difference.

i have made users on my 2000 to match my 98 users

i have created a share on c:\ called c drive and set the priveliges to everyone, i also added guest to the share made no difference.

i have all the protocals enabled (i think) netbeui tcp/ip etc

I can ping all the machines from each other as i have given them all static ip addresses.

i have added the 98 users to the admin group which i thought would give them rights to everything??

my 98 users dont have passwords so i leave the passwords blank on my users in 2000.

please help what am i missing

Plaster
0
 
LVL 5

Expert Comment

by:dcgames
Comment Utility
Nothing (that I can think off).

So you must have flubbed one of the steps.. Something's missing from this picture.

:)

Dave

0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
1) Add a new user with a password  ( user1) in both win98 and win2k.

2) Login with this user in win98.

3)  Add a share to a subdirectory , not a drive.

I hope this helps !


0
 
LVL 1

Author Comment

by:plaster
Comment Utility
Sorry im late answering this but i couldnt get into EE it kept saying it was down try later. Anyway i started again and followed your guides carefully. and it worked.

What i had missed the first time round was setting the security on the drive when you right click. i had just been messing around in the sharing tab! once i had added guest to the security tab it all fell in place.

Cheers for your help guys

All the best

Plaster
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now