Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1780
  • Last Modified:

The Oracle Report Service returned service spicific error 186

How to fix it.
0
germaknv
Asked:
germaknv
  • 2
1 Solution
 
crsankarCommented:
Here is something from metalink. There are plent of others related to 186. Check this out first.

PROBLEM DESCRIPTION:
====================

Reports server is installed on Windows NT.  You are receiving a service
specific error 186 when trying to start the Reports server as a service.


PROBLEM EXPLANATION:
====================

You have taken the following steps:

1.  Verified that the tnsnames.ora contains a single line entry for the Reports
    server.

2.  Verified that the port is used only once.

3.  Verified that the default domain in the sqlnet.ora matches the Reports
    server entry (.world).

4.  Deinstalled and reinstalled the Reports server.

5.  Verified that the Reports server account has a default printer assigned
    and is set up as a "Use this account" account.

Solution: PLACE THE TNSNAMES.ORA IN ORANT/NETWORK/ADMIN DIRECTORY


SOLUTION DESCRIPTION:
=====================

Place the tnsnames.ora in the local ORANT/network/admin directory.
.
0
 
r_sudipCommented:
Hi,
 
 Usually this error occurs due to incorrect entry in the
 tnsnames.ora file or picking up the wrong tnsnames.ora
 file.

 As per crshankar's comment first find out whether it's
 picking up the correct tnsnames.ora file or not.
 the best way to ensure this is to set TNS_ADMIN in the
 registry(if windows)or env. variable(if Unix).
 Set the value to where your tnsnames.ora file is.

 Now try to start the report server.
 If it still throws the same error then check for the
 entry NAMES.DEFAULT_DOMAIN in the sqlnet.ora file in the
 same path where your tnsnames.ora file is.
 for e.g if it's set to

 NAMES.DEFAULT_DOMAIN=world

 then your reports server entry should read
 
 repsrv.world=(ADDRESS=(PROTOCOL=TCP)(HOST=server)
 (PORT=port))

 On the other and if NAMES.DEFAULT_DOMAIN is not set then
 the report server entry should be

 repsrv=(ADDRESS=(PROTOCOL=TCP)(HOST=server)(PORT=port))


Sudip
0
 
MindphaserCommented:
Please update and finalize this old, open question. Please:

1) Award points ... if you need Moderator assistance to split points, comment here with details please or advise us in Community Support with a zero point question and this question link.
2) Ask us to delete it if it has no value to you or others
3) Ask for a refund so that we can move it to our PAQ at zero points if it did not help you but may help others.

EXPERT INPUT WITH CLOSING RECOMMENDATIONS IS APPRECIATED IF ASKER DOES NOT RESPOND.

Thanks,

** Mindphaser - Community Support Moderator **

P.S.  Click your Member Profile, choose View Question History to go through all your open and locked questions to update them.
0
 
MindphaserCommented:
Force accepted

** Mindphaser - Community Support Moderator **
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now