Inexplicable Delay on Deleting

Almost every time I delete a file from my Win2k system, there is a 30 second delay before I get the confirmation dialog, and regain control of the Windows Explorer. If I delete a file from a remote drive, I of course do not have that delay.

Sometimes, if I delete a second file immediately after experiencing the delay, it is much shorter, say 10 seconds. But if I go and do other tasks, then delete another file, the wait is back up to its 30 second standard.

Can anyone recommend what I should investigate to eliminate this irritating delay? I have copied my system info (from msinfo32), below, in case this is helpful.

Thank you in advance,

System Information report written at: 06/21/2001 03:19:55 PM
[System Summary]

Item               Value
OS Name     Microsoft Windows 2000 Professional
Version     5.0.2195 Service Pack 2 Build 2195
OS Manufacturer     Microsoft Corporation
System Name          ATX
System Manufacturer     System Manufacturer
System Model          Product Name
System Type          X86-based PC
Processor          x86 Family 6 Model 0 Stepping 1 CyrixInstead ~233 Mhz
BIOS Version          Award Modular BIOS v4.60PGA
Windows Directory     C:\WINNT
System Directory     C:\WINNT\System32
Boot Device          \Device\Harddisk0\Partition1
Locale     United States
User Name          ATX\abcd
Time Zone          Mountain Daylight Time
Total Physical Memory          163,316 KB
Available Physical Memory     65,188 KB
Total Virtual Memory          555,272 KB
Available Virtual Memory     363,420 KB
Page File Space     391,956 KB
Page File               C:\pagefile.sys

jamestremainAsked:
Who is Participating?
 
goldwarlockConnect With a Mentor Commented:
try program filemon.exe (it's free)
to seen which processes use this file and you'll know the reason
I think hat:
1. antivirus/backup/etc process is working
2. ntfs/compress/bad HDD
0
 
intheCommented:
hi,
dunno if it helps but i have same problem after but i know what caused it .i installed 2 new harddisks (2*40gig),with many partitions and switched to ntfs file system,i believe this is a bad combination for this problem as there are small bits of files written all over the drives/partitions and many virtual recycle bins to check and empty,after defragging it gets better but still slow..

mabye you have similar configuration.
0
 
frankaCommented:
How are your partitions formatted?
Only one harddisk?
Less than 128 MB RAM?
many, many files on the partitions? (how many)
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
geoffrynCommented:
How about anti-virus software?
0
 
citadelgradCommented:
try setting the paging file by right clicking My Computer --> Properties --> in the Systems Properties click the Advanced Tab --> then Performanac Options --> under Virtual Memory click Change --> Set the Initial size and the Maximum size to 326MB ---> it will ask you to reboot your computer.

Why? The paging file may be fragmented.

Setting the initial and maximum the same size keeps your paging file from becoming fragmented. Microsoft recommends that you set your paging file between 1.5 to 2.5 times the amount of RAM in your system. I got 326MB by doubling your total physical memory.

I hope this works!
0
 
nrajanCommented:
Have you tried defragmenting the disk.

<Disk>->Properties->Tools->Defragment
0
 
jamestremainAuthor Commented:
Problem Sovled!

I tried the different recommendations here, but it was Filemon.exe (from sysinternals.com) that revealed what was going on during the 30 second delay: the system was scanning through files in the Recycle Bin. Turns out that although only a few items showed up in my Recycle Bin, some of these were actually folders that had hundreds or thousands of sub files and sub folders. Because I had a large hard disk, I hadn't worried about the fact that I had over a gigabyte of content in the recycle bin. It took about 20 minutes just to empty it all, and afterwards, my delete pause is gone.

Thanks all,

JT
0
 
jamestremainAuthor Commented:
Filemon.exe revealed that the problem was in my excessive recycle bin.
0
All Courses

From novice to tech pro — start learning today.