Setup problem:-(

Hi Experts,

In installed a software (I made that) which includes two ocxs,
the ocxs were put in the same folder as the exe.
Running fine.
Then I uninstall the software from the Control Panel.
Looks OK.
After that, I have found some other programs that need the
same ocxs cannot work anymore!
I quess the registry has linked to the ocxs in the folder
(not the windows/system) when I install the softwaer and
the link has been destroied when I uninstall the software:-(

Is this the reason nobody like to put ocxs in the same folder
as the exe?

If I put the ocx to windows/system and there are alweady same
ocxs there what will happen? I am using InstallShield.
learnAsked:
Who is Participating?
 
IainHereConnect With a Mentor Commented:
>If I put the ocx to windows/system and there are alweady same ocxs there what will happen? I am using InstallShield.

This is standard: if you're updating them to an earlier version, the installation will warn the user about this.  If updating to a later version, then it will [/should] be compatible with all programs that currently use it.

In any case, it should work fine.  BTW - did you get the autorun.inf to work :)
0
 
learnAuthor Commented:
Thanks a lot lainHere.
1. I decided to try send the files to windows/system and am going to post another question about how to do this:-)
2. I will try the autorun.inf.....but I hope I can create all setup files before try that....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.