Solved

Index tab on Delphi5 help contains no entries!

Posted on 2001-06-22
11
280 Views
Last Modified: 2010-04-06
I'm hoping someone can help me with this.  I'm not sure when this happened, but my Index tab on my Delphi5 help contains no items.  I installed Windows ME a few months ago, and it is possible it happened when I did that, but I'm not sure.  I've read a few vendors comments about Windows ME and the index tab being blank, but nothing which fixes my problem.

I've tried using the OpenHelp editor to look for problems and rebuild everything to no avail.  I've even removed all 3rd party help and still the same problem.  

Anyone have any ideas.  I can post the contents of my Delphi help project, contents, index and link files if requested.  I'm just hoping this is a known issue and is fixable since no index is kind of a bummer when searching for things.

Thanks in advance.
Steve Sutherland
0
Comment
Question by:ssutherl
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 4

Expert Comment

by:Colin_Dawson
ID: 6218842
Re-install deplhi!
0
 
LVL 1

Author Comment

by:ssutherl
ID: 6218900
Hope you're joking.  That's 2 days of downtime, and not a desirable option.
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 6219509
listening . . .(have the same problem) ;-)

offer same points to the answerer, if its helps me too
0
 
LVL 4

Expert Comment

by:YodaMage
ID: 6219549
I'd have to agree that you are re-installing.

*Side Note- Windows ME is flat out Evil.......
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 6219589
i use windows95, where this happens, and reinstall is no option
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 4

Expert Comment

by:Colin_Dawson
ID: 6219656
OK, that was a bit of a blunt message. But it's still true.  

Before trying any of the following BACKUP !!!!!!!!


1. Do a registry only install of Delphi and see if that works

2. Do a normal install of delphi and see if that works

3. Delete ALL the help file's to do with delphi, re-install them, and see if that works

4. Remove delphi using Add/Remove then re-install

5. Re-boot into safe mode, Remove delphi do a full scandisk & defrag, then re-install

I hope this gives you some more options.  Notice that I did not mention the old favorite of a complete machine re-build!

Regards
0
 
LVL 1

Author Comment

by:ssutherl
ID: 6219690
The reinstall option seems like solving a roach problem with a nuclear bomb.  This problem only exists in my delphi help file, and no others.  I'm sure it has to do with the way delphi integrates help files together.  Surely, there is a fix targeted more towards the problem itself.  

One thing worth noting, is after installing Windows ME, I DID have to install Delphi from scratch, so this is not caused by some messed up migration.  There is something just not right, and I am hoping for a more insightful answer.  I am not willing to do the registry only option, because that resets the component palette which makes it a real pain to get everything back the way it was.
0
 
LVL 22

Expert Comment

by:mnasman
ID: 6220045
Hello ssutherl

  I have Win Me from long time, and I don't have any problem with Delphi, the index tab work fine with me without any problems, I reinstalled win me and delphi several times, but I havn't got ur problem, and I don't think it from win me, I know most bugs came from microsoft ;) , but I don't know about this, try to reinstall delphi again

Mohammed
0
 
LVL 4

Expert Comment

by:DMN
ID: 6220456
It happen to me after attempt to install additional help files into Delphi help system... But soon after that I reinstalled all my system, so I don't know correct solution. But I think it's possible to completle move (to backup place, not remove) your borland\delphi\help directory and rewrite help files from RUNIMAGE folder on your delphi cd.
0
 
LVL 27

Accepted Solution

by:
kretzschmar earned 100 total points
ID: 6221347
i've resolved my problem (maybe partial),
maybe it works for you too

edit the file delphi5.cnt in the help directory (make  a save-copy first)

i have deleted lines which patterns

:Include AName.cnt

the index seems now to be ok
(maybe i will miss sometimes something, but not yet)
after saving the file and opening the delphi help

meikl ;-)
0
 
LVL 1

Author Comment

by:ssutherl
ID: 6222735
Meikl,

Your answer led me to something which worked.  I did what you said, and I did get my index back, but I lost my contents tab.  I then put all :INCLUDE's back, except the one:

  :INCLUDE Delphi5.ohi

which is the Openhelp Index file, and I had an index and contents.  This led me to believe that something was wrong in Delphi5.ohi.  So I put back the delphi5.ohi include, and commented out every item in delphi5.ohi.

Then, one by one, I uncommented each item in the .ohi file, deleted the delphi5.gid file, and retried the help. Each time I had an index.  After a while, the index would disappear when I added another item, so I would take it out again and try another.

So, I finally have an index tab, with most of the delphi help files, and a few of the 3rd party help files.  My guess is that there is somehow a limit to the size of the index in Windows ME, and maybe 95/98.  It seems like I can have only a certain number of things in the index.

I'm not happy with this, and I'm going to report this as a bug, but I am happy to have my index back with most of the help I need.  

Thanks for helping me to find an acceptable solution.

Steve Sutherland
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Objective: - This article will help user in how to convert their numeric value become words. How to use 1. You can copy this code in your Unit as function 2. than you can perform your function by type this code The Code   (CODE) The Im…
Introduction I have seen many questions in this Delphi topic area where queries in threads are needed or suggested. I know bumped into a similar need. This article will address some of the concepts when dealing with a multithreaded delphi database…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now