Solved

Networking Linux and Windows 2000

Posted on 2001-06-22
14
229 Views
Last Modified: 2010-03-18
I have a Red Hat Linux  7.1 system , Windows 2000 professional system and Windows 98 machine. I am sharing one DSL connection amongst the three of them . The WINDOWS 2000 machine is  dual boot enabled and has Windows ME on it.
I want to network these three systems together. I want the Linux box to act as the main server , the two other machines ( Win 98 and Win 2000/Me) should be able to telnet/access/interact/share files  with the LINUX system. I am going to install SYBASE ( or some other database ) on LINUX, the other two machines should be able to interact with that database. I want to setup an ideal programming environment. This kind of system exists in schools and offices .
Any kind of help will be highly appreciated.

Rahul
0
Comment
Question by:rahulkothari
  • 6
  • 5
  • 2
  • +1
14 Comments
 
LVL 3

Expert Comment

by:tdaoud
ID: 6220758

You will need to have TCP/IP installed and configured properly among the three machines.  It is already on LINUX but you may need to add it to Windows based (if not defined already).  You will need to assign addresses to all to show they are on one network.

You should have no problem after that of fully interacting with the LINUX system.  You should be able to TELNET, FTP, ACCESS DATABASES, through TCP/IP.

I'm not sure how you are sharing your DSL connection among the three machines, but you can also have LINUX act as a firewall/proxy server to the other machines (if you need that).

Good Luck,

Tarik
0
 
LVL 17

Accepted Solution

by:
psimation earned 200 total points
ID: 6222662
Your answer here is SAMBA. It is software you will load and configure on the Linux box, and it will allow the windows machines to log into the network and see the Linux box in network neighborhood, and the linux box to "mount" the windows machines' shares.
I have a comprehensive step by step page on setting up samba on my website that has helped many people here on EE before, so you might want to take a look at it.
go to www.linuxhelp.co.za and follwo the networking link.
You will notice that I start directly with samba, and assume that you already have the TCP setting on all machines sorted out and can ping the machines...
If you don't know how to set this up;
on windows.
Make sure TCP/IP protocol is installed in your networking.
Then assign an IP number in the 192.x.x.x or 10.x.x.x range to each machine, as well as a subnet mask ( for three machine, 255.255.255.224 will be more than ample) and make sure they all have the same workgroup  name. Make sure File(and print) sahring is enabled adn sahre something on each machine.

On the Linux box;
use netconf from a command line to make sure the network adapter is there and is enabled. Give the linux box an IP and subnet to coinside wth the windows boxes, and the rest is up to the SAMBA configuration as per my website.
If you don't have those three machines linked within 20minutes if you can ping all three, you KNOW you are doning something worng, and I would start re-tracing the steps...
If you can't ping, check hardware/cable.
0
 
LVL 2

Expert Comment

by:gregdavey
ID: 6223410
Hi psimation

I have a similar setup to rahulkothari

I have one machine as a firewall/fileserver with RH 7.1

I have 2 Windows 2000 machines with networking installed correctly on all 3. (I can ping all 3 machines from each machine)

I have installed and set up SAMBA. My windows boxes show the Linux box, but when I click on it, windoze gives and error "The network path was not found"

I have downloaded the instructions from your web site and I will follow them (I used other instructions to set up SAMBA)

Quickly looking at them, I think they should fix the problem.

I will let you and rahulkothari know how it works. If I am still having a problem, rahulkothari may like to know the solution.

After that I may be able to assist rahulkothari as I have a similar setup. I am also a newbie and will see things from that perspective

Greg
0
 

Author Comment

by:rahulkothari
ID: 6229203
Hi psimation,
              I can ping all my machines......i have a problem. I dont see the LINUX machine in th NETWORK NEIGHBOURHOOD. Also i didnt find the smb.conf file on my LINUX machine. I have a Red Hat 7.1.

As i had mentioned before....i want to be able to telnet into my Linux machine and use the programming toold and databases that i have installed on it.
 What should i do next.

Rahul
0
 
LVL 17

Expert Comment

by:psimation
ID: 6229277
Oops, my fault, I havn't updated my website yet since 7.0/7.1, in the new redhat distros', samba and it's config files are in /etc/samba and not in /etc, so your smb.conf file is /etc/samba/smb.conf
If you still don't find it there, then it is not installed, and you should install it with rpm -i sambaxxxxx.rpm from your Linux CD in the RedHat/RPMS folder where xxxxx is the version and other info as you will see when viewing the contents of the cd-rom. You will see more than one file relating to samba there, and should install all of them. Afterwards, you need to do the configuration bit as per my website with the cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd for the 7.1 version instead of the line listed there curentlyy.
For telnet ( and samba to start automatically), type setup at a prompt and make a mark infront of telnet and samba. If you don't see telnet there, then you didn't install it ( probably did a workstation install then and that's why samba isn't there either...
0
 
LVL 2

Expert Comment

by:gregdavey
ID: 6230153
Rahul

If you need to install/update your samba installation I would reccommend either the Gnome package manager (if you have gnome installed) or Kpackage (if you have KDE installed)

If you can't find gnorpm or kpackage under the system menu then:
- make sure you are logged in as the root user to install software on Linux.
- Open a terminal and type su - and enter the root account?s password when prompted.
- type either gnorpm or kpackage to launch KDE or GNOMEs package managers.

I have found the gnorpm to be 100% relible on my system. It sure makes life a lot easier than building by hand

THe other thing you can do if you are looking for a file is to start a terminal session
type cd \ <enter> to change to the root directory
type locate smb.conf <enter> to find where smb conf

to start samba type samba start <enter>
to restart samba type samba restart <enter>

Good luck!

Greg
0
 

Author Comment

by:rahulkothari
ID: 6235421
psimation,
           it worked like a charm....here is the other problem. The linux bob appears as localhost on the networking neighbourhood. What should i do inorder to telnet into my LINUX machine...i typed telnet://localhost/
and it didnt work...i tried the ipadress of the LINUX machine to telnet into it..i couldnt.
The idea is to use the databses and programming tools in the LINUX machine through the WINDOWS machines.
Now how would i telnet into the LINUX machine from my home ?

Please help

Rahul

PS: thanx greg.....its good to see you taking part in this
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 17

Expert Comment

by:psimation
ID: 6235623
You didn't set a name for your machine in the network configuration part in Linux. Run netconf ans set a hostname ( choose a name for your Linux PC...)
The reason telnet localhost didn't work, is because localhost is a special name pointing towards the machine from where you are issuing the command onto itself.
Once you gave your machine a host name, the problem should be solved.
Also, make sure telnet is installed, running and not disabled in the /etc/xinetd.d/telnet file. Open the file in a text editor and make sure it reads disable = no ( or something to that effect)
PS, I would really recomment NOT to use telnet if you plan to have this machine accessible from outside a private network. Rather use SSH, it's basically the same as telnet, but much more secure, and in this case much esierto setup and run.
For the db stuff, if you run mysql and you want the windows boxes to "link" to it, it should happen accross a normal TCP/IP link, which samba should be able to maintain automatically. Thus you only need to be able to "ping" the Linux box in order for your other machines to be able to access mysql or similar db apps. as they run on a different port than your normal network layers.
0
 

Author Comment

by:rahulkothari
ID: 6235884
I ran netconf and i gave the hostname Delllinux....
i ran tellnet://Delllinux from the windows Pc and it said CONNECTION LOST.

I see the Delllinux name in the network neighborhood.
So i know its in the nhetwork...
i opened the Telnet configure file...and it reads

# default: on
# description: The telnet server serves telnet sessions; it uses \
#     unencrypted username/password pairs for authentication.
service telnet
{
     flags          = REUSE
     socket_type     = stream        
     wait          = no
        disable         = no
     user          = root
     server          = /usr/sbin/in.telnetd
     log_on_failure     += USERID
}


i added the "disable = no" part....and it wasnt there before.

Kindly suggest what to do....

Rahul
0
 
LVL 17

Expert Comment

by:psimation
ID: 6236945
Sorry, that line I mentioned should read:
disabled = no and should be added just above the "flags = REUSE line.
Make sure there is a process called xinetd running ( type ps -A )
Did you setup the IP and subnetmasks correct?
IP's must be in range 192.x.x.x or 10.x.x.x and should be unique for each machine, and netmask should be the same for all machines, use 255.255.255.0 to be safe and IP's like 192.0.0.1 ; 192.0.0.2; 192.0.0.3 etc.
0
 

Author Comment

by:rahulkothari
ID: 6238905
a new problem has arised.......i try to boot my computer and it stops at
Starting sendmail :
it hangs for a long time and when i hit ctrl+alt+del
it reboots.

please suggest.

Rahul
0
 

Author Comment

by:rahulkothari
ID: 6239371
if i dont hit any key...after 5 min or so, the computer boots up normally.

Rahul
0
 

Author Comment

by:rahulkothari
ID: 6239384
surprisingly.....it said Starting sendmail : OK.
this suggests it started sendmail successfully , i wonder why it took 5 min to start it.

i am sure there something wrong in the boot up.

Rahul
0
 
LVL 17

Expert Comment

by:psimation
ID: 6240003
Just type setup and remove the mark from the sendmail line, it will prevent sendmail from starting.
You are getting this problem because sendmail is not coreectly setup, but you don't need sendmail anyway, so just stop it from loading...
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now