dsn connection

When i am using northwind database (built in when installed sql server) to create a recordset, it is ok.
But when i am using my own creation database to create a recordset, one dialog box come out showing:

[Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword 'User'.

I use the same driver in odbc when i create the DSN

I am using Sql server 7.0 and ultradev 4.0 with Windows2000 server.

Please help...
thank you
anwar13Asked:
Who is Participating?
 
dclaryConnect With a Mentor Commented:
The only message I get with SQL 7.0 is

"The total row size (8353) for table 'File' exceeds the maximum number of bytes per row (8060). Rows that exceed the maximum number of bytes will not be added."

Hope that helps
0
 
anwar13Author Commented:
[Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword 'User'.

User here is the user table.
0
 
Eric AKA NetminderCommented:
Can you post your query?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
anwar13Author Commented:
ALTER TABLE [dbo].[File] DROP CONSTRAINT FK_File_USER
GO

if exists (select * from sysobjects where id = object_id(N'[dbo].[USER]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[USER]
GO

if exists (select * from sysobjects where id = object_id(N'[dbo].[File]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[File]
GO

CREATE TABLE [dbo].[USER] (
     [UserID] [numeric](18, 0) NOT NULL ,
     [name] [varchar] (50) NOT NULL ,
     [password] [varchar] (50) NOT NULL ,
     [email] [varchar] (50) NOT NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[File] (
     [UserID] [numeric](18, 0) NOT NULL ,
     [FileID] [numeric](18, 0) NOT NULL ,
     [FileDesc] [varchar] (8000) NOT NULL ,
     [FileTitle] [varchar] (200) NOT NULL ,
     [FilePath] [varchar] (100) NOT NULL ,
     [FileDate] [datetime] NOT NULL
) ON [PRIMARY]
GO
0
 
Eric AKA NetminderCommented:
Looks to me like USER is being thought of as a keyword or reserved word...

Try changing the name of the USER table to something else, and see what happens...
0
 
PhilipT1999Commented:
I agree with dclary your create table is 8336 plus the length of the date. Which exceeds the max row size.  You have a fileDesc of 8000 (seems kinda large), just lower that until the total length is less that 8353 or break it out into a second table.
 
0
 
PhilipT1999Commented:
I meant lower it until the total length is below 8060 bytes.  Sorry about the typo.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.