Solved

F10 and Compaq CMOS Setup for New SCSI Stuff

Posted on 2001-06-24
15
783 Views
Last Modified: 2007-12-19
I have a Compaq Prolinea 5133 which I bought second hand a couple years back. It's worked very well for me, but a recent problem has come up. I bought a Konica Q-Scan at auction, so to install it I got a SIIG SCSI 2 adaptor. On reboot after install the system saw the new card and I installed the drivers and hooked up the scanner. Now on boot up the first thing I get is an error asking me to set the IRQ to 255. I hit a key and it by-passes this screen, recognizes the Konica scanner by name, starts WIN 95 and everything runs well as before, except when I go into my scanning software, it says the Q-Scan is there, but when I actually go to scan it says the scanner is not connected. I also have a flat bed scanner piggybacked onto the printer port, and it still works fine.
A couple of folks told me to go into CMOS and change the IRQ for the SCSI, and this brings me to my main problem. The HD was formatted blank when I got the thing used, and none of the Compaq install disks came with it. I didn't think it was a big deal at the time, but apparently you need the Compaq Start Up Utility in a non-DOS partition to even have the option of hitting F10 on start up to go into CMOS. I went to the Compaq website and downloaded "SP6144.EXE", which, if I understand correctly, should install the Start Up Utility, but when I went to run it, it couldn't.
Question: Is there a way I can get this scanner up and running without screwing up anything else? I'd hate to do that since everything else is working well.
0
Comment
Question by:Dean Peterson
  • 4
  • 3
  • 2
  • +5
15 Comments
 
LVL 2

Expert Comment

by:gikam
ID: 6223328
temporary remove your CDROM drive.
check again. If its working now, then change SCSI ID for your scsi card
let me know
0
 
LVL 6

Expert Comment

by:kahlean
ID: 6223520
IRQ 255, this sound strange, you cant have this IRQ value. I might afraid it has conflict with your other devices. Now from your system info check out if thereare any device that are sharing the same resources as your scanner. Remove both of them. Try to install the scanner first and follow by the other deivce that might have conflict with it.
0
 

Expert Comment

by:vkapila
ID: 6224074
You need to logically tackle the problem and go through a process of elimination, sorry microsoft speak :-).

Check your scsi card eg.
- see if it will work with another type of scsi device
- try a different scsi card, if you can possibly borrow one
- go into the scsi configuration software, normally you will get a prompt to hit something like ctrl+A just after the card initialises.  I think this is where you change the scsi id, not in the cmos

Check the Scanner
- if bought in an auction there is a possibilty that it may be faulty.  
- check if there are any dip switches on the scanner that you could configure.  you should be able to download specs for the scanner from the net
- check the scsi termination on the scanner.  If the scanner is the only, or last device on the scsi bus, it will need to be terminated

 System partition / start up utility
I would not try to install this, unless you have means of backing up your system first.  normally compaq utilities can be set up in a special system partition, but this needs to be done prior to operating system installation.  Trying to do it as a later step is not possible and could corrupt your operating system.
0
 
LVL 32

Expert Comment

by:jhance
ID: 6225209
Dean,

Please reject vkapila's answer here.  It's far too general and doesn't really address your specific problem at all.  He was overzealous in locking your question with it.

Not only that, but by doing that, he has moved your question out of "play" and most experts won't see your question or if they do see it, will be reluctant to spend any time offering help, only to have you accidentally accept his answer to this question.

If you want to get any additional attention paid to your question, please REJECT the PENDING ANSWER NOW!
0
 

Author Comment

by:Dean Peterson
ID: 6225665
A couple of comments regarding the various comments:
gikam-My CDROM is an IDE, not a SCSI.

kahlean-In the device manager there is no apparent resource conflict indicated.

jhance-I'm going to hold a moment before deciding whether to reject the proposed answer.

vkapila-I've already done the Ctrl-A and gone into the manager that came with the SCSI card. There is no provision there for changing the IRQ.
0
 

Author Comment

by:Dean Peterson
ID: 6226093
Afraid I'll have to reject vkapila's proposed answer. The SCSI card is good, the device ID is not in question, the scanner is terminated and set properly. SCSI clearly says "set IRQ to 255" on every boot but Ctrl-A does not allow for changing IRQ. Couple of other points. Get code 10 in Device Manager with the yellow exclamation mark. No IRQ is assigned to SCSI adaptor, nor is one assigned to the other SCSI device (the flatbed scanner) which is piggybacked on the printer port. But the flatbed still works fine. Followed SIIG's website advice and uninstalled driver, deleted and sigscsi.inf, siigscsi.inf, or OEMx,inf files pertaining to SCSI installation, then reinstalled. Only thing I have not yet tried is to change slots.
0
 
LVL 17

Expert Comment

by:rayt333
ID: 6226125
To get into the setup you will need to download a softpaq from Compaq from this site:
http://www.compaq.com/support/files/desktops/us/download/303.html

Choose the language of choice and download it, then follow the direction to make the (2) floppies that will enable you to access the setup
One is for the setup and the other is for the Diagnostics
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 2

Accepted Solution

by:
BigFitz earned 300 total points
ID: 6226217
to expand on rayt333's answer here, as well as some further info about Compaq's F10 setup utility:  The "F10" setup utility goes in a NON-DOS partition out AHEAD of your "C" partition, and MUST BE INSTALLED PRIOR TO FORMATTING the "C" partition.  Trying to add it after the fact will NOT corrupt anything, it simply will not work.  It will insist that there is "insufficient space" on the hard drive (there ISN'T where it wants to put it) BUT there is a saving grace here--the setup utility can be run from floppy, having it in the "F10" partition is simply a convenience.  Download the appropriate Compaq "SP" use it to make a set of floppies, and boot from the "setup" floppy to get int setup.  It may try to get you to install or update a system partition, but don't bother (as mentioned above.)  The other comment above about IRQ 255 being an incorrect value is indeed right on.  IRQ's (at least in that unit) are numbered from 1-15, period.  The fact that you have a yellow exclamation mark in device manager means either a hardware conflict, incorrect or incorrectly installed driver or a failed device.  I'm betting IRQ conflict or incorrect driver, possibly a CMOS setup issue but I doubt it.  (By the way, if you do indeed have a SCSI scanner running off a parallel port, I'd like to see it---a neat trick, if it were possible, which it isn't.)  And you may want to change slots and give Windows a clean shot at redetecting the card.---Fitz
0
 

Author Comment

by:Dean Peterson
ID: 6226249
rayt333-Already downloaded the software in question from Compaq with the results BigFitz noted, a message saying there was insufficient space.

BigFitz-I didn't say anywhere that the flatbed scanner was a SCSI...but when you go into Device Manager WIN95 lists it as a SCSI device. I'm also aware that interupts on this machine are 0-15, but that doesn't negate the message the AdvanceWare gives me every time the system boots, which is ERROR-Set IRQ to 255.

I did boot from the floppies, I get the "Compaq" screen but no option to go into CMOS and none of the utilities address the problem. This I will try again, though, to see if there's anything I missed.
0
 
LVL 2

Expert Comment

by:BigFitz
ID: 6226295
Yes, good old misguided Win 95 DOES identify parallel-port devices such as scanners and ZIP drives as "SCSI" devices but it's befuddled.  If you got the correct SP, you should be able to boot from the "setup" disk and choose "computer setup" from the menu.  If you'll post the SERIAL NUMBER (12 digit alpha-numeric) of your system, I'll look it up on Compaq's site (when I get a spare minute) and be sure you got the correct SP for your system.  Compaq doesn't refer to CMOS as CMOS, just "setup" and probably won't be too much help as Compaq's BIOS's rarely provide the opportunity to assign IRQ's, but it WILL help you find a conflict.  I'm betting it's a driver issue, but if I have the serial number I can be of more help (Compaq hides a BOM or config code in their sn's) with your specific system.---Fitz
0
 
LVL 2

Expert Comment

by:gikam
ID: 6226835
Man,
there is no doubt that your CD is IDE,
remove it just a bit for me, please.
Windows sees sometimes IDE CDROM as a SCSI device, I had this problem with a SCSI scanner whith a SCSI controller which I cannot set other ID than 0, and I had to remove the CDROM for the software to see the scanner, really
luck!
0
 
LVL 4

Expert Comment

by:drcspy
ID: 6227189
now...to add to this
I have a prolinea 575e (dont laugh- it's overclocked to 90 heheh) had to get to the setup to enable the second ide channel....anyway...you DONT have to go to the trouble of installing an "F10 Partition"......just download the correct softpaq...and run it from dos....off a floppy or from windows by making a dos shortcut....easy...then use the softpaq setup function to change your system settings.......you'll need to run the 'setup' softpaq program then   goto '/storage/advanced/ (within the program)  to enable the secondary and fiddle with the irq

oh I read further...you say you did boot from the floppy...well what you need to do is...goto windows...put in floppy then try to run from there it'll give you choice to goto dos and will restart and run the program ......clik language choice then run the 'setup' option....the goto storage/advanced..to change the irq
0
 
LVL 17

Expert Comment

by:rayt333
ID: 6229280
Dean
Maybe you misunderstood my earlier comment, this is a DIFFERENT softpaq then the one you had, the one you had was to make the setup and diagnostics partition on a HD without any partitions defined yet.
The one I posted a link to is for making TWO FLOPPIES that will allow you to get into the  setup and diagnostics from them, you simply boot up to one of them (one is for setup, other is for diagnostics)

You download that softpaq, then you follow the directions to make the two floppies.

In other words you put a floppy in the drive then you doubleclick on that softpaq, then when it tells you to remove that one and insert another.

If you would have looked at that link I posted it sure would save alot of time here ........................................
It is self explainatory ................................
0
 

Author Comment

by:Dean Peterson
ID: 6229296
Worked like a charm from the floppy. The first time I tried it had a corrupt command.com. Reformatted the floppy and it worked.
0
 
LVL 17

Expert Comment

by:rayt333
ID: 6229439
Dean Peterson
You are very welcome for the help here, it is nice to see the correct expert get the credit .................
Ray
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now