Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 280
  • Last Modified:

CD Rom disabled after Safe Mode reboot

Installed a MS Access based program, the new program screwed up some basic workings of  Windows 98 so that I had to reboot in Safe Mode.  After the Safe Mode reboot I lost access to my CD Rom.  "No problem", I thought, "Been here before", I'll delete the CD Rom from the Device Manager, from Autoexec. Bat and Config. Sys and reinstall the CD software.  Multiple attempts to reinstall the CD Rom no success.  I get, "Device driver not found "CD001" and "no valid CDROM device drivers selected".

I'd like a solution that does not require the drastic Format Disk suggestion.  I have backed up the registry and other important hard disk info but that is on Zip Drive which I may lose if problems  escalate. I have a Microsoft Boot Disk and CD rom Installation disk  on floppy.  Also an old startup disk created months ago.   I have opened the case and reseated all connectors and air sprayed the dust bunnies.  At this time the CD light is flashing but I cannot eject the guilty CD out.

Pentium II 400MHz with 8 gb hard drive (C:), 128 RAM, CD is 42x (E:), ZIP 100mb (D:), bought in 1999.  Access to internet only from this computer.

Last time this happened Emery800 and Ampcats helped me.
0
syhnbuddy
Asked:
syhnbuddy
  • 7
  • 2
  • 2
  • +4
1 Solution
 
hewittgCommented:
Use your boot disk and see if the cd is detected.  If so, we will go from there.  In safe mode, it will not load all drivers.

Glenn
0
 
trekie1Commented:
syhnbuddy....look on the front of the cddrive,,,,there is a very small hole,,,,,stick a pin or whatever into that little hole and push,,,,the cddrive door should open enough to get the cd out,,,,then follow Glenns directions
0
 
syhnbuddyAuthor Commented:
Thanks trekie1, the cd door opened and guilty cd out but still not detected by device manager.

Glenn, the boot disk start does not detect cdrom with all three modes of start (1. start windows setup from CDROM; 2. start computer with CDRom support; 3. start somputer without CDRom support)  CDRom is also not detected from startup disk boot up.  CD installation disk from Add/Remove Programs in control panel doesn't seem to do the trick.  Add New Hardware doesn't give option to add CDRom.

syhnbuddy
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
syhnbuddyAuthor Commented:
Thanks trekie1, the cd door opened and guilty cd out but still not detected by device manager.

Glenn, the boot disk start does not detect cdrom with all three modes of start (1. start windows setup from CDROM; 2. start computer with CDRom support; 3. start somputer without CDRom support)  CDRom is also not detected from startup disk boot up.  CD installation disk from Add/Remove Programs in control panel doesn't seem to do the trick.  Add New Hardware doesn't give option to add CDRom.

syhnbuddy
0
 
syhnbuddyAuthor Commented:
Thanks trekie1, the cd door opened and guilty cd out but still not detected by device manager.

Glenn, the boot disk start does not detect cdrom with all three modes of start (1. start windows setup from CDROM; 2. start computer with CDRom support; 3. start somputer without CDRom support)  CDRom is also not detected from startup disk boot up.  CD installation disk from Add/Remove Programs in control panel doesn't seem to do the trick.  Add New Hardware doesn't give option to add CDRom.

syhnbuddy
0
 
aranaCommented:
if a win98 startup disk does not detect your CD then :

a) you may have a physical problem on your CD Drive

b) you disabled the IDE of your CD drive (almos allways 2nd ide), on the system SETUP (cmos)

c) your setup (cmos) IDE for that drive is not in the "AUTODETECT" or CDROM option)

i think b or c are the easiest to happen (since you said you opened your box i assume you usually move the setup also :)  )
0
 
emery800Commented:
Don't remember what we found before, however, recall that some would not load up in windows and the questioner had to load them fro the config.sys and autoexec.bat. Have you checked too see:
1. Come up in safemode and go into device manager and make sure no cd-roms are showing and also that your secondary IDE controller is working properly?
2. Look for autoexec.bak and config.bak and open them up in wordpad and see if they contain the strings for loading the cd-rom.
3. The cmos settings could definately cause the problem but why would they have changed? :>) Dave
0
 
syhnbuddyAuthor Commented:
Arana you may be correct concerning "a physical problem" on cd rom drive since "the cd rom disappearing act" was corrected by emery800 asking me to twiddle the cables connecting the cdrom to power and controller cables.  I told him I didn't think that would work because there hadn't been any earthquakes - BUT it worked.  Just checked CMOS and the primary and secondary master and slave are on autodetect.  Can find no mention of cdrom.  There is something odd about the secondary slave because the boot-up check says, "Detecting HDD secondary slave...F4 to skip, then it changes to NONE."  When cdrom is working the same line mentions something about ATAPI.

Emery800 (Dave)
I came up in safemode and indeed there is mention of the cdrom.  This is not found with ?regular' startup.

The autoexec.bak file says:
REM ***  ATAPI SERIES ADDED LINES ***
rem - By Windows Setup - C:\WINDOWS\COMMAND\MSCDEX.EXE /D:CD001 /L:D /M:32
REM ***  ATAPI SERIES ADDED LINES *** ( 31-Jul-00 )

Autoexec.old says:
SET SIMFILES=C:\SIMPC
@PATH C:\PROGRA~1\WIN98RK;%PATH%
Rem TShoot: REM ***  ATAPI SERIES ADDED LINES ***

Rem TShoot: C:\MSCDEX.EXE /D:CD001 /L:E /M:32

Rem TShoot: REM ***  ATAPI SERIES ADDED LINES *** ( 26-Jun-01 )

Rem TShoot: SET SIMFILES=C:\SIMPC



The config.old says:
Rem TShoot: REM ***  ATAPI SERIES ADDED LINES ***
BUFFERS=10
Rem TShoot:
FILES=20
LASTDRIVE = Z
Rem TShoot: [common]

Rem TShoot: DEVICEHIGH = C:\CDROM\CDROM.SYS /D:CD001 /PIO4

Rem TShoot: [common]

Rem TShoot: LASTDRIVE = Z

Rem TShoot: DEVICEHIGH = C:\hardware\CDROM.SYS /D:CD001 /PIO4

Rem TShoot: REM ***  ATAPI SERIES ADDED LINES *** ( 20-Aug-00 )


Rem TShoot: REM ***  ATAPI SERIES ADDED LINES ***

Rem TShoot: REM ***  ATAPI SERIES ADDED LINES *** ( 26-Jun-01 )


REM ***  ATAPI SERIES ADDED LINES ***
[common]
LASTDRIVE = Z
DEVICEHIGH = C:\CDROM\CDROM.SYS /D:CD001 /PIO4
REM ***  ATAPI SERIES ADDED LINES *** ( 27-Jun-01 )

The REM above were done by me messing in the msconfig program.

Is any of this helpful?
Syhnbuddy
0
 
babkeCommented:
Well to see if the problem is hardware based you should carefully watch during BIOS startup (when it offers you to enter BIOS setup) if there is a list of awailable drives showing... if you do not see the list of available drives (in "primary master,primary slave, secondary master, secondary slave" format) you should enable it through "standard CMOS feature" where you will place all drives to auto... if you do not see your CD ROM drive after this the problem is hardware... since you opened your computer case and MADE sure your connections are ok the only other solution for hardware part is your IDE controler.

Do check that your primary and secondary IDE controler are working properly (in control panel\system\device menager\)
and that the proper controler drivers for your motherboard are installed.

another solution would be to force CD-ROM instalation with your driver disk. actually there is a section in add new hardware that lets you choose "cdrom controlers" so try it with that. if not than use your driver disks to install DOS drivers (autoexec.bat and config.sys) again.

please keep us posted with the results after these suggestions
0
 
babkeCommented:
missed your post... :(

well...
what you see in safe mode is not mention of your CD-rom it is a mention of still present drivers for your cd-rom on your system. these should insure that when you reinstall your cd-rom in your computer the preinstalled drivers are used by windows...

there's always a press f4 to skip and than a change to none type of message although it's usually to quick to notice....

forcing driver instalation in win and dos
0
 
syhnbuddyAuthor Commented:
Babke, I did try installing CD-ROM controllers (picked Sony).  Didn't succeed since need windows CD-rom. in E: drive to complete installation and of course that's the problem here.  If you look above at the copies of config.old and autoexec.old, I have tried to force CD-ROm installation by reinstalling dos (autoexec and config) drivers.  Added and REMoved multiple times.  Tried it with the mscdex.exe file in various locations (e.g. A: and C:)Doesn't cause windows 98 to recognize it.  
0
 
syhnbuddyAuthor Commented:
Thanks everyone!  I got my CD rom back!  It turned out that another Startup disk boot up recognized the cd rom.  The Microsoft Boot Disk was not the right disk.  It was the Startup Disk that is created during Windows 98 install that worked.

I don't know why the previous attempts did not work.  The ONE THING different that I did was a VERY COLD BOOT (about 5 minutes of the CPU shut off then start with Startup in A: drive) instead of a RESTART.  Can such a silly thing make a big difference?

I really solved my own problem but will arbitrarily give these points give these points to hewittg (Glenn) since his advise was similar to what solved the problem.  Thanks to all who tried to help me.
0
 
cumboCommented:
syhnbuddy,

Right click on "My Computer" and click on Properties from the menu. Click on the Performance tab.
Do you see a "DOS Compatability message? If so, goto Device Manager and click the + next to
Hard Disk Contollers, you should see a Master, Primary and Secondary. If the secondary is missing this is part of your
problem. If you see the DOS Compatability message that is also part of your problem.

Let me know what you find.

Cumbo
0
 
emery800Commented:
syhnbuddy: Great advise above and glad your working but you need to follow through with what cumbo is telling you as you may be loading the cd-rom through dos and if you can let windows load it you will be much better off! :>) Dave
P.S. I would have deleted the cd-rom in safemode and rebooted to see if windows would reload it.
0
 
syhnbuddyAuthor Commented:
Dear Cumbo,
Did as you suggested to check the hard disk controllers in the System Properties Folder.  No mention of DOS Compatibility.  I therefore presume the cdrom is loading through Windows.  I also note that Device Manager mentions master, primary and secondary in the Hard Disk Controller section.

Dear emery800
Yes, I remember you advised me to delete CDRom from device manager in safe mode last year when I was having the earthquake problems.  In fact it was the first thing I did before appealing to EE.  Didn't work, Windows didn't autodetect.  Have no idea how it got back there.  Perhaps when I restored Registry.

Things are back to normal now after the last resgistry restore.  Used it for business all day today, thanks everyone.

syhnbuddy
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now