Solved

Help: ORA-01012: not logged on

Posted on 2001-06-27
25
5,735 Views
Last Modified: 2012-06-21
I have
Oracle Standard Edition Release 3 (8.1.7)
installed on
NT Windows 4.0 (Service Pack 6a),
computer: Pentium II 266 Mh, 196 MB RAM.

I have all the network options in Oracle configured.

When I try after installation to install a database with the Database Configuration Assistant
I get the following error: ORA-01012: not logged on.
I tried to install the database with different options
( from CD, Typical, Custom, Dedicated Server Mode...)
but I get always the same error.

Can someone please help me with this.

Saso Zitnik
0
Comment
Question by:sasozitnik
  • 10
  • 5
  • 4
  • +4
25 Comments
 

Expert Comment

by:sunsapollos
ID: 6234129

check install software is ok
check the instance is running or check startup nomount not error.
check user is dba and admin group
0
 

Author Comment

by:sasozitnik
ID: 6234234
I reinstalled oracle several times (typical, custom, with or without Database Configuration Assistant) and there were no problems with it.

If I try to create the database with the script step by step I get the instance running (started with ORADIM). But when I execute: startup nomount, I get the error: feature not enabled, database is in standby mode. And then if I'm trying to create the database I get the error: ORA-01012: not logged on.  

I'm logged as user: Administrator (group: admin and dba)in NT. Also Oracle is correctly configured to recognize the NT user.
0
 
LVL 4

Expert Comment

by:fva
ID: 6234443
I feel you might get low on memory when running DB Conf Assist.
Can you add some memory (at least temporarily) to test for this cause?

F.

0
 

Expert Comment

by:nikhilnk
ID: 6234458
Hi,

Since you have enough RAM and tried enough installation methods, this issue something look like a bug or may a patch is required.

But, you can check some things before giving up,
Find out from installation documentation (if you have any) what default options it is installing ie. Oracle Spatial, JServer or other options. Even during custom installation if you can do the minimal installation without any extra options (mentioned above), you may have a chance.

I have some similar probles with Oracle 8.1.7 Enterprise Edition, I have sorted out by not installing extra features, which is actually never required.

If possible please mention exact error messages and numbers.

Thanks,
bye,
NK
0
 
LVL 4

Expert Comment

by:fva
ID: 6234541
Don't use oradim. Make sure there's no instance running, then startup nomount.
I guess NK is however right; 196 MB should be enough, especially if you have also some VM configured. Oracle recommends at least 200MB of VM.

F.
0
 
LVL 1

Expert Comment

by:ashokskumar
ID: 6234744
Hi,

Verify through control pannel/services whether any services for the database is running and stop them.  

If already you have database services remove it using oradim.

Create fresh database service using oradim

start database service through control pannel/services

Set the oracle_environment for the SID you are looking for,
by SET ORACLE_SID=<SID>

Start the database through svrmgrl/svrmgr30

Ashok.
0
 

Expert Comment

by:sunsapollos
ID: 6236482

startup nomount error lead ora-1012 and create database fail. first apply ashok'method.if not ok,then remove any oracle sevice,remove any oracle database software,remove any regedit for oracle and reinstall it with custom install,remove any new option,for example java and object rdbms(spatial,intermedia,parallel server,http server etc).after install finished,check oracle file attribute is 6751.make -f ins_rdbms.mk isvrmgrl and make -f ins_rdbms.mk ioracle and relink all.run adapters check ipc is ok(maybe Nt no ipc,sorry)
0
 

Expert Comment

by:lolomuros
ID: 6237112
Well, i'm not familiar with oracle in windows, but in solaris i have this error when i try to create a instance but the ORACLE_SID of my oracle user is not the name of the new instance i will create.

Good luck, Lolomuros.
0
 
LVL 1

Expert Comment

by:ashokskumar
ID: 6238991
sasozitnik!

Have you tried it?
0
 

Author Comment

by:sasozitnik
ID: 6240980
I have virtual RAM: 256 - 384 MB

I have deleted the instance with ORADIM, deinstalled Oracle completely, deleted all files on disk.
I couldn`t remove some oracle services in NT, also the user group ORA_DBA was left. In NT registry were Oracle parameters left (can I delete them all without having problems with NT afterwards?).

Then I installed Oracle: custom without all the additional options - at the end I got only 390 MB of installed software.
I didn`t configure the network options. I only created the file sqlnet.ora (sqlnet.authentication_services=(NTS))and the parameter file (dedicated server mode). The NLS_LANG was not set. Administrator account has the group ORA_DBA. Then I executed the following commands:

set ORACLE_SID=orcl
oradim -new -sid orcl -startmode manual -pfile
              "E:\oracle\admin\oracle\pfile\initorcl.ora"
SVRMGR> connect INTERNAL/oracle
Connected
SVRMGR> startup nomount pfile=
              "E:\oracle\admin\oracle\pfile\initorcl.ora"
ORA-00439: feature not enabled: Managed Standby

If I try to create the database I get the error:
ORA-01012: not logged on

I started the OracleServiceorcl in NT and configured it to automatic. Nothing changed.

I configured the network options:
listener.ora
LISTENER =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = server)(PORT = 1521))
  )
tnsnames.ora
BAZA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = server)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = oracle)
    )
  )
Nothing changed.

0
 
LVL 1

Expert Comment

by:ashokskumar
ID: 6241222
Verify the init.ora file.  There may  be some parameters related to Enterprise edition. From the error message, it looks like, there is may by standby database archive desitnation parameters. Since automatic archive and managed standby features are not available in standard edititon, you may change them.  

You can delete all the entries under ORACLE_HOME in NT registery.  This will be again created in next installation.  There is also option to take backup of existing NT registery.

Due to incompatible parameters(init.ora), oracle fails to start the instance.

First we will address the issue of bringing up the database then connecting to the database through sqlplus or through any other client. Listener and tnsnames are used to connect the client with database.  To bring up the database, we we may consider Proper software installation, Oracle service, SET the ORACLE_SID=<SID> , init.ora, directory access and disk space.

Ashok.
0
 

Author Comment

by:sasozitnik
ID: 6243964
I cannot find standby database archive desttnation parameters in my initorcl.ora file. Here is the content of the file:

db_name = "oracle"
instance_name = orcl
service_names = oracle
db_files = 1024
control_files = ("E:\oracle\oradata\oracle\control01.ctl", "E:\oracle\oradata\oracle\control02.ctl", "E:\oracle\oradata\oracle\control03.ctl")
open_cursors = 300
max_enabled_roles = 30
db_file_multiblock_read_count = 8
db_block_buffers = 3233
shared_pool_size = 8830566
large_pool_size = 614400
java_pool_size = 0
log_checkpoint_interval = 10000
log_checkpoint_timeout = 1800
processes = 150
parallel_max_servers = 5
log_buffer = 32768
max_dump_file_size = 10240
log_archive_start = true
log_archive_dest_1 = "location=E:\oracle\oradata\oracle\archive"
log_archive_format = %%ORACLE_SID%%T%TS%S.ARC
global_names = true
oracle_trace_collection_name = ""
background_dump_dest = E:\oracle\admin\oracle\bdump
user_dump_dest = E:\oracle\admin\oracle\udump
db_block_size = 8192
remote_login_passwordfile = exclusive
os_authent_prefix = ""
distributed_transactions = 10
compatible = 8.0.5
sort_area_size = 65536
sort_area_retained_size = 65536
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 1

Expert Comment

by:ashokskumar
ID: 6246562
Modify the parameter
log_archive_dest_1  "location=E:\oracle\oradata\oracle\archive"

to log_archive_dest=E:\oracle\oradata\oracle\archive

0
 

Author Comment

by:sasozitnik
ID: 6251266
Thank you, I have modified the parameter. The error is gone, but there is now another error:

set ORACLE_SID=orcl
oradim -new -sid orcl -startmode manual -pfile
             "E:\oracle\admin\oracle\pfile\initorcl.ora"
SVRMGR> connect INTERNAL/oracle
Connected
SVRMGR> startup nomount pfile=
             "E:\oracle\admin\oracle\pfile\initorcl.ora"
ORACLE instance started
ORA-01012: not logged on

If I try to create the database I get again the error:
ORA-01012: not logged on
0
 
LVL 1

Expert Comment

by:ashokskumar
ID: 6256219
After setting ORACLE_SID=orcl, try for startup
You have created the service, no need create again.

Try in following sequence.
set ORACLE_SID=orcl
SVRMGR> connect INTERNAL/oracle
startup


If you get any error post it.
0
 

Author Comment

by:sasozitnik
ID: 6311114
Sorry for not answering so long - I was on holiday. I will try it now.
0
 

Author Comment

by:sasozitnik
ID: 6311813
I always delete the instance, when I'm finishing trying to create the database with:

oradim -delete -sid orcl

If I try the suggested sequence I get:

set ORACLE_SID=orcl
svrmgrl
SVRMGR> ORA-12560: TNS:protocol adapter error
0
 

Expert Comment

by:sunsapollos
ID: 6313026

 If the error get when start svrmgrl?or connect internal error or startup error?
0
 

Author Comment

by:sasozitnik
ID: 6315963
When I start svrmgrl I get the error:

ORA-12560: TNS:protocol adapter error
0
 

Expert Comment

by:sunsapollos
ID: 6316185

  Have you started oracle service?If not,start it and restart svrmgrl.if yes,check oracle file attribe,it should 6751?if not,modify it or make it.if yes,make network and retry.
0
 

Author Comment

by:sasozitnik
ID: 6405203
I don't understand: "oracle file attribe, it should 6751?"

could you please explaine it more

thank you
0
 

Author Comment

by:sasozitnik
ID: 6405233
I can give only 300 points for one question. Because I desperately need the solution for this problem I made another question under the title:

"Help: ORA-01012: not logged on - 2"

Whoever answers this question will also get the points of the other question.
0
 
LVL 4

Expert Comment

by:fva
ID: 6405344
Did you configure the listener to listen for the instance you are creating?
I had once some similar problems, but they went away after a system restart. I guess it was a mess within the OS network layer or something similar. However, this would suggest that configuring the listener, too, might help.

F.
0
 
LVL 3

Accepted Solution

by:
ramkb earned 300 total points
ID: 6406940
Hi there,

ORA-1012 while startup often occurs b'coz of incorrect NLS_LANG and related parameters in your client.

Check 2 things:

1. Run regedt32 to access the registry.
 
2. Go to the \HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE key.
   
3. Ensure the following values are set with type REG_EXPAND_SZ:
 
      NLSRTL33 should be C:\ORANT\NLSRTL33
 
      ORA_NLS33 should be C:\ORANT\NLSRTL33\DATA
 
*NOTE:  These values assume that your Oracle Home is C:\ORANT.

Also verify that the NLS_LANG parameter under the  
\HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE key is set to the proper value.  The format should be:
 
   <language>_<territory>.<character set>
 
The default value for a U.S. environment with 8-bit character set is:  
 
   AMERICAN_AMERICA.WE8ISO8859P1  
 
Without the NLS_LANG variable set, if the characterset differs from the default characterset, then the database will log you off when it tries to startup.  This is what generates the ORA-1012 error message.

The ORA_NLS33 environment variable allows the database to find the resource files that are used for different character sets.

The 1012 could probably be b'coz of incorrect setting of either of these variables in registry.

Do you have multiple Oracle Home in your registry?
  HOME0, HOME1  (If so, check the NLS_LANG values in each Oracle Home).

Hope this helps..
- Ramesh
0
 

Author Comment

by:sasozitnik
ID: 6412199
Thank you Ramesh, with your help I solved the problem.

The problem was, that in the registry the NLS_LANG parameter had the value (I'm from Slovenia):

SOLVENIAN_AMERICA.US7ASCII

In the Database Configuration Assistant the default value for the character set was: WE8ISO8859P1. I didn't change the default value so the values didn't match.

When I changed the NLS_LANG parameter to:

AMERICAN_AMERICA.WE8ISO8859P1

the installation worked without a problem.

Because I'm from Slovenia I then changed the NLS_LANG parameter to:

SLOVENIAN_AMERICA.EE8ISO8859P2

and in the Database Configuration Assistant I used the character set EE8ISO8859P2 and again the installation worked without a problem.

Again thank you for your solution!

Saso
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Delphi selector screen 2 58
oracle function to get percentge of shelf life remaining 17 45
Oracle Pivot 2 35
SQL Retrieve Values 4 44
Working with Network Access Control Lists in Oracle 11g (part 1) Part 2: http://www.e-e.com/A_9074.html So, you upgraded to a shiny new 11g database and all of a sudden every program that used UTL_MAIL, UTL_SMTP, UTL_TCP, UTL_HTTP or any oth…
From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now