Solved

HELP!  lost my Xwindows

Posted on 2001-06-30
18
264 Views
Last Modified: 2010-03-18
I'm using RHLinux7.1 and i tried to start Xwindows, 'startx' and it gives me the error "/root/.Xclients-default  no such file or directory".  Xwindows will not run.  Is there a utility to run to get Xwindows working again?  Thanks in advance!
0
Comment
Question by:GorGor1
  • 6
  • 5
  • 4
  • +3
18 Comments
 

Expert Comment

by:m931a2
Comment Utility
can you log in as a user?

you can rerun the X setup with Xconfigurator (Xconf then hit tab) this will let you set it up again and rewrite your X config file.

mark
0
 
LVL 1

Author Comment

by:GorGor1
Comment Utility
I can't do anything in Xwindows.  I'm stuck at a shell because Xwin won't load.  Is there a utility I can run from a shell?
0
 

Expert Comment

by:colind
Comment Utility
Yeah,

from the shell, type Xconfigurator ( should be in your path, or /usr/X11R6/bin ).  
0
 
LVL 1

Expert Comment

by:edvinkv
Comment Utility
run XF86Config and choose the correct parameters.

This will configure your x-windows for startup.

Thanks
Edvin.
0
 

Expert Comment

by:praka_v
Comment Utility
hi gorgor1
   first try that ur kernel is making boot with xwinows general the RH 7.1 starts with xwindows
or go to command promt and type setup know u can configure the x windows and probe ur vga card and after probing
qiut the sesion and restart ur system i hope now u can go directly in to xwindows
0
 
LVL 1

Author Comment

by:GorGor1
Comment Utility
my "/root/.Xclients-default" file is completely gone.  xwindows will not load since that file is missing.  Running XF86Config doesn't replace that file.  How do I fix this?  Maybe it isn't even an XF86Config problem??
0
 

Expert Comment

by:aminf
Comment Utility
hello
I'm using redhat7.1 and running X but
I haven't that file and everything works well.
Xconf* is used to set parameters related to ur graphiccard and ur monitor .
but  ur error is  due to another problem ,i think .
change ur runlevel to 5 and see wether u can login using xdm or not and tell me the result

0
 
LVL 1

Author Comment

by:GorGor1
Comment Utility
here's a dumb question....how do I do I change runlevels?  I've done it before but I don't remember how I did it
0
 

Expert Comment

by:m931a2
Comment Utility
at the lilo promt put the name of your kernel and the number that you want.

lilo: linux 5

the do it for good go it to /etc/inittab and look for id:3:initdefault the 3 in this example is my run level. Just change it as root to 5 and restart.


Mark
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Author Comment

by:GorGor1
Comment Utility
I used the command "init 5" at the initial command prompt.  KDE is not letting me log in as root, but YES, x-windows IS now working.  There must be something wrong with runlevel 6.  Any ideas what that '.Xclients-default' file does or how I can restore it?
0
 

Accepted Solution

by:
colind earned 50 total points
Comment Utility
I had the same problem...  X was complaining that .Xclients-default was missing.  The solution ended up being to just delete a bunch of files in my /tmp directory.  When it happened to me, I could get into X as root but not as a normal user.   I couldn't find any Xclients-default file in root's home directory either so I don't know what was up with that.

So, try going into you /tmp directory in a plain shell (no X running or anything) and just delete everything, reboot into runlevel 6 and see if you can get in.  Worked for me.
0
 
LVL 1

Author Comment

by:GorGor1
Comment Utility
i have the files .font-unix, .X11-unix, .ICE-unix, and the directories kde-root, mcop-root, ksocket-root, and orbit-root in my /tmp directory.  You really think I should delete them??
0
 

Expert Comment

by:colind
Comment Utility
Probably not if you are in X.  If you are in a plain shell (i.e. no X running underneath or on top or anywhere) then it should be safe.

I forget the exact name of the files that were causing me problems (this happened a couple weeks ago) but there were about 10 files with very similar names - lockfiles of some kind I'm guessing.

Anyhow, I think the worst that can happen by deleting a file in /tmp is that a program crashes.  It should start up fine the next time because no program expects files to exist in /tmp on startup...  only while they are running...  Know what I mean?

Colin

0
 

Expert Comment

by:colind
Comment Utility
Probably not if you are in X.  If you are in a plain shell (i.e. no X running underneath or on top or anywhere) then it should be safe.

I forget the exact name of the files that were causing me problems (this happened a couple weeks ago) but there were about 10 files with very similar names - lockfiles of some kind I'm guessing.

Anyhow, I think the worst that can happen by deleting a file in /tmp is that a program crashes.  It should start up fine the next time because no program expects files to exist in /tmp on startup...  only while they are running...  Know what I mean?

Colin

0
 
LVL 1

Author Comment

by:GorGor1
Comment Utility
I did it and I'm getting the same problem....hmmmmmm....I don't know what to do now
0
 

Expert Comment

by:colind
Comment Utility
Probably not if you are in X.  If you are in a plain shell (i.e. no X running underneath or on top or anywhere) then it should be safe.

I forget the exact name of the files that were causing me problems (this happened a couple weeks ago) but there were about 10 files with very similar names - lockfiles of some kind I'm guessing.

Anyhow, I think the worst that can happen by deleting a file in /tmp is that a program crashes.  It should start up fine the next time because no program expects files to exist in /tmp on startup...  only while they are running...  Know what I mean?

Colin

0
 

Expert Comment

by:m931a2
Comment Utility
try making a file called /root/.Xclients-default and adding the line exec gnome-session to the file and restart X. If you are not running gnome then put in what ever window manager that you are using.
0
 

Expert Comment

by:m931a2
Comment Utility
for kde i think its startkde. not sure as i don't use it.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
BIND rate-limit - DNS for web server requests 29 112
Cron jobs 12 86
Linux Hanging with disable Error Output 4 69
Issue to mail 11 36
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now