• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 663
  • Last Modified:

MS Excel: Hiding zero rows in Pivot Tables

I am looking for a way to hide zero rows in pivot tables. This would need to work for tables that change monthly.
0
mblanken
Asked:
mblanken
  • 4
  • 3
  • 2
1 Solution
 
criCommented:
Is Tools|Options|View: Clear 'Zero values' an option ?
0
 
criCommented:
Remember that this option is set for each worksheet
0
 
mblankenAuthor Commented:
Unfortunately no, I need to be able to hide these rows, prederably automatically. It seems as though this could/should be an option provided by Excel.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
criCommented:
Try with double clicking the applicable Pivot field header button. A dialog should pop up. Select hide item 0.

If this produces the wanted result, if should be possible to automate this with a macro. Unfortunately the expert 'antrat' is dormant and, regarding Pivot Tables, I am a beginner.

0
 
q2eddieCommented:
To, cri:

I tried that suggestion.  It appears to work only if one of the pivoting elements is a zero.  Also, I have a pivottable (customer vs time-of-day-usage) where there are no zero pivoting elements.

Hmmm....  no quick and easy option, Nuts.

Hi, mblanken.

#Questions
1. Is this to be an automated process?
2. Does the example given below have the _effect_ that you wanted?
3. How close is this result to what you had in mind?

#Try This
a. If your pivottable's upper-left corner is in cell A1, then insert a blank row before it.
b. In the now-blank cell B1, type "+B3" (without the quotes).
c. Copy this formula to all the cells in row 1 for the length of your pivottable.
d. Now click on b1 and goto Data->Filter->AutoFilter.
You should see little down-arrow buttons in almost every cell in row 1.

To limit the pivottable display to show only non-zero rows, then ...
a. Goto the "GrandTotal" cell in row 1.
b. Click the down-arrow button and select the "Custom" item.
You should see a "Custom AutoFilter" dialog appear.
c. Set the first combobox to "does not equal".
d. Type the number zero into the combobox on its right.
e. Click OK.

#Comment
I think that you want something close to this - but not this exactly.

Bye. -e2
0
 
mblankenAuthor Commented:
I'm familiar with this and that doesn't work. I've asked Mrexcel.com about this problem and he has not found an answer either. He refered me to this site.
I appreciate your efforts.
0
 
q2eddieCommented:
To cri:

I went to mrexcel.com and found out what you're talking about.  Wierd, I don't have that checkbox on my "data-item" dialog in the PivotTable Wizard.  Perhaps, I'm using an earlier version then he is.

Me: Excel 97

Bye. -e2
0
 
mblankenAuthor Commented:
To e2 and cri,

e2 - Your solution appears to work as an interim fix. Still wish MS would provide an option to hide zero data in a pivot table.

Thanks to both.

mblanken
0
 
mblankenAuthor Commented:
Regarding your last comment, yes it is close and does work ok but, I still would like as an option in pivot table set-up.

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now