Allowing users to access ntfs partitions & fstab

Posted on 2001-07-02
Last Modified: 2013-12-15

I am a newbie to linux and I have installed Linux Mandrake 8.0.  I am using /etc/fstab.

Within the fstab script I have several entries such as:

/dev/hda1 /mnt/win_c ntfs defaults 0 0
/dev/hda5 /mnt/win_d ntfs defaults 0 0
/dev/hda6 /mnt/win_e ntfs defaults 0 0

When I run the above script only the root user is allowed to access the partitions and no other users!!!

if I change the entries to say:

/dev/hda1 /mnt/win_c ntfs user,exec, umask=000

Then this still does not allow any users to access the win_c partition.

Additionally, if I try to make the modify the 'win_c' directory so that it is accessible to all (user, group & others) then it does not update!!  I believe the drive is read-only.

My problem is as follows:

How can I make my  partitions available to all users
How can I make the partitions read & writable for the users!

Any information would be gratefully received.

Thanks in advance.

Question by:david_d
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2

Expert Comment

ID: 6246490
you can not if it is ntfs, ntfs is supported as read only, unless you wanna live on the wild side and in that case build  2.4.5 kernel, it will give your write capability.  I can tell you that is is not stable and already crashed my box, but i was just playing around.

Author Comment

ID: 6250505

So how could I just access the ntfs partition for all users?  I only have 2 users on my PC 'root' and 'David'

An example would be very useful.

Many thanks.

LVL 12

Expert Comment

ID: 6252898
you need to use the uid and gid params of mount to pull that one off, or maybe use "mode" to set the mask
LVL 12

Accepted Solution

j2 earned 60 total points
ID: 6252913
with only two users tho, just create a group called ntfsaccess, in /etc/group add


then use the gid=WhateverGIDyouusedforthegroup to mount it.

Author Comment

ID: 6257415

your answer worked perfectly.

Many thanks.


Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question