Solved

Novell Netware - Changing adapter speed

Posted on 2001-07-03
11
663 Views
Last Modified: 2008-02-01
Hi

I am trying to change the network adapter speed from 10Mbs to 100Mbs.  The network adapter card is an Intel Ether Express Pro/100UTP 100 Base and is currently connected to the network via a BNC connection.  I wish to change this to good old RSJ-45 and bump the speed up to 100Mbs (I have just upgraded the hubs to 100Mbs and hence want to use the new speed).  How to I go about changing the Netware settings to reflect these changes?  (Novell Netware version 5.0)

Thanks for any help in advance.


Ian Swatton
0
Comment
Question by:microdrainage
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 10

Accepted Solution

by:
tonnybrandt earned 200 total points
ID: 6248166
On the console run
inetcfg
choose boards
choose the correct board and press enter
Move the cursor to the line
Manual Select 10/100 Mb, Full/Half Duple:
Here select 100/full or auto.

I don't think you need to do anything else.
0
 
LVL 2

Expert Comment

by:melchioe
ID: 6249157
If you're editing the autoexec.ncf file directly, here are some tips:


PRO/100+ TX adapter (100 Mbps full duplex):
FORCEDUPLEX=2 SPEED=100

(1 half duplex, 2 full duplex)

note: The PRO/100B T4 adapter does not support full duplex at 100 Mbps, nor does the T4 adapter support Auto-Negotiation, or Nway. The EtherExpress PRO/100+ TX adapter does not have any of these limitations.



The full contents of the parameters for the LOAD command for the INTEL ethernet adapters are at  (and the above shamelessly copied from):

http://support.intel.com/support/network/adapter/pro100/23717.htm
0
 

Expert Comment

by:MG
ID: 6249671
I would only work in Inetcfg if possible. The Intel cards we use are configured under "Boards" in Inetcfg. They use 0, 1, or 2 for duplex (0=auto, 1=half, 2=full) and the same for speed (0=auto, 1=10, 2=100). Make sure that you have the same setting for both the network card and the switch/hub. Both speed and duplex must match for both devices. If one is set for auto and the other is set for full, it may drop back to the least speed and duplex. This seems to effect duplex more than speed. Some hardware cannot run properly at 100/full. So you may try dropping back to 100/half even if auto-negotiation setting it to 100/full. If it is flakey.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 2

Expert Comment

by:melchioe
ID: 6250165
MG, you might want to consider in the future offering comments rather than answers unless you are absolutely stone cold certain that you have the first complete, full, and unarguable answer.  Since most of what you said was previously posted, and is also in a tentative tone ("if possible", "may try"), it seems to be more a comment than a full answer.  

Just my $.02.  YMMV.
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 6253981
A word of caution regarding using Full vs. Half Duplex on your network:

If your NIC supports Full and your Hub/Switch supports Full -AND- you switched the configuration to Full Duplex, you may have data corruption on your hard drives IF:

1)  Your hard disk subsystem is not quick enough to support reads and writes to keep up with Full Duplex
2)  Your server does not have sufficient RAM to cache reads and writes
3)  Your server is being used heavily (lots of read and writing)

I had a Compaq ProLiant 1500 (Pentium 90 with 180MB RAM with a Fast-Wide SCSI disk subsystem) - when I placed an Intel EtherExpress PRO/100+ Server Adapter into the server and set it to Full Duplex my accounting users were getting corrupted data.  The server was holding a direct-connect COBOL-based database with nearly 50 users hitting the data files at a high rate.  The poor server hardware could not keep up with the NIC.  I had to set the NIC to Half Duplex (which fixed the problem) - btw: it was NetWare 4.10

Not expecting any points - just wanted to warn you about the problems you could encounter if the rest of your server is not up to speed.
0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 6297928
Any progress ?.
0
 

Author Comment

by:microdrainage
ID: 6298567
Sorry I haven't got back to you, I've tried using inetcfg, and there is no setting for the speed.  This is probably due to the fact that I may have given you duff info.  The board name is reported as being 3c90x_1 (driver 3c90x) which to me looks like a 3 Com board.  The paperwork for the machine stated the board was a intel board, but now I'm not sure - when I can down the server I'll take the case off and have a look!

Thanks for your help.

Ian

PS (Tonny if you want the points for your orginal comment (as I hadn't used this tool before) there yours!!!)
0
 
LVL 2

Expert Comment

by:melchioe
ID: 6299159
You can still put the FORCEDUPLEX and SPEED commands on the LOAD command, even if intecfg doesn't like it.  I may be wrong, but I don't know of any 3c90x cards that do not do 10/100 and full/half.  Also, my experience is they do not autonegotiate in a Netware server.

Look in etc\netinfo.cfg for the appropriate LOAD line.
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 6299419
melchioe - better check your switches then - my 3C905B-TX cards fully autonegotiate just fine under NetWare 4.2 and 5.1... <grin>  however, you should not modify the netinfo.cfg line by hand - use INETCFG for that.

Microdrainage - MG has the right answer above.  Also, there is a 3C90XCFG.EXE utility that you run from the DOS prompt to set the speed and duplex type on the 3Com 3C905 cards if you want to force it at the hardware level.

0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 6435923
Any progress ?.
0
 

Expert Comment

by:ComTech
ID: 6437966
This question has become out of date and abanded and brought to our attention in CS.

This question will be awarded to tonnybrandt

Thanks,
ComTech
Community Support

User agrees.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
The recent Petya-like ransomware attack served a big blow to hundreds of banks, corporations and government offices The Acronis blog takes a closer look at this damaging worm to see what’s behind it – and offers up tips on how you can safeguard your…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question