Solved

AIX: mounting filesystems

Posted on 2001-07-03
11
2,061 Views
Last Modified: 2012-05-04
I have an annoying startup problem. We are running all kinds of AIX 4s (4.1.5 - 4.3.3). AT startup we are mounting a couple of filesystems (one of the entries from /etc/filesystems:

/home/ep1/cron_reposit:
        dev             = "/home/ep1/cron_reposit"
        vfs             = nfs
        nodename        = earth
        mount           = true
        options         = bg,hard,intr,timeo=3,retry=3
        account         = false
)

Now although we are setting the timeout and the retry value for the mount, it takes always 10 minutes or so for each filesystem that is not available. Because of our strange configuration (no automount, local build directories) a restart of the servers after a power outage takes veeeeery long, since the clients we have to mount are not up yet.
Does anybody have a clue how to fix that problem?

I will be out for the rest of the week, but I promise to get to you ...

======
Werner
0
Comment
Question by:griessh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +1
11 Comments
 
LVL 4

Expert Comment

by:newmang
ID: 6250741
Werner

The problem is that you use a "hard" option which dictates that the mount does not return until the operation succeeds and you infer a fg option (default) which means that the mount operates in foreground if the first mount attempt fails.

You could either change hard to soft so the mount returns an error if it fails then retry the mount manually or explicitly code the bg option so the mount continues in background if the first attempt fails.

Refer to the mount man page

Cheers - Gavin
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6251547
as newmang said: use soft instead of hard
It also prewvents your hanging your server if the mounted fs is temporarily unavailable ;-)
0
 
LVL 11

Author Comment

by:griessh
ID: 6252877
Thanks newmang

As I said I am out of office until Monday, but then I'll try it. Everything you explain sound reasonable.

======
Werner
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Author Comment

by:griessh
ID: 6265673
The 'fg' is the default, but as you might see, I am actually using the 'bg' option.

The 'hard/soft' sounded intrigueing, but the behaviour doesn't change. Even with

 options = bg,soft

the system hangs if the other system is powered down. I looked up man pages for "mount" and "filesystems" and was surprised that the "filesystems" doesn't tell me about the "options" attribute (although these options show up right when I run the 'mount' command).

Any more ideas where to look at?

Thanks
=======
Werner
0
 
LVL 4

Expert Comment

by:newmang
ID: 6267239
I'm sorry, I read into your post that the problem was when your system started up and the NFS server was not available. In these cases the soft and bg options do apply.

These options apply to the mount command and therefore would not apply once the mount has completed and the server then went down which is the situation your later posts infer.

In these situations it would depend on the nfs client timeout variables, I've looked through smit and can't find a reference to nfs client timeouts. I suspect you'll have to find an NFS reference for more info if no-one else posts anything here

Cheers - Gavin
0
 
LVL 11

Author Comment

by:griessh
ID: 6267463
Gavin

I think you were right in the beginning. Let's just set up a scenario:

It is Monday morning, I am firing up my AIX system called 'neptune' (I usually shut down for the weekend). My neighbor box 'earth' is still down (I am the first one to come in :-).
The 'mount all' command is started from the /etc/rc file. According what you and the man pages tell me, by changing the 'options' in my stanza in rc to 'bg,soft', I should not see the 10 minute wait for /home/ep1/cron_reposit failing to mount. But that is exactly what happens. It looks like mount doesn't care about fg/bg and hard/soft. The disturbing part is I saw that under 4.1.5, 4.3.2 and now under 4.3.3 again. I just thought somebody might have the same problem ... and knows where to tweak the mount.

======
Werner
0
 
LVL 11

Author Comment

by:griessh
ID: 6267465
Oh, BTW, the fileserver doesn't behave any different than these clients ...

======
Werner
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6269725
simple question: did you restart the NFS server after changing to  bg,soft ?
0
 
LVL 11

Author Comment

by:griessh
ID: 6270202
simple answer: shutdown -Fr :-)
0
 
LVL 11

Author Comment

by:griessh
ID: 6783560
I will ask CS to PAQ this question now.

Several people tried to solve that problem (it's not my problem only anymore ...) but none of the option work. My workaround is:


In the /etc/filesystems I only set local filesystems
mount=true

For all external filesystems I created a new
type=remote_server

Since 'mount all' is run from rc (that is of action type 'wait' in inittab) the initial mount process works without problems. I created a new entry in inittab 'mount' of action type 'once' (could also be respawn) to call a script that does the 'mount -t remote_server'. This script is able to run in the background.
This way you get to your login prompt even if the box is still waiting for remote systems.

======
Werner
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 6784140
points reduced to 0 and placed in PAQ.
Thank you
Computer101
Community Support Moedrator
0

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
I have been running these systems for a few years now and I am just very happy with them.   I just wanted to share the manual that I have created for upgrades and other things.  Oooh yes! FreeBSD makes me happy (as a server), no maintenance and I al…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question