Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Setup and deployment errors

Posted on 2001-07-05
10
Medium Priority
?
406 Views
Last Modified: 2013-11-13
I have written a MapX program in VB6 on an NT workstation (Mapinfo solutions language).  

The application was packaged and deployed using the VB package and deployment wizard.  The application installs and runs in Windows 95, 98 (Edition 1) NT and 2000.  The problem occurs when I tried to install onto a 98 Edition 2 machine.  The machine was a new machine, and I encountered the following errors:

"Cannot start main setup program! (CreateProcess() returned error code 0x000000C1H)"


Then when you press ok it says
"Setup will now start the application removal utility to remove temporary installation files"

Press ok again and another error occurs:
"Error attempting to run the application removal program to remove temporary installation files"

Does anyone have any solutions to the problem.  I have tried to get an anser from Mapinfo, but it is not a MapX problem.

Thank's in anticipation.
0
Comment
Question by:polobear
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 7

Expert Comment

by:Inteqam
ID: 6255149
did you try on more than one machine ?
0
 

Author Comment

by:polobear
ID: 6255156
Yes we tried on 4 different Windows 98 Edition 2 machines, some older than others in terms of hardware!
0
 
LVL 7

Expert Comment

by:Inteqam
ID: 6255163
actually i am thinking in security and authorization wise, do you have the permission to install on the machines, and do they have enough hard disk space.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:polobear
ID: 6255175
Yes there was plenty of hard disk space (3 Gb for a 60mb program), and there was no requirement for permissions as it is a windows 98 machine.  I sucessfully installed the other software that it compliments, it is just that packaged with VB that has the problem.
0
 
LVL 7

Expert Comment

by:Inteqam
ID: 6255188
0
 
LVL 7

Accepted Solution

by:
Inteqam earned 900 total points
ID: 6255203
0
 
LVL 8

Expert Comment

by:Dave_Greene
ID: 6255845
Not positive but I think this is caused by the deployment machine not having a Temp directory specified.  try creating a directory "C:\Temp" and run the install again.
0
 
LVL 8

Expert Comment

by:Dave_Greene
ID: 6296169
What's the word on this?
0
 

Author Comment

by:polobear
ID: 6297152
I have checked with the users, and there is both a temp directory in the windows, C and D drives of the machine.  The error still comes up, which is annoying~!
0
 
LVL 49

Expert Comment

by:DanRollins
ID: 7148100
Hi polobear,
It appears that you have forgotten this question. I will ask Community Support to close it unless you finalize it within 7 days. I will ask a Community Support Moderator to:

    Accept Inteqam's comment(s) as an answer.

polobear, if you think your question was not answered at all or if you need help, just post a new comment here; Community Support will help you.  DO NOT accept this comment as an answer.

EXPERTS: If you disagree with that recommendation, please post an explanatory comment.
==========
DanRollins -- EE database cleanup volunteer
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The debugging module of the VB 6 IDE can be accessed by way of the Debug menu item. That menu item can normally be found in the IDE's main menu line as shown in this picture.   There is also a companion Debug Toolbar that looks like the followin…
If you have ever used Microsoft Word then you know that it has a good spell checker and it may have occurred to you that the ability to check spelling might be a nice piece of functionality to add to certain applications of yours. Well the code that…
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
Show developers how to use a criteria form to limit the data that appears on an Access report. It is a common requirement that users can specify the criteria for a report at runtime. The easiest way to accomplish this is using a criteria form that a…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question