Transparent and treeview

Hi EEs:

This is the scenario:

I have a treeview and imagelist controls.
Imagelist is loaded with transparent gifs images.

Why those images haven't transparent background when are seeing on treeview?

Thanks

LVL 16
Richie_SimonettiIT OperationsAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
TheRedGuyConnect With a Mentor Commented:
Dunno, can you not just convert the gifs to icons?
0
 
CesarGonCommented:
You have to set the ImageList's MaskColor property to the color in your GIF images you want to see as "transparent" when used on the TreeView. It won't take the transparency settings of the GIF files.

Best,
Cesar.
0
 
VincentLawlorCommented:
What colour is the background when they are in the TreeView ?

If it always the same then in your image list control
in the Color tab change the mask color to the color of the background.

Hope this helps
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
VincentLawlorCommented:
In your ImageList load the gif images and set the mask color to the background color that it appears as in the imagelist (usually black). Make sure the UseMaskColor option is checked.

The pictures should now appear as transparent in your TreeView.

Vin.
0
 
Richie_SimonettiIT OperationsAuthor Commented:
Well, i already tried Usemaskcolor property without solve the problem.
VincentLawlor, i would reject your answer until i have received more input from others EE.

At the momment of posting question, i had this:
All Gif background are &HFF00FF (Nice color, isn't it?) and all are 256 color depth, loaded to imagelist at design time.
Maskcolor = &HFF00FF
UseMaskColor=true

By the way, i am working with those controls from within VBA.

Thanks for yours comments, i am waiting...
0
 
Richie_SimonettiIT OperationsAuthor Commented:
TheRedGuy, your comment is close enought.
I would like to know why it doesn't works with gif.
0
 
Richie_SimonettiIT OperationsAuthor Commented:
I don't like to use BMPs simbce they are so heavy. I was using gif instead for that reason.
Ico files are less weight than BMP and it works.
TheRedGuy you have the answer. Thanks
0
All Courses

From novice to tech pro — start learning today.