Solved

workspace.EditDocument in 4.6.7

Posted on 2001-07-06
7
247 Views
Last Modified: 2013-12-18
When using notesuiworkspace.editdocument(false,doc,false) in 4.6.X client I get an error saying" You are not an allowable author of this document". I am trying to open it in read mode but the script seems to be oblivious of this. In 5.x clients this works real fine. I have a workaround here of going via a ws.opendatabase, ws.currentview.selectdocument etc ... But there seems to be no notesuiview.close method. Any ideas on how to put the document in edit mode w/o keeping the via open in the background?


Thanks
Pronam
0
Comment
Question by:pronam
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 6260532
Try
notesuiworkspace.editdocument(False,doc,True)

~Hemanth
0
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 6260544
Continuing..

The editdocument method tries to open the document in edit mode that is why you are getting the error. If you are not an author for the document then this problem will arise.

~Hemanth

0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6260868
Listening..
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:pronam
ID: 6263391
hmm... that doesn't work hemanth. the tragedy is R5 client it works --- it opens in the read mode. The first and the third parmeter(false in both case) tells domino to open it in read mode. R 4.6.7 seems to be a little stubborn ---
I have tried and gone via the notesuiview - that works. But why is here not uiview.close in uiview?
0
 
LVL 24

Accepted Solution

by:
HemanthaKumar earned 100 total points
ID: 6265152
Good question ;-)

I don't have answer why Lotus hates uiview.close !

Coming to your problem, Does the form that opens the document has "Automatically enable Edit Mode" set !

Check this technote, Lotus says it works.
http://support.lotus.com/sims2.nsf/eb5fbc0ab175cf0885256560005206cf/84608c2d68f2298b852568fe005c0dd6?OpenDocument

~Hemanth



0
 
LVL 63

Expert Comment

by:Zvonko
ID: 10476277
pronam,
No comment has been added lately (964 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to HemanthaKumar http:#6265152
Please leave any comments here within 4 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

Zvonko
EE Cleanup Volunteer
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

For users on the Lotus Notes 8 Standard client, this article provides information on checking the Java Heap size and adjusting it to half of your system RAM in attempt to get the Lotus Notes 8.x Standard client to run faster.  I've had to exercise t…
I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…
Suggested Courses

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question