Installing of RedHat Linux on NT4.0 system...

Posted on 2001-07-07
Last Modified: 2013-12-15

I have a laptop currently running Windows NT 4.0.  I would like to install RedHat Linux 7.0 on this laptop. I intended to clean the NT OS so I don't care about the current contents. I have the Linux CD with me but it's of a Linux/Unix format. I don't know how to invoke the Linux installation program as there isn't a setup.exe or any Windows executable to start the installation from within Windows. I eben tried to load the CD in the CD-ROM and changed the laptop's BIOS to boot for the CD-ROM drive but that didn't have any effect. The boot process detected an installation of NT and picked that on for the boot.

Please advance on how I can start the Linux install.

Question by:baigmz
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
LVL 17

Accepted Solution

dorward earned 75 total points
ID: 6262518
I would suggest that you grab a copy of Red Hat 7.1 if possible, there are a lot of bug fixes.

If the CDs refuse to boot then you need to make boot floppies.

You will find disk images in the images directory and a program called rawrite.exe in the dosutils directory. Use rawrite to transfer the boot.img image to floppy disk.

Then boot from that floppy with the first CD in the drive.

Author Comment

ID: 6263338
I'll try this on Monday 7/9th and let you know. Thanks!

Expert Comment

ID: 6270903
go to d:\dosutils if your cdrom letter is a d: and type autoboot
this should fire up the installation my friend.
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users


Author Comment

ID: 6271046
Thanks. I'll consider this approach as well. I haven't started this yet but will let you guys know the outcome as soon as I am done. Should be before the end of this week.


Author Comment

ID: 6278606

I called the autoboot from my RedHat 7.0's CD...I got these results...


D:\dosutils>loadlin autoboot\vmlinuz initrd=autoboot\initrd.img
LOADLIN v1.6 (C) 1994..1996 Hans Lermen <>

CPU is in V86-mode (may be WINDOWS, EMM386, QEMM, 386MAX, ...)
You need pure 386/486 real mode or a VCPI server to boot Linux
VCPI is supported by most EMS drivers (if EMS is enabled),
but never under WINDOWS-3.1 or WINDOWS'95.
(However, real DOS-Mode of WINDOWS'95 can have EMS driver with VCPI)
If loading via VCPI you also MUST have:
  1. An interceptable setup-code (see MANUAL.TXT)
  2. Identical Physical-to-Virtual mapping for the first 640 Kbytes

Your current DOS/CPU configuration is:
  load buffer size: 0x00000000     , setup buffer size:  0x3E00
  total memory:     0x00100000
  CPU is in V86 mode
  SetupIntercept: NO
  stat2: cpu_V86, but no VCPI available (check aborted)
  input params (size 0x002B):
    autoboot\vmlinuz initrd=autoboot\initrd.img
  LOADLIN started from DOS-prompt
WARNING: Not enough free memory (load buffer size)

Expert Comment

ID: 6278727
get a window98 startup disk, start the laptop with that, choose the first option which is starting with cd-rom enabled, then, repeat the autoboot, and it better work this time.
Ps.  did you say you want or don't want to keep your NT OS?

Expert Comment

ID: 6278841
get a window98 startup disk, start the laptop with that, choose the first option which is starting with cd-rom enabled, then, repeat the autoboot, and it better work this time.
Ps.  did you say you want or don't want to keep your NT OS?

Author Comment

ID: 6278863
I won't mind loosing the NT OS but I would prefer to have booth NT and Linux on the same machine if possible. I have Windows 2000 actually.

Expert Comment

ID: 6285802
did you try the win98 disk? I tried that on my machine dur weekend and it worked.  how about U

Author Comment

ID: 6286073
Thanks, I'll let you know soon.

Featured Post

Stressed Out?

Watch some penguins on the livecam!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question