Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Win2k Security Settings

Posted on 2001-07-09
4
Medium Priority
?
169 Views
Last Modified: 2010-04-13
I have a strange thing on my WIN2K system.  When I go to My Computer and right click on the drive, I
click on  sharing and set it not to share the drive. When I reboot, it sets itself to share.  I turn
it off again, but upon reboot it is again in permit sharing. I set sharing to 0 persons,and it automatically
goes back to 10persons.
Thanks in advance for any help provided,
Jon
0
Comment
Question by:aloner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 10

Accepted Solution

by:
blohrer earned 400 total points
ID: 6265097
This is a default function of WindowsNT/2000.  What you probably see shared is c$, this the administrative share.

The easiest way to stop the sharing, even after reboot is to:

Go to Control Panel -> Administrative tools

Open the Services icon

Scroll down to the Server service

Click STOP to stop the service immediately.

You will get a message about stopping the Computer Browser service.  Say Yes.

Set the startup type to Manual.

Now the C$ share, or any shares for that matter will not be available.  

If you want to restart the service to share something, you can go to the services icon, double click on the Server service and click start.
0
 
LVL 4

Expert Comment

by:arminl
ID: 6265112
I guess the sharename is c$? If so, forget the share, it's just convenient for administrative purposes and can be disabled via a policy. No one except an Administartor is allowed to connect, so there is no security risk. Let me know it you still want to disable the share and I'll guide you through the policy setting.

If the name is not c$, foget this comment :-)

Armin
0
 
LVL 5

Expert Comment

by:matt023
ID: 6266700
"No one except an Administartor is allowed to connect, so there is no security risk." -- what if someone finds out the local admin password or has a higher priviledge?  In addition, the whole world knows that the default administrative share for the c: is c$.

Try changing the name c$ to something else (ie. cloud$).  
0
 

Author Comment

by:aloner
ID: 6267467
Blohrer's answer solved my client's problem.  
Thanks again!
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
While opting for any web-to-print solution, you need to discuss with your team and some of your end users and know their opinions about your decisions. In this article we list down some questions you need to ask yourself.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question