Very good one, guys!!!

If I SHUT DOWN my PC with the usual Win98SE clics, wait for about 15 sec and restart it, everything works fine.

If I choose to RESTART it instead, with the same usual Win98SE clics, my system hang while booting. Hard boot (reset), safe mode, shut down, wait, restart... and everything return to normal...?!?...

The only suspicious thing is my IDE ATA-33 4.3GB Fujitsu MPC3043AT hard drive. It's the second (handy) hard drive on my system, not my primary master one. No matter if configured as a slave on primary channel, as a master or a slave on the secondary channel, with the jumper setting ok for each position, the problem still persist.

My cables are ok, the BIOS detect the drive each time, both channels are activated, the drive is formatted and partitionned by the book. As a matter of fact, everythings ok since my drive works when I "cold boot" my system. So, what's wrong??? First time I've seen this one...

Thanks for the support!!!
Who is Participating?

Improve company productivity with a Business Account.Sign Up

ComTechConnect With a Mentor Commented:
No activity, no definitive answer.  This question will move to PAQ.

Community Support Moderator
y2polAuthor Commented:
By the way, when the drive is removed, everything (shut down AND restart) works great...
A puzzling case, indeed.

Do you have or can you borrow yet another drive?  Put it in place of the trouble-maker.  If the system behaves the same, you likely have some bizarre BIOS or Win chipset driver issue that will never be resolved.  If the system works perfectly, then some bizarre aspect of your Fujitsu drive is either malfunctioning or causing some conflict.  The choices can be narrowed down if you can test a different drive in the system.


PS - Is this drive SMART capable and is SMART enabled in system BIOS?
Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

y2polAuthor Commented:
To Margarity:

Tried with SMART enable AND disable. Same problem. Told you, everything been tested ( aday long case...).

But your idea is worth a try!!! Thanks!!!
wlennonVP of Domestic & Int'l OperationsCommented:
If you second hard drive has an operating sysetm on it, this could be your problem.  If so, save all your files you want to keep to the New hard drive, and refomat the old one.  Then go to BIOS and run auto detect for your HDD's.  If it recognises it, just transfer you data back on the old one, and run Scandisk and Defrag on both.

If there is no Operating System installed (windows or such) the Boot up as usual, go strait to Bios and do auto detect.

You can also look from the device manager and click on a drive, go down to properties and see if DMA is checked.

Do you have the HD set to AUTO in the CMOS setup?
If so then try setting the 4.3GB Fujitsu to user defined and see what it does then.
I think that the fujitsu drive has a problem. It does not do a proper soft reset, and that is why you are having these problems.

Other option is a power supply problem, or an incompatability of fujitsu with your IDE controller.

Have you tried using the fujitsu by itself , or in another machine ?

I hope this helps !!
What kind of ide cable are you using to connect the drives?
i would say that u remove all the major ide products /otherhardware form windows control panel ->
system .

then reinstall the ide ata driver (newest version )for ure motherboard and reinstall the devices using latest drivers
MurpheyApplication ConsultantCommented:
Try the reset button on your system.
If the pc starts normal then it is a hardware or setup problem, when it also gives problems then you know that you need search for a software solution.
Let me (us) know.

Good luck
I have had it now.  I asked, I pleaded, and I warned you, DO NOT Block questions.

Community Support
Aland CoonsSystems EngineerCommented:
Problems of this type generally relate to the reset time of the IDE HD in questions. When you hard reset or cold boot the system takes longer to POST and gives the HD time to do its own reset but "quick" reset of a restart command doesn't allow enough time.
Suggestion: On my system I set the BIOS to count RAM at every startup to give the drives time to ready themselves for a boot.

Just out of curiosity.....

Do you have an anti-virus software running.....which one?

I once had a problem when shutting down the computer where it stays for a long time without shutting down and turned to be solved through some settings in Norton antivirus which I run on my computer.

tdaoud, I removed the others.  It happens, not to worry.

Community Support
I would like to take a slightly different tact for this problem.  Where exactly does the machine lock up?  Is it during the POST process, or after windows has started to reboot?

Also, try holding the "Shift" key down before you push yes at the restart screen -- this should force a quick reboot that skips the POST process.  Does it still lock up?

I would like to verify that this is not a software problem before looking more closely at the hardware.  I have seen several problems of this nature with Win98SE that have turned out to be software issues.


Josh Elson
Fujitsu has had FIRMWARE issues with some of its recent hard drives; check their website to see if yours is affected.  Also, check the jumper on the OTHER drive, it may be "parked" (a lot of IDE drives are only "master" if a "slave" is present, so they come with the jumper in the "null" or parked position.)  To be able to more accurately address this sisue, we would need to know what type/make/model of hard drive the other one is, as well as what type/make/model of system board.  Post this info, and we may be able to help.---Fitz
Alandc has the simplest answer

The boot sequence is addressing the harddrive, BEFORE the drive has spun up to running speed..

You need to put a delay into the boot sequence...

If you don't know how to adjust your BOIS settings for this...Just let the ram count out completely, and the delay will let the drive spin up
Well, it seems this has been addressed, but I recently saw in the a very complete bios manual that if you have this problem, do not enable quick power on selftest.
Hello everyone,

This question has been open for quite awhile. I am going to allow feedback from the questioner and experts. If it is not resolved, I will delete or accept an answer based on the info I have been given. Experts, feel free to offer input. I will monitor this question for a period of 5-7 days and come back and evaluate.  

Thank you,
Community Support Moderator

*Question Author, please return and resolve this question.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.