• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

Dual NIC's slow response

I have just setup Mandrake 8.0 with two nic's, one is a 3com 509 and the other is an SMC.

My network setup is:- windows machines connected on the 192.168.1 network(eth0 - 3com card), and a Mandrake 7.2 box on the 192.168.0 network (eth1- SMC card).

They both are working but when I telnet from my WinME machine to the 8.0 box the response is in spurts. It will output half the screen, wait half a second and then output the other half.

If I don't load eth1 the network response is as you would expect.

Here's the output of 'ifconfig'
.....................................
eth0 Link encap:Ethernet HWaddr 00:A0:24:08:BA:F1
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1361 errors:0 dropped:0 overruns:0 frame:0
TX packets:1446 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:84219 (82.2 Kb) TX bytes:378412 (369.5 Kb)
Interrupt:10 Base address:0x300

eth1 Link encap:Ethernet HWaddr 00:00:C0:AD:85:96
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:349 errors:0 dropped:0 overruns:0 frame:0
TX packets:474 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 txqueuelen:100
RX bytes:70150 (68.5 Kb) TX bytes:28699 (28.0 Kb)
Interrupt:3 Base address:0x290 Memory:d0000-d4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:78 errors:0 dropped:0 overruns:0 frame:0
TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5460 (5.3 Kb) TX bytes:5460 (5.3 Kb)
.....................................


Here's the output of 'route -n'
..............................................
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
...........................................


__________________
Regards
Harry Phillips
0
hazza96
Asked:
hazza96
  • 3
  • 2
  • 2
  • +1
1 Solution
 
tdaoudCommented:

Do you have the win station defined in /etc/hosts.  That may improve the resolving of its name while trying to identify it.

Good luck,

Tarik
0
 
jlevieCommented:
The SMC card (eth1) is using IRQ3 which normally belongs to a COM port. Have you disabled the COM port in the BIOS? If the COM PORT is still enabled it could cause problems for the NIC.
0
 
psimationCommented:
I think your problem lies with the netmask.
I see that (provided that it's not a typo), that the one NIC has an IP of 192.168.1.1 with netmask 255.255.255.0
and the next NIC has IP 192.168.0.1 with netmask 255.255.255.0
As they are setup now, it's remarkable that the machines can even see each other.
If your intention was to have two separate networks "bridged" by the Linux box, then you should change the netmask for the 2nd NIC to be 255.255.0.0 and of course, all PC's connected to one NIC in the Linux box, ie. all on that specific network should have the same netmask and their IP's should be in that range. For instance, your first NIC; IP = 192.168.1.1 netmask = 255.255.255.0 and all other PC's connected to that network should all have the same netmask and their IP's should only alternate at the last number.
Same for the 2nd NIC.netmask = 255.255.0.0 for all and number only alternate at last number in IP.
PS, I'm not 100% sure that the netmask 255.255.0.0. will work, can't remember the exact valid netmasks, but I'm sure there are other clever guys here that will know which masks to use.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
psimationCommented:
No wait, sheet, I'm thinking myself confused now...
Now I can't remember how these damn netmasks work again... Let me quickly go and grab my books and get back, the more I look at your current setup, the more it looks to be 100% correct after all...
hang ten...
0
 
jlevieCommented:
His netmasks are okay. Each of the NIC's has an attached CLASS C (255.255.255.0) network and presumably he has routing enabled on the system.

If the netmasks were set to 255.255.0.0 the system would think that both NIC's were connected to the same network and things would get really squirrely.
0
 
hazza96Author Commented:
I don't have routing enabled on the linux box with the two nic's and don't actually want it.

The reason I have this setup is to practice setting up a linux box to be used as a gateway with an ADSL connection. I don't have ADSL yet, one provider said it will be available in 6 months and I can have a linux server as a gateway.

I am treating the second linux box on the 192.168.0 network as 'the big bad internet' and trying to setup IP masqing/firewall, samba etc on the one with two nic's.

I then try and 'surf' from my win machine through the gateway to the other linux box. It saves my hours and a phone calls on my dial-up account.

Yes, I do have the win box in the /etc/hosts file.

I might try disabling the com port in the BIOS and see how that goes.
0
 
jlevieCommented:
Actually if you have IPMasq set up you do have routing enabled, but that's actually beside the point. There is some level of connectivity between the two networks, else you wouldn't even be able to establish a Telnet session. On the target of the telnet session (on the outside of the gateway) what do you have set for the default route? It should be pointint to the outside IP of the gateway box.
0
 
hazza96Author Commented:
I used a jumper to set it to IRQ 3 and forgot all about the com port.

I disabled the com port in the BIOS and everything is sweet now.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now