Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 317
  • Last Modified:

ODBC Drivers error 80004005

I am connecting to an Access database on a Novell 5.X server (using a mapped drive) from an NT Workstation running IIS4 via an ASP page.  I get the following error when running the ASP page;

Microsoft OLE DB Provider for ODBC Drivers error '80004005'
[Microsoft][ODBC Microsoft Access 97 Driver] Out of Ms-DOS File handles.

When I move the Access database to the local drive everything works correctly and I don't get the error.  What can I do to get it to work correctly from the Novell server?

Thanks for your help,

John
0
JReynolds
Asked:
JReynolds
  • 6
  • 5
  • 4
  • +1
1 Solution
 
IcecubeCommented:
do you have read/write access there ?
0
 
mgfranzCommented:
You are leaving your recordsets and connection strinngs open in your scripts, ensure you use Close on your conn and rs.

conn.Close
rs.Close
0
 
makerpCommented:
i dont think you can use mapped drives with access and ADO. anyway the performace will be terrible. if your using access make sure its on the same machine as the web server.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
JReynoldsAuthor Commented:
Yes, and the power is plugged in and the machine is turned on :-)  The database can be opened using MS Access on the NT Workstation from the network drive.  The tables from a local database can not be linked to the database on the network drive though.
0
 
makerpCommented:
you may be able to open the database in access, but that means nothing, in ASP you are not accesing it via MS Access front end but rather a driver and ODBC
0
 
mgfranzCommented:
You can access mapped drives with ADO, and yes, performance is degrating...
0
 
IcecubeCommented:
This behavior occurs when password synchronization is enabled for the IIS 4.0
application. For IIS 5.0, password synchronization is called "Allow IIS to
control password."
 
When you connect to an Access database or that Access database is linked to
Access tables across the network, this problem can be caused by a combination of
password synchronization being enabled and a bug in the Odbcjt32.dll version
3.51.1029 (Microsoft Data Access Components 1.5). That particular problem has
been fixed in MDAC 2.0 and later.
 
Disable password synchronization for the Internet Information Server 4.0
application. For IIS 5.0, do not allow IIS to control the password. To do this,
perform the following steps:
0
 
IcecubeCommented:
See microsoft KB : Q189408
0
 
makerpCommented:
okay so you can access access via mapped drives. i was under the impression that was not possible, i stand corrected.

>>Out of Ms-DOS File handles

it sound like either the OS has run out of filehandles or the user account that the db is being accessed under has a restriction on the number of filehandle and this has been reached. (bloddy Novell :|)
0
 
mgfranzCommented:
Icecube, haven't we already discussed the issue of answering questions, especially if you do not know the true solution!  Your solution ~might~ be the answer, but ONLY if JReynolds is using MDAC 1.5, (highly unlikely since IIS4 loads 2.1).  From the "answer" you provided;

"...this problem can be caused by a combination of password synchronization being enabled and a bug in the Odbcjt32.dll version 3.51.1029 (Microsoft Data Access Components 1.5). That particular problem has been fixed in MDAC 2.0 and later."

Please do not lock questions by posting a "answer", especially a wrong one.
0
 
JReynoldsAuthor Commented:
Yes, and the power is plugged in and the machine is turned on :-)  The database can be opened using MS Access on the NT Workstation from the network drive.  The tables from a local database can not be linked to the database on the network drive though.
0
 
JReynoldsAuthor Commented:
Hey Icecube,
I am rejecting this answer for now to unlock the question.  I tried earlier to not allow IIS to control the password and that didn't work. It is using MDAC 1.5, I don't know why but, it is. I'm going to upgrade to MDAC 2.0 or greater.  If it works I'll select your answer.

John
0
 
makerpCommented:
go to M$ and download MDAC 2.6 and JET 4.0, it has imrpoved my performace and reliablity orders
0
 
mgfranzCommented:
I find it hard to believe that you have MDAC 1.5 installed on a NT 4 Workstation running IIS4...  What service pack are you using?
0
 
JReynoldsAuthor Commented:
Hey Icecube,
I am rejecting this answer for now to unlock the question.  I tried earlier to not allow IIS to control the password and that didn't work. It is using MDAC 1.5, I don't know why but, it is. I'm going to upgrade to MDAC 2.0 or greater.  If it works I'll select your answer.

John
0
 
JReynoldsAuthor Commented:
Hey Icecube,
You were right on!  We upgraded to MDAC 2.5 and it works.  I spoke with the guy who installed IIS 4.0 and he doesn't know why it wasn't upgraded to 2.1.

Thank you,
John
0
 
mgfranzCommented:
IIS 4 installs MDAC 2.1.

Perhaps you have no idea what you are running JR... Bu I guess a stab in the dark is better than no stab at all...
0
 
JReynoldsAuthor Commented:
Sorry everyone but, I didn't install the OS, Service Pack, or IIS 4 so I don't know why it still had the MDAC 1.5.  The Workstation has Service Pack 6 on it so something must have replaced the newer files with old ones (must be a Microsoft thing).

Anyway, what a rough crowd of people you are, don't hold anything back just tell me like it is :-)..... Maybe I won't quit my day job.

Thanks again for all your help,
John
0
 
IcecubeCommented:
Your welcome !

If somebody thinks the same error can occur when all updates are there on the server, try to recreate that situation and give me some feedback on how to do that !
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 5
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now