Solved

ASP page won't refresh... with a twist

Posted on 2001-07-11
17
2,157 Views
Last Modified: 2011-10-03
OK, I know there was a question just like this a few days ago, but this is VERY strange.

Same deal -- made major, major changes to ONE folder of a website. It had been a subweb, but I've made changes to subwebs before that screwed them up, and recalculating the links, reapplying the server extensions and checking server extensions usually fixed them. Not this time...

I had copied pages from another server, put them into a NEW folder on the website. Worked fine. Renamed the OLD live folder, reanmed the NEW folder to the old folder name, reset up the subweb, reapplied the server extensions, recalculated links/indices. The browser pulled up the OLD pages -- but all the links to graphics were wrong, since no graphics showed up. Moved the old, RENAMED folder to OUTSIDE of the web folders. Still happened. REnamed the OLD files, that seemed to fix it...

So I made my minor changes to the NEW files. Brought them up -- unchanged files showed up. Hmmm... Cleared browser cache. Same thing.

So I changed the cache pages on THAT subweb only to 0, changed include cache to 0 -- nothing. Went through, deleted any/all files with the same names from any/all folders (including the one that had the OLD versions of the files in the _vti_cnf folder. Deleted the ENTIRE vti_cnf folder from the old, RENAMED folder. Nothing.

Converted the subweb to a folder, RENAMED that. STILL pulled up the old pages -- even though the FOLDER didn't exist. The pages that connected to the database generated an error -- but a DATABASE error, not a 404.

The files ARE changed -- when I open them in Notepad, on the server, the changes are made. But the old pages are being pulled from SOMEWHERE. They don't exist on the server -- I did a search, the only pages with those names are the ones I just fixed.

You want to hear the WEIRD part? Other folders on the SAME website, SAME server, don't have this problem. I make changes, hit REFRESH in the browser, BOOM -- new page shows up.

There's obviously some connection that's been broken. What, where, how to change it -- I've got NO clue. Can't find ANYTHING on MS site.

Anybody got any clue?
0
Comment
Question by:webwoman
  • 5
  • 3
  • 2
  • +6
17 Comments
 
LVL 33

Expert Comment

by:hongjun
Comment Utility
Try this to minimize caching.
http://www.activeserverpages.com/learn/cachenomore.asp

hongjun
0
 
LVL 33

Expert Comment

by:hongjun
Comment Utility
Perhaps try stopping your web server and then clear all the cache again. Then restart the web server.

hongjun
0
 
LVL 15

Expert Comment

by:robbert
Comment Utility
Frontpage Server Extensions bug. Had it, too, a couple of times. Better delete the folder (if you can), the web, or the question...
0
 
LVL 20

Expert Comment

by:Silvers5
Comment Utility
Not that weird:
IIS has caching in it too.. go to your web server propreties in IIS (right click on the web server).. select the server extensions tab.. in performance select the settings tab.. set the cached documents to 0.. from 4092..

and test.. this should do the job..


also you can select in the Internet information the services tab the www master services.. edit.. home directory..  configure button (near the application name)
select the process options tab select the script file cache to 0..

when all is ok you can set that setting back to boost up performance

also read from a developer point..:

Caching is hard to manipulate, (is it o bug or not) you need to add several lines on the client and
server side (although this won't eleminate the problem 100% but will minimise it a lot)
<%..
Response.expires= 0
Response.Expires=-1
Response.Expiresabsolute = Now() - 1
Response.AddHeader "cache-control","private"
Response.CacheControl = "no-cache"
%>
<meta http-equiv="PRAGMA" value="NO-CACHE">
<meta http-equiv="Expires" content="Mon, 01 Jan 1990 12:00:00 GMT">


one of the best ways to suppress cache is to redirect to another page with  a querystring at the end
of the url like:

response.redirect "mynocachepage.asp?" & Server.URLEncode(rnd)

For more information see:

   http://www.activeserverpages.com/learn/cachenomore.asp

0
 
LVL 20

Expert Comment

by:Silvers5
Comment Utility
hmm if you made all these and nothing works then the cache is persistant on the web server even after disabling it.. try to stop and start the IIS.. finally if nothing helps.. do as robbert said..
0
 
LVL 33

Expert Comment

by:hongjun
Comment Utility
Ya personally I think it is best to try to get rid of the cache first before really going to delete the folder.

hongjun
0
 
LVL 19

Author Comment

by:webwoman
Comment Utility
It's working now... and it had absolutely NOTHING to do with caching (at least, nothing to do with the caching settings).

It's the folders. There is some kind of strange link between the folders, and I never did find anyway to break it. What I wound up doing was renaming the folders back to their original names, moving the one back into the web, and copying the files from the new to the old.

Then everything works. I update pages, they show up. No cache changes, no restarting anything, no changing any other settings (other than removing the extensions on the subweb and then putting it back -- which I had done a zillion times before with no effect).

Remember -- I HAD changed the cache settings -- zilch. HAD changed the file to no cache -- zilch (the new file didn't even come up, remember? And it really didn't.. once it DID, there was an syntax error in the no-cache asp command. ;-) ) I could DELETE the file, and it would STILL come up. And if it was IIS caching, why did everything ELSE work fine, with those SAME original cache settings?

It's the FOLDERS. Quite possibly rebooting the server would have fixed it, but I didn't have that option (not right now, anyway -- and I suspect it wouldn't have done anything). You can ADD folders, using FP or anything else, and it works just fine. I copy folders over or make new ones all the time. You just can't rename or delete them (it's fine for files) OUTSIDE of FP/IIS.

So now that I know, it's manageable.

If it's OK with everybody, I'd like to reduce this to 0 and PAQ it, and give 10 pts each to robbert, silver5 and hongjun with an A for effort. ;-)  
0
 
LVL 33

Accepted Solution

by:
hongjun earned 10 total points
Comment Utility
Great that your problem is solved.

hongjun
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 2

Expert Comment

by:elstcb
Comment Utility
I've had FrontPage extensions do the same to files as well - now I never rename ANYTHING on the server. One to be aware of...!!!
0
 
LVL 2

Expert Comment

by:Lunchy
Comment Utility
Hi webwoman, I have reduced the points for the split as you requested.  Please post 2 other "Points for" questions for the other two experts in this topic area with a link back here so others know what the points are for.  Then post links from here to the points questions for the experts.

Thanks

Lunchy
Friendly Neighbourhood Community Support Moderator
lunchy@experts-exchange.com
0
 
LVL 33

Expert Comment

by:hongjun
Comment Utility
Just inform Lunchy, I did not receive any Good Answer email for this question.

Really strange. A bug?

hongjun
0
 
LVL 20

Expert Comment

by:Silvers5
Comment Utility
when a moderator accespts a comment you don't get one.. It's developed like this it seems.. Webwoman.. I stated to restart IIS too.. anyways glad to see you made it.. if I had such a problem I would've die if I didn't know the real reason behind it..

rgrds
0
 
LVL 2

Expert Comment

by:Lunchy
Comment Utility
Didn't know that accepting a comment this way doesn't generate Good Answer mail.  If it hasn't been done, I'll report it to engineering.  Thanks.

Lunchy
Friendly Neighbourhood Community Support Moderator


0
 

Expert Comment

by:pbisht
Comment Utility
Hi webwoman,

I'm facing the same problem that you described above.  However, I wasn't trying to rename a folder.  I just updated some files inside the webfolder, but I cannot see the changes.  My files are located on a shared folder on server1 and the IIS is on a different server (server2) and points to the shared folder on server1.  I have tried several things...

1. Restarted the IIS (on server2)
2. Restarted server1 (contains the shared folder and files)
3. Broke the shared link by "unsharing" the folder temporarily and linked it back again.
...

Nothing seems to work.  To test further, I added a small file "hello.asp" which contained "hello puja" into the folder.  I could see this file on my browser.  Then, I added some more text to the file, but never saw the changes.  I still saw only "hello puja" when I viewed it from the web browser.  Then, I DELETED the file and tried to view it from the browser... I could still SEE it!  ...freaky!

Do you have any suggestions?  Any help would be greatly appreciated!  Thanks.

- Puja
0
 
LVL 19

Author Comment

by:webwoman
Comment Utility
Recalculate the links in IIS, clear the cache on the server, check the server extensions. If there's a proxy server, that could cause it.

Do that on BOTH servers... the problem could be in either one.
0
 

Expert Comment

by:sjacob
Comment Utility
Hi all,

We had a similar problem (one sub-web doesn't clear its cache, updates in that folder doesn't show up through browser), and it is with IIS 4. Here is how we solved the problem through IIS.

In "Directory" tab in IIS, check the "Run in seperate memory space" and Apply.


0
 

Expert Comment

by:aaronwk
Comment Utility
I know this is an old topic but thought i would post our problem / solution for others.

Problem: In IIS 6 users created .asp files with frontpage. Initially the files would load but after saving changes the the old content would still appear even thought the file was correctly changed. I would open the file on the server and it would have the updates but IIS was serving an old version. I would download the file from the server with FTP and re-upload and like magic it would show the new updated content.

Solution: Turn off IIS .asp cache. Open the IIS manager, expand the local computer, right click on 'Web Sites', choose properties, click the Home Directory tab, click on the configuration button, then choose the Cache Options tab at the top. Choose 'do not cache asp files', then apply and ok the changes. Without restarting IIS it should fix the problem, if not though restart IIS.

To me this appears to be a bug in the FP server extentions.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

I have helped a lot of people on EE with their coding sources and have enjoyed near about every minute of it. Sometimes it can get a little tedious but it is always a challenge and the one thing that I always say is:  The Exchange of information …
I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now