Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Note - nupdate.exe consume 90%+ cpu all the time (for weeks)

Posted on 2001-07-12
7
6,651 Views
Last Modified: 2011-08-18
Hi,
   i am using note 5.07a client + win2k pro sp2 , and saw in task manager that nupdate.exe is consuming 90%+ of cpu all the time. at first i think it would drop the cpu usage after nupdate.exe finish its job.
   Weeks later , problem still exist. Any idea to explain this , this is quite boring - i always need to reduce nupdate.exe process priority to 'Low' to speed up other jobs.  
    Thanks in advance
0
Comment
Question by:blackdragon
  • 3
  • 3
7 Comments
 
LVL 16

Expert Comment

by:GUEEN
ID: 6279682
Nupdate handles the task of full text indexing (no doubt disk paging has gone quit insane too. . .)  It might be that your index is broken. Turn off full text indexing and delete the db.ft directory (and all sub dirs) from the server. Then try a re-index.
0
 

Author Comment

by:blackdragon
ID: 6279711
shekerra ,
   your comment sounds interesting , i want to give it a try . but i've got many full text-indexed ( .ft directories ) databases in my workspace. which one should be deleted ? (or just delete all and reindex ?)
0
 
LVL 16

Expert Comment

by:GUEEN
ID: 6279720
Since you do not know which one is broken - you could do it via all or one at a time and see if CPU useage decreases.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Accepted Solution

by:
CommView earned 150 total points
ID: 6287170
shekerra is only partly right. nupdate not only works for the FT index, but more importantly updates the view indexes of the database as well (see R5 admin help under topic "update task")

You probably have one or more large databases (that is: many documents) with views that have date or time functions in it (e.g. @Today and @Now). These formulae can be in de selection as well as in the columnformula.

nupdate consuming that much CPU time, usually means a view needs constant updating, which is triggered by these Date formulae.

An easy way to find the views responsible, you might look for views that always show the blue refresh arrow in the lefthand corner.
If so, replace formulae responsible with the workaround
@TextToTime( "Today" ) instead of @Today.

Good luck
Wiebe van Bruggen (CommView)
0
 

Author Comment

by:blackdragon
ID: 6338054
thankss
0
 
LVL 16

Expert Comment

by:GUEEN
ID: 6339740
Blackdragon,

Just a question?  CommView gave you a full answer (An A grade in my book) - why the B grade?

>Bev
0
 

Author Comment

by:blackdragon
ID: 6342864
shekerra ,
   well , i am not aware that grading the proposed answer is so serious. I'm satisfied with CommView's answer . If possible i wanna change my grading to A. is it possible? How?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
An analysis of the phishing scam that has been affecting Google users, along with steps to take for protection, as well as what to do if you receive one of the emails.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question