Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 464
  • Last Modified:

Informix SQL 7.3 Connection Failure on slakware linux

I have loaded slakware v 2.2.13 and then installed an eval copy of Informix SQL and SE (7.30 UC5).
Have been totally unable to get either I-connect or Client SDK to connect. This also occurs logging
in locally and trying to connect to the database. On doing this you get an error :- 952: Users password
is not correct for the database !

Have been overwhelmed looking through tons of on line doc's but can I find anything on this ????
Some things seem to point to .netrc file but I'm not sure !!

Any ideas anyone ??
Pat.
0
Greyboy
Asked:
Greyboy
1 Solution
 
gamaerteCommented:
Pat,

Although I don't have a lot of experience in SE , I think there are a few possibilities you can try .

- Is you DB_PATH pointing towards the directory where the database is located?

- If you want to set network connections , Is your network daemon is started up?

- Try Logging on with the informix user(use OS passwords those are the ones used by informix) and granting access to another (grant connect to "user").

I appologise for the help I can give you but the SE is very different from the online version.

Greetings,

Gamaerte
0
 
GreyboyAuthor Commented:
Cheers for the tips but I sort of managed to crack this one (at least a stage further !). SE doesn't like password shadowing on Linux and you have to run pwunconv utility.
Dug this up from the web after hours of digging around !!
Have now run against a new problem in that I can't get the odbc drivers to work correctly which I think I'll try logging on here !
Thanks anyway.
Pat.
0
 
GreymanCommented:
1) Given the relationship between login names, I just couldn't help myself.

2) We've had a world of trouble with Informix ODBC drivers on Unix & had a person work for two weeks to get it running, only to give up.  The JDBC stuff can be made to work eventually, but good luck :)
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
nico5038Commented:

No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
 - PAQ'd and pts refunded
Please leave any comments here within the
next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER !

Nic;o)
0
 
GreyboyAuthor Commented:
IF anyones interested, this turned out to be because of having shadow passwording enabled on linux. I've still not managed to get i-connect or openlink to work correctly with multi tables queries as it seems to get the sql syntax wrong but that's probably for another question !!
0
 
JgouldCommented:
Thanks for updating this Greyboy

Question has been closed as per recommendation

JGould-EE Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now