Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

ASPExec

Posted on 2001-07-14
4
Medium Priority
?
321 Views
Last Modified: 2010-05-18
I am using ASPExec to run a command line pgp type program to encrypt a file.  This works fine on Windows 2000 Advanced Server but not when I run it on another server running Windows 2000 Server.

The code is as follows

Executor.Application = "c:\gnupgp\gpg --yes -a -e -r daveamour@hotmail.com c:\gnupgp\test.txt"

This works fine if I type it in at the server but when run from an ASP page I get the following error...

gpg: c:\gnupgp\test.asc: can't create: No such file or directory gpg: c:\gnupgp\test.txt: encryption failed: file create error

Any ideas anyone?

Cheers

Dave

0
Comment
Question by:daveamour
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 3

Accepted Solution

by:
phuctran earned 150 total points
ID: 6283137
I think that is because of permission.
Try to change c:\gnupgp to c:\temp to see if it work. (c:\temp has everyone permission).
Give the directory c:\gnupg permission (IUSR_).

0
 
LVL 19

Author Comment

by:daveamour
ID: 6283143
Permissions are fine, this is not the problem, thanks anyway

Dave
0
 
LVL 19

Author Comment

by:daveamour
ID: 6283166
My apologies ph

I had already set file permissions to what I thought they should be but after having tried setting Full control to Everyone this worked fine.  This doesnt need to be done on Windows 2000 Advanced Server though so I guess its a MS bug

Any better security solutions would be appreciated by anyone.

Cheers

Dave
0
 
LVL 3

Expert Comment

by:phuctran
ID: 6283210
I think there is something wrong.  Your directory c:\gnupgp should have IUSR_MachineName permission (full) -- don't give everyone permission.  And usually, only directories under your web directory automatically has that permission.  You should check it again.  If it does not need to be done on Windows 2000 Advanced Server then I think you should have a look about permission on all your directories.
:) I will check mine tomorrow.

0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently decide that I needed a way to make my pages scream on the net.   While searching around how I can accomplish this I stumbled across a great article that stated "minimize the server requests." I got to thinking, hey, I use more than one…
Have you ever needed to get an ASP script to wait for a while? I have, just to let something else happen. Or in my case, to allow other stuff to happen while I was murdering my MySQL database with an update. The Original Issue This was written…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question