Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

pcmcia nic problems with freebsd 4.3 stable

Posted on 2001-07-15
6
Medium Priority
?
424 Views
Last Modified: 2010-04-22
On my Toshiba PII 266 laptop with a Linksys 10/100 Fast
Ethernet NIC, can access Internet & email & local area
network including ssh/scp but my download speeds on the
Internet are really slow, considering I have a cable
connection.  Originally, when I installed freebsd on the
laptop, it had my Linksys 10/100 pccard running on ed1.
I was told that was wrong, so I went into the kernel
config & changed to ed0 under PCI Ethernet NICs and
recompiled the kernel.Since making the change to ed0,
all of the above ability to access is still the same.
Unfortunately, the bad speed is still the same too.
Below are portions of my dmesg output &  ifconfig ed0
output:
-------------------------------------------------
ed0 at port 0x300-0x31f irq 3 slot 0 on pccard0
ed0: address 00:e0:98:8a:a1:fc, type Linksys (16 bit)
ed0: DAD detected duplicate IPv6 address
fe80:000a::02e0:98ff:fe8a:a1fc:1
NS, 0 NA
ed0: DAD complete for fe80:000a::02e0:98ff:fe8a:a1fc - duplicate
found
ed0: manual intervention required
------------------------------------------------
ed0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
mtu 1500  inet6 fe80::2e0:98ff:fe8a:a1fc%ed0 prefixlen 64 duplicated
scopeid 0xa
 inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
 ether 00:e0:98:8a:a1:fc
------------------------------------------------
From the looks of it, it looks like 2 things on the
system are trying to use the same resources. All 3 of
my computers are going to a Netgear hub, on to a Linksys
router/firewall box, & then to the cable modem. Neither
the windows machine or the slackware linux box have any
Internet speed problems. Can someone help me decypher the
above messages & maybe point me in the right direction as
to what to read to solve this problem? The part about
manual intervention is a problem. I don't know what the
system wants me to about it, unless it's something I have
to change in the kernel config & recompile. Was wondering
if the duplex was wrong on the pccard, that is maybe only
running at half-duplex, but then I read in one of the
news groups that if you're running through a hub, that's
the way it has to be anyway. Also, I've been told to
"sh MAKEDEV ed0" but the system refuses to do it. And
then, on the other hand, I've read where that's one
device you don't make, that it's handled directly from
the kernel. So, any light shed on this will be greatly
appreciated. If any other info is needed, please advise
& I'll try to dig it up.
Denny White
0
Comment
Question by:dennywhite
  • 2
  • 2
5 Comments
 

Expert Comment

by:PaulSmirnoff
ID: 6285978
It seems like you have configured the same IPv6 address somwhere else ...

Please provide  ifconfig -a output if possible...

Regrading Simplex operation:
I had similar situation with 3com card.
The problem has been solved using proprietary
3com configuration utility and setting card to
autosense mode instead of hard configured for duplex mode.

Paul
0
 

Author Comment

by:dennywhite
ID: 6287257
Here's the output of ifconfig -a
-----------------------------------------
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
faith0: flags=8000<MULTICAST> mtu 1500
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
gif1: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
gif2: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
gif3: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
     inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
     inet6 ::1 prefixlen 128
     inet 127.0.0.1 netmask 0xff000000
ppp0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500
sl0: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 552
ed1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
     inet6 fe80::2e0:98ff:fe8a:a1fc%ed1 prefixlen 64 duplicated scopeid 0xa
     inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
     ether 00:e0:98:8a:a1:fc
0
 

Accepted Solution

by:
PaulSmirnoff earned 800 total points
ID: 6288875
Hmm,

Looks like you already have configured ed1
using the same IPv4 and IPv6 addresses.
Try to look through you /etc/rc.conf
in order to ensure only one device using these addresses.

If you want it to be ed0 - ensure that only ed0 is configured in rc.conf.

Paul
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 6939396
ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.  Moderators Computer101 or Netminder will return to finalize these if still open in seven days.  Please post closing recommendations before that time.

Question(s) below appears to have been abandoned. Your options are:
 
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you, but may help others. You must tell the participants why you wish to do this, and allow for Expert response.  This choice will include a refund to you, and will move this question to our PAQ (Previously Asked Question) database.  If you found information outside this question thread, please add it.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question (if it has no potential value for others).
   --> Post comments for expert of your intention to delete and why
   --> YOU CANNOT DELETE A QUESTION with comments; special handling by a Moderator is required.

For special handling needs, please post a zero point question in the link below and include the URL (question QID/link) that it regards with details.
http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
 
Please click this link for Help Desk, Guidelines/Member Agreement and the Question/Answer process.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Click you Member Profile to view your question history and keep them updated as the collaboration effort continues, to maintain your open and locked questions.  If you are a  KnowledgePro user, use the Power Search option to find them.  Anytime you have questions which are LOCKED with a Proposed Answer which does not serve your needs, please reject it and add comments as to why.  In addition, when you do grade the question, if the grade is less than an A, please add a comment as to why.  This helps all involved, as well as future persons who may access this item for help.

To view your open questions, please click the following link(s) and keep them all current with updates.
http://www.experts-exchange.com/questions/Q.20151034.html
http://www.experts-exchange.com/questions/Q.20151036.html




**** PLEASE DO NOT AWARD THE POINTS TO ME. *****
 
------------>  EXPERTS:  Please leave your closing recommendations if this item remains inactive another seven (7) days.  If you are interested in the cleanup effort, please click this link http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=commspt&qid=20274643 
POINTS FOR EXPERTS awaiting comments are listed here -> http://www.experts-exchange.com/commspt/Q.20277028.html
 

Moderators will finalize this question if in @7 days you have not responded.  They will either move this to the PAQ (Previously Asked Questions) at zero points, delete it or awarding expert(s) when recommendations are made, or an independent determination can be made.  Expert input is always appreciated to determine the fair outcome.
 
Thank you everyone.
 
Moondancer
Moderator @ Experts Exchange
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 7116719
Zero response finalized.
Moondancer - EE Moderator
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tech tip describes how to install the Solaris Operating System from a tape backup that was created using the Solaris flash archive utility. I have used this procedure on the Solaris 8 and 9 OS, and it shoudl also work well on the Solaris 10 rel…
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

824 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question