Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

data source name error

Posted on 2001-07-16
14
Medium Priority
?
259 Views
Last Modified: 2006-11-17
I am going crazy....i have two Win2k machines next to eachother with a real simple asp page:

*********************************************
<%
dim conn
dim rs

set conn = server.createobject("adodb.connection")
conn.open "Kamfile","sa", "password"
set rs = conn.execute("select * from table")
%>
*********************************************

Both use the exact same DSN configured identically on each machine.  One web page works fine the other gets this error:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
/dataconn/Default.asp, line 6


Any ideas?  I have tried everything i know...doesn't make sense...

0
Comment
Question by:svfafel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +3
14 Comments
 
LVL 46

Expert Comment

by:fritz_the_blank
ID: 6286096
Are the permissions to the directory containing the database the same?

Also, what type of database is it?

Fritz the Blank
0
 
LVL 3

Accepted Solution

by:
Maxim10553 earned 200 total points
ID: 6286129
This problem usually occurs when the machine has problems finding the DSN. Make sure you are using a system DSN.
0
 
LVL 5

Expert Comment

by:mattyk
ID: 6286130
Also double check that you made the DSNs System DSNs on both machines.

-matty
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 5

Expert Comment

by:mattyk
ID: 6286134
Looks like I'm slow today... it must be Monday:)

matty
0
 

Author Comment

by:svfafel
ID: 6286135
It is a SQL database (referred to in the DSN) and they are both System DSN's...

0
 
LVL 46

Expert Comment

by:fritz_the_blank
ID: 6286150
Okay then,

Are you logging on to both machines with same username and password? If you are using Windows authentication on a SQL Server Database, you may be running into security issues. Also, in the DNS, are you using TCP/IP or named Pipes? I have come across instances where only one or the other might work on any given computer.

Fritz the Blank
0
 
LVL 3

Expert Comment

by:Maxim10553
ID: 6286154
instead of a System DSN, try a connection string and see if the same problem exists.
0
 
LVL 3

Expert Comment

by:Maxim10553
ID: 6286158
'example syntax would be
cn.Open "Driver={SQL Server};Server=127.0.0.1;Uid=sa;Pwd=pass;Database=db1
0
 

Author Comment

by:svfafel
ID: 6286316
the problem did still exist....BUT....

I figured it out...after installing Crystal Reports 8, the registry permissions for the ODBC connections in the registry excluded the DSN's I created.  I added the IUSR user to the ODBC connections using REGEDT32 and it is now working fine...

Thanks for all your suggestions!!!!
0
 

Author Comment

by:svfafel
ID: 6286672
the problem did still exist....BUT....

I figured it out...after installing Crystal Reports 8, the registry permissions for the ODBC connections in the registry excluded the DSN's I created.  I added the IUSR user to the ODBC connections using REGEDT32 and it is now working fine...

Thanks for all your suggestions!!!!
0
 
LVL 3

Expert Comment

by:Maxim10553
ID: 6308398
svfafel - can you give us an update?
0
 

Expert Comment

by:amp072397
ID: 6783392
svfafel:

You have many open questions:

http://www.experts-exchange.com/jsp/qShow.jsp?qid=20151411
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20142486
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20152290
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20153618
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20155682
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20169125
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20175800
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20180978
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20190767
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20169126
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20146852
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20128521
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20134835
http://www.experts-exchange.com/jsp/qShow.jsp?qid=20136451

To assist you in your cleanup, I'm providing the following guidelines:

1.  Stay active in your questions and provide feedback whenever possible. Likewise, when feedback has not been provided by the experts, commenting again makes them receive an email notification, and they may provide you with further information. Experts have no other method of searching for questions in which they have commented, except manually.

2.  Award points by hitting the Accept Comment As Answer button located above and to the left of that expert's comment.

3.  When grading, be sure to read:
http://www.experts-exchange.com/jsp/cmtyQuestAnswer.jsp#3
to ensure that you understand the grading system here at EE. If you grade less than an A, you must explain why.

4.  Questions that were not helpful to you should be PAQ'd (stored in the database for their valuable content?even if not valuable to you) or deleted. To PAQ or delete a question, you must first post your intent in that question to make the experts aware. Then, if no experts object after three full days, you can post a zero-point question at community support to request deletion or PAQ. Please include the link(s) to the question(s).
CS:  http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
At that point, a moderator can refund your points and PAQ or delete the question for you. The delete button does not work.

5.  If you fail to respond to this cleanup request, I must report you to the Community Support Administrator for further action.

Our intent is to get the questions cleaned up, and not to embarrass or shame anyone. If you have any questions or need further assistance at all, feel free to ask me in this question or post a zero-point question at CS. We are very happy to help you in this task!


thanks!
amp
community support moderator

2/6
0
 

Author Comment

by:svfafel
ID: 6870965
The actual problem was corrupt ADO 2.5

Thanks everyone for the input....this was an individual machine issue...
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently decide that I needed a way to make my pages scream on the net.   While searching around how I can accomplish this I stumbled across a great article that stated "minimize the server requests." I got to thinking, hey, I use more than one…
I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question