Windows 2000 access share

I have a windows 2000 domain with the following set-up

win2k server
ip =
name =w2kserver

win2k workstation
name w2kWs

win98 workstation
name test98

Linux machine
name testLinux

I am testing this in order to convice my boss to use Linux as a file server and then email and fax server and phase out windows servers within our office.

trouble is i cannot access my file shares from my windows pc's I get the following error

\\testlinux is not accesable
the account is not authorised to log in from this station

could anyone help me out as to why this is happening

thanks in advance


======================== sambafile
# Samba config file created using SWAT
# from (
# Date: 2001/07/16 23:08:45

# Global parameters
     workgroup = test     netbios name = testlinux        server string = Samba Server 2
     encrypt passwords = Yes
     map to guest = Bad User
     null passwords = Yes
     log level = 0
     log file = /usr/local/samba/var/log.%m
     max log size = 50
     load printers = No
     os level = 0
     dns proxy = No
     wins server =
     guest account = ftp
     hosts allow = 10.0.0.

     comment = Home Directories
     read only = No
     browseable = No

     comment = All Printers
     path = /usr/spool/samba
     print ok = Yes
     browseable = No

     comment = test folder
     path = /storage/kris
     read only = No

Who is Participating?
psimationConnect With a Mentor Commented:
You probably didn't run the
cat /etc/passwd | > /ets/samba/smbpasswd
command after setting up samba and adding your valid users.

Go to my website at and follow the Networking link on the main page, it will show you all the steps to get Linux shared (and windows for that matter) using Samba.
In my config I have the following entry in the global section, perhaps this helps:

guest ok = yes

You can also increase the debuglevel so you have some more information in the logfiles:

debug level = 3

I also had to look that my samba server does not conflict with the domain master so i set everything to the lowes priority:

domain master = no
local master = no
preferred master 0 no
os level = 0

and to create all the files case sensitive (like I type them on Windoze) but to search them case insensitive I added the following lines to all shares:

mangle case = no
mangled names = no
case sensitive = no
preserve case = yes

And you also cannot connect if the path does not exists.
krisjobAuthor Commented:
Thanks it done the trick also your page helped me out with my next task mysql and php
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.