Replication Problem

Hello everyone,

I have 2 replicas of a database which reside on 2 servers on 2 different domains. When I replicate the database, the replication is acting in a very strange way, which giving me strange results, for example..

1. When there is new documents added to one of the replicas, it is not being added to the other replica after replication.
2. Some documents are being duplicated, in which the other copy appears as "replica or save conflict" even if the documents have not been changed.


I tried to replicate the database by using a local replica, in which I start replicating the local replica with one of the servers then replicate it with the other server. But that did not solve the problem!!
I made sure that "Merge replica conflict" option is ticked from the form properties. But this did not help either!!

So what else can be checked?
Any ideas?!!

Thanx in advance,
Areej
AreejAsked:
Who is Participating?
 
HemanthaKumarConnect With a Mentor Commented:
Checkw whether you are using selective replication and neglecting new documents by using @isnoewdoc function.

Secondly, the replication conflict can occur for various reasons, like some user or agent has tried to change the same field of the document in two replicas and system is wondering which is what ?

Replication conflict flag will work only when two documents were modified at same time but two different fields are modified then the copy is merged.

So check what edits happened on the docs

~Hemanth
0
 
CRAKCommented:
I agree with Hemanth: check if there are any agents saving the documents, causing replication/save conflicts.

Regarding your 1st problem: It might happen if the server's date/time settings are not correct, or if they have been modified.

Example:
Mid 1999 (lets say, in june) people were testing for the Y2K-bug. Servers dates were shifted to Dec 31, 1999 and left for a while to see what happened. When such servers performed a replication before the date was set back to normal, the software (databse) still remembered it had already replicated on Dec 31. Modifcations made in July were not replicated: the database was already up-todate for another few months!

Back then it could be solved by selecting the database(s), choosing File > Replication > Settings > 3rd icon (other) and checking the date under "Only replicate incoming documents saved or modified after". You'd have to do so on all replicas and adjust if neccessary.
0
 
AreejAuthor Commented:
Thanks a lot for both of u. U r right, I found one agent that modifying the same field in both replicas.

Thanks again
Areej
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.