Solved

How do I get Internet Connection Sharing to work?

Posted on 2001-07-17
12
253 Views
Last Modified: 2010-04-13
I'm trying to share a modem in the server with other machines on the LAN. I followed the instructions on MS web page, which is just to go into the Properties for the dial-up connection, then on the Sharing tab, set "Enable Internet Connection Sharing for this connection".

But it didn't work - the other machines couldn't see the connection. Plus, it caused the other machines not to see a shared folder on the server, so I had to disable the ICS and reboot the server to get back to normal.

Anyone know what needs to be done to make this work? Thanks!
0
Comment
Question by:oldbie
  • 4
  • 2
  • 2
  • +4
12 Comments
 
LVL 1

Expert Comment

by:losgadas
ID: 6291414
Check the following article:

http://support.microsoft.com/support/kb/articles/Q238/1/35.ASP

Also, make sure you have only one host in your lan for ICS.  And also make sure you have two NICs installed.
0
 

Author Comment

by:oldbie
ID: 6291441
Why do I need two NICs? It's an internal modem with a phone line to it.
0
 

Author Comment

by:oldbie
ID: 6291446
Also, this is Windows 2000 we're talking about. Does it matter that the website you gave me is for Win98SE?
0
 
LVL 1

Expert Comment

by:petemcc
ID: 6291658
You don?t need two NICs (unless your connected via DSL), you need two interfaces on the host machine, one to the internet and one for your LAN.  The client boxes need to have DHCP enabled. ICS is gonna set the LAN adapter on the host machine  to 192.168.0.1 and assign IP addresses to the host machines in that range (192.168.0.XXX). If you are using hard addresses you?ll lose connectivity when you enable ICS. You can?t have AD, be a  DHCP or DNS server or be a domain controller on the ICS host!
Here?s a link to a W2K specific article on ICS.

http://www.zdnet.com/sp/stories/issue/0,4537,2595940,00.html
or:
http://support.microsoft.com/support/kb/articles/Q237/2/54.ASP

If  you want to share to more than 10 clients, or need hard addresses,  NAT is available on W2Kserver  and would be a better choice

0
 

Expert Comment

by:leystan
ID: 6291680
the machine you have connected to the internet is the gateway. set the other machines to use this connected machine as the gateway.

try this:
1. After you have enabled ICS on one of the machines
2. Go to another machine on the network
3. Right click on My Network Places and select Properties
4. Right click on the LAN connection and select Properties
5. Highlight TCP/IP in the Components window
6. Click the Properties button
7. In the Default gateway field enter the IP of the machine that is running the ICS

I don't remember if you have to reboot the machine....

that should be it.
0
 
LVL 5

Accepted Solution

by:
mattyk earned 100 total points
ID: 6291737
I know a lot of folks who have had problems with Internet sharing in the past.  Give this a try instead (it's free)

http://www.analogx.com/contents/download/network/proxy.htm

-matty
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Expert Comment

by:daggodt
ID: 6293785
Hello!
You have to use the server with as a proxy server.
It doesn't mather if you're using a cable modem/modem or a T1-line.

You have to install a proxy server program on the server. I think winproxy is a great program(http://download.ositis.com/downloads/Winproxy.exe).
Install that prog on the server and use following settings on the machines:

server:
Static IP: (e.g. 198.162.0.1)
automatic startup for the winproxy prog

clients:
different Static IPs on each machine- start with 198.162.0.2
Use proxy server-setting in all internet-progs
(www:IP=198.162.0.2:80   , SOCKS5:IP=198.162.0.2:1080  or 198.162.0.2:8080)
Also you can use 198.168.0.1 as gateway

This should solve the internetproblems you have...

Good luck!

-Daggodt-
0
 
LVL 5

Expert Comment

by:matt023
ID: 6300768
petemcc, "You can't have AD, be a  DHCP or DNS server or be a domain controller on the ICS host!"
-- you can have these services on the ICS machine.  the warning is that ICS changes the IP address of the machine to 192.168.0.1 and clients will lose connectivity to these services once ICS is enabled.  You can re-configure the clients to point to the new IP address.

DHCP is not recommended to be installed on the machine because ICS creates a DHCP allocator which functions as a mini-DHCP server.  With DHCP service installed on the same machine as the ICS, there will be 2 DHCP services.

Technically, all you have to do is:

1. enable ICS
2. reconfigure all your clients' ip addresses to be within the 192.168.0.x range.
3. configure the clients' default gateway to point to the ICS machine.
4. Do not configure the browser to use proxy.  Just direct connection.
0
 
LVL 1

Expert Comment

by:petemcc
ID: 6300834
matt023,
 You make a good point and it's true ICS is acting as a DHCP allocator without the full functionality of a DHCP server. But if you were running those services and ICS on the same box wouldn't you get conflicts on the internet connection which is generally DHCP enabled and resolving externally? The literature I have read plus my own experience has shown that other DHCP services can cause difficulties with internet connection sharing.

Pete  
0
 
LVL 5

Expert Comment

by:matt023
ID: 6303025
you are right with the DHCP port binding conflicts. I didn't know that ICS also installs a DNS proxy.  I had enabled ICS on a DC with DNS running in the past and everything was running fine.  This is what happens when MS tries to make everything easy and automatic.  It causes confusion and problems.  Whatever happened to running a plain old NAT daemon on a UNIX or Linux server.  So simple, so straight forward.
0
 

Author Comment

by:oldbie
ID: 6395698
mattyk, I installed the proxy program you pointed me to, and it works OK, but it doesn't cause the server to dial the ISP, when a station tries to get online. (It's a simple 56k modem dial-up line.) Is there a way to force that to happen? I can't have everyone logging in to the server to dial the ISP!

Thanks.
0
 

Author Comment

by:oldbie
ID: 6722264
Sorry I took forever to award points for this! The AnalogX proxy was a pretty good solution.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Performance in games development is paramount: every microsecond counts to be able to do everything in less than 33ms (aiming at 16ms). C# foreach statement is one of the worst performance killers, and here I explain why.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now