isapi with iis doing my nut in..

hi,
i am changing from sambar to iis to cut down on how many web servers im using,and iis isnt playing the game.

my isapi dlls working fine under sambar but wont work at all under iis.

i made a new simple dll with only one action and set to default with event of:

response.content := 'test worked';

that works fine under my other web servers but not iis.

i put it in the scripts dir and checked under iis web manager -advanced that the scripts for is set to execute (which it is).

am i missing something?

my link in index.htm in wwwroot is set to
<a href="../Scripts/Project1.dll">project1</a>

if i enable directory browsing and link to ../scripts dir i can see the dll so why wont it execute?

Regards Barry

note ,
i tried giving the dll also a pathinfo of /test and added that to the end of the hyperlink but that didnt work either


LVL 17
intheAsked:
Who is Participating?
 
geobulConnect With a Mentor Commented:
Hi Barry,
As you describe the things you have done, I think that the problem is in the IIS settings because your example works fine on my IIS (NT4). What is your server OS?

Regards, Geo
0
 
EpsylonCommented:
Hi Barry, on the 'Home Directory' tab of the IIS config, did you set the 'Execute Permissions' from 'Script only' to 'Scripts and executables'?
0
 
sagerydCommented:
I found that when using DLL's, you also need to "Create an Application", function can be accessed from the "Home Directory" tab in the config.

Cheers
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ziolkoCommented:
also helpful might be setting: "Cache ISAPI application"
ziolko.
0
 
sagerydCommented:
Hint:

The "Cache ISAPI Application" checkbox should be unchecked until you have finished developing, otherwise you will need to restart to be able to replace the DLL because it then stays in memory.


Johan
0
 
ziolkoCommented:
Hint: don't give 'read' permission when "Execute(including script)" is selected
ziolko.
0
 
sagerydCommented:
Thanx ziol, didn't really know that! :o)

Johan
0
 
ziolkoCommented:
When both Execut(including script) and read are selected in some circumstances WebBrowser might start to download DLL, and We don't want that :-))
ziolko.
0
 
sagerydCommented:
Precisely. :)

Johan
0
 
sagerydCommented:
Precisely. :)

Johan
0
 
sagerydCommented:
Oops. Double. :)
0
 
sagerydCommented:
They should add the possibility to delete one's own comments! That'd be great.
0
 
EpsylonCommented:
I would like to be able to accept my own answers.  :o)
0
 
sagerydCommented:
*lol* :)
0
 
NicoLaanCommented:
My first ISAP dll didn't work because I used IIS older then optionpack 4.
You didn't make the same mistake did you?

Please tell us exactly what (serverstuff) you're using.
(NT 4 server, optionpack 4, SP6a? If so that shouldn't be the problem)
0
 
intheAuthor Commented:
ok i played a bit with it after work & its working now after i had to do a reinstall of iis.
i hadnt done the obvious and checked about .asp pages and they werent working either.the whole thing was a mess with 2 frontpage webs mixed together.(and i dont use frontpage so heaven knows how musta been some coping files that went wrong somewhere),anyways it was set for 'Scripts and executables' etc and i had tried the read both on and off so i dont know what was problem but now its working good that all that matters.
i give geobul the p's for being first cause o dont like deleting
(well it was the settings i suppose which i sorta knew already but hey ;-)
oh and it was win2k[sp1] with iis5..so now i have apache working for php/mysql and iis for asp/isapi.
Regards Barry
0
 
ziolkoCommented:
NicoLaan > my ISAPI works good even on IIS2 (no option pack!!)
ziolko.
0
 
geobulCommented:
Thanks inthe, but I didn't help you much. At my work, when I get such a MS software problem, almost always reinstalling is the fastest and stable solution.

Regards, Geo
0
 
NicoLaanCommented:
ziolko> Weird. On IIS 3, I couldn't get any ISAPI dll to work. ASP went fine. Then I installed Optionpack 4 and all was fine, so I thought that was it. But if you got it to work on iis 2, I'm really confused! It's no problem for me anymore, but thanks anyway.

Nico
0
 
ziolkoCommented:
Yeah weird I've never played with IIS3, just moved from IIS2 to IIS4, everything went smooth.
ziolko.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.