Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1027
  • Last Modified:

Configuring Proxy Server.

I recently switched ISP's and installed a Proxy server.  I have the following set up:

Proxy server:  
   Internal Address 192.168.0.1
   Internal Subnet 255.255.255.0
   External Address Static Assigned by ISP
   External Subnet 255.255.255.224

Exchange Server:
   Address 192.168.0.2
   Subnet 255.255.255.0
   WINS Address 192.168.0.6
   Default Gateway and DNS Search Order are blank.

Backup Domain Controller/WINS Server:
   Address 192.168.0.6
   Subnet 255.255.255.0
   WINS Address 192.168.0.6
   Default Gateway and DNS Search Order are blank.
   Static Mappings are entered for all servers.

Primary Domain Controller:
   Address 192.168.0.10
   Subnet 255.255.255.0
   WINS Address 192.168.0.6
   Default Gateway and DNS Search Order are blank.

DHCP Server:
   Address 192.168.0.11
   Subnet 255.255.255.0
   WINS Address 192.168.0.6
   Default Gateway and DNS Search Order are blank.
   Scope is 192.168.0.1/254
   Exclusions are 192.168.0.1/50
   DHCP Default/Global Options:
       003 Router ---  192.168.0.1
       004 Time Server --- 192.168.0.10
       044 WINS/NBNS Servers --- 192.168.0.6
       046 WINS/NBT Node Type --- 0x2     (P-Node)

_________

I also Placed the 2 wspcfg.ini files into the appropriate directories on my Exchange Server, and set up my proxy client on one client workstation (win98).



Now when i try and send an external e-mail it get's bounced back with the following message:

__________
Your message did not reach some or all of the intended recipients.

      Subject:     test e-mail setup
      Sent:     7/20/01 1:36 AM

The following recipient(s) could not be reached:

      rhansen1@austin.rr.com on 7/20/01 1:36 AM
            Unable to deliver the message due to a communications failure
     The MTS-ID of the original message is: c=US;a= ;p=Austin Pacific H;l=AUSEXCHPRXSL-010720063615Z-2
            MSEXCH:IMS:Austin Pacific Holdings:Spectrum:AUSEXCHPRXSL 3902 (000B099C) Host Unknown
_________________

Also, one other odd thing is that when i run winipcfg on the client PC it shows my node type as peer-peer.

Does anyone have an idea of where i went wrong?

Many Thanks, Kal


       
       




0
Kallik
Asked:
Kallik
  • 4
  • 2
1 Solution
 
KallikAuthor Commented:
I did a release/renew on my client and now my node type is Hybrid...

/Kal
0
 
andyalderSaggar makers bottom knockerCommented:
Host Unknown is because DNS Search Order is blank. You have to enter the DNS info on the Exchange server or it won't be able to resolve an address to send the mail to.
0
 
KallikAuthor Commented:
ok, i put my new ISP's DNS info into the Exchange Server's TCP/IP settings, now the bounce message has gone away but i have done a few test e-mails (both going out and in) and nothing has been reveived after over an hour.  I still think i am missing something.

Thanks, Kal
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
KallikAuthor Commented:
When i look at my outbound e-mails in my exchange queue they all have a "network error during host resolution" also, not sure what setting is causing this though.

/Kal
0
 
andyalderSaggar makers bottom knockerCommented:
Can't think why outbound mail fails, if proxy was set to block the port then you'd get a failed to connect error. Try opening a command prompt on the mailserver and "telnet <ip address of remote mailserver> 25"

Inbound mail might still be going to your old ISP, you will have to run nslookup and check the MX recordpoints to an A record which resolves to the external IP address of your proxy server.

Presumably you are following http://support.microsoft.com/support/kb/articles/Q181/8/47.ASP
0
 
GrizzleCommented:
Kallik,

You need to set up your servers (especially the Exchange Server with a default gateway of 192.168.0.1 (the internal IP addy of your Proxy Server))

You may also need to get your DHCP Server to broadcast the default gateway 192.168.0.1 to it's clients

then you should be able to ping your ISP DNS Server, which will mean that your DNS Resolution should begin to work.

Hope this helps

Grizzle
0
 
KallikAuthor Commented:
Fixed it, i didn't have the proxy client installed on Exchange.  Awarding points to andyalder.

Thanks All, Kal
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now