• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2092
  • Last Modified:

making the samba SMB service run at start up

Currently i have samba running for winnt access but i have to start the service manually whenever i reboot,
i.e. /etc/rc.d/init.d/smb start
im sure there is a way but i don't know it, to autoload this service at boot.......

let me know how and the points are yours!!

somebody_else
0
Somebody_else
Asked:
Somebody_else
  • 4
  • 2
1 Solution
 
superschlonzCommented:
There have to be links in /etc/rcX.d to /etc/init.d/smb
X is the runlevel. The link is normally named something like S94smb or K06smb where S means start, K means kill and the number is just for ordering the scripts.

If you have these links and it doesn't work have a look at the skript /etc/init.d/smb . there is probably a check for a variable which is set in a config file.
On SuSE Linux this is START_SMB in /etc/rc.config
0
 
Somebody_elseAuthor Commented:
i will go check it out right now... btw i am running redhat 7.0/7.1  thanks!!
0
 
Somebody_elseAuthor Commented:
i will go check it out right now... btw i am running redhat 7.0/7.1  thanks!!
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
j2Commented:
The correct way of doing this under redhat is:

chkconfig --level 35 smb start
0
 
Somebody_elseAuthor Commented:
i tried schlonz's way but managing all those links proves to be a headache  with j2's answer it is fast and simple....although the actual command line is:
chkconfig --level 35 smb on


in the future a lot of experts would be less grumpy if you didn't post answers so fast...  as this allows others to jump in with help and suggestions.....
thank you for your time and effort.
-me

0
 
j2Commented:
OH! you're right about the "on". I reedited the source to "service" a year or so back, because i was (at the time) so aggrevated over the fact that it was "on" even tho the prefix in the scripts is "S" (for start) so i thought that "start" would be more apropriate.. so my service handles both "on" and "start".

Sorry for the confusion.
0
 
Somebody_elseAuthor Commented:
oh np  i was glad to get it workin!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now