Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 243
  • Last Modified:

3c905b-tx 100tx?

I have two 3c905b-tx nics.
Drivers compiled in the kernel.
They only transfer at 10mbs.
If I loaded modules, options=4 should make them transfer at 100mbs.

Can I make them transfer at 100mbs without using modules?
0
Ted22
Asked:
Ted22
  • 2
  • 2
1 Solution
 
tdaoudCommented:

What operating system do you have?

with redhat 6.2 and above you can use 3C59x driver that comes with it.  I use it and it works great at 100mbps.

Good Luck,

Tarik
0
 
Ted22Author Commented:
RedHat7.1
I have "3c590/3c900 Vortex/Boomerang" compiled in kernel 2.4.5
The help says it's the correct driver.

Dmesg:
eth1: 3Com PCI 3c905B Cyclone 100baseTx at 0xe800,  00:10:5a:ca:31:64, IRQ 11
  product code 5152 rev 00.12 date 11-01-98
  8K byte-wide RAM 5:3 Rx:Tx split, 10baseT interface.
  Enabling bus-master transmits and whole-frame receives.
eth1: scatter/gather enabled. h/w checksums enabled


I tried a crossover cable and a switch that routes on the mac address.
Works at 100mbs with windows2000.
0
 
tdaoudCommented:

I have 7.1 too and I used linuxconf and choose 3c59x for each of my three network cards in my server.  They are all detected and function at 100 mbps while connected to a 100mbps 3Com switch.
0
 
kannabisCommented:
try checking the NICs with 3coms diagnostic program.  It could be that they're set for 10Mbps and not auto detect.
0
 
Ted22Author Commented:
I didn't know there were dos utilities for pci cards.
That was it.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now