[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

redhat 7.0 won't shut down correctly

Posted on 2001-07-21
5
Medium Priority
?
326 Views
Last Modified: 2013-12-15
When shutting down my redhat 7.0 system, it gets to "unmounting mounted devices" and jsut stops.  the hard drive light is going, and i am forced to power it off at the switch as it won't shut down.  I ran fsck (fsck /dev/hdb) and it displayed "parallelizing fsck ..." and then went to a new line and didn't continue.  I don't know exactly when this started, but i am still using the stock kernel (un-modified) that came with redhat 7.0 (2.2.16).  I recently modified the boot process to enable ide-scsi emulation on the cd drive (hdd).  I did so by adding append="hdd=ide-scsi" in teh lilo.conf file and insmod'ing ide-scsi in rc.local.  it also recognizes my zip drive (hdc) as being scsi too now.  any ideas?
0
Comment
Question by:blackc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 14

Accepted Solution

by:
xberry earned 800 total points
ID: 6304974
HUh, looks as if you did confuse your kernel with your boot process modifications. What you put into lilo.conf with the ' append ' line ONLY applies to functions that are built INTO the kernel but not to loadable modules. Apart from that: bootparameters starting with hd directly address
harddisks but never CD ROM drives. Technically you told your Computer to emulate SCSI for the second device on your second IDE controller, with the result that
a) your zip drive is misrecognized
b) when the halt script is running the various configuration scripts in order to unmount devices then it will find itself unable to unmount your falsely configured 'SCSI' zip device, thus stopping the process & leaving it ' active ' together with the ide controller & any other device hanging on it.

You should at ANY case remove that false append line in your lilo.conf in order to shut down your system the 'normal' way.

If your ide-scsi emulator does exist as a loadable module then you may leave the insmod line in rc.local for sake of your CD-ROM. I recomend to insert any modules with the ' modprobe ' command though.
 
0
 

Author Comment

by:blackc
ID: 6305146
it does exist as a loadable module.  the problem is, without the line in the lilo.conf file, the ide-cdrom or whatever the normal ide cd module gets ahold of  the cd first and i can't emulate scsi, and thus can't burn cds.  i have to be able to emulate scsi for my cdrom drive, and i seem to remember that my zipdrive was that way the last time i confgured my redhat 7.0 system.  And it shut down just fine.  how would i modify the closing unmount scripts to unmount the zip as scsi, as opposed to ide?  first i will reboot with the modifications taken out, and see if it shutds down normally.  that'll tell us something i hope.
0
 

Author Comment

by:blackc
ID: 6305174
when i removed those references the system shut down without a problem.  However, i previously tried to recompile my kernel to enable the ide-scsi emulation for the cdrom.  it would get to checking filesystems at boot and just stop.  This method of enabling emulation was given a few days ago on this forum.  I need to burn cds on this machine, but i also need to shut it down.  the most prominant solution to me is to edit the shutdown scripts.  can anyone tell me where they reside?
0
 

Author Comment

by:blackc
ID: 6305238
you didn't really answer the question to my satisfaction (just because then the cd burner wouldn't work) but you did point me in the correct direction.  What i did was to remove both lines starting emulation and reboot.  from a clean system, i mounted the zip drive as an ide device.  it worked.  then i installed the ide-scsi module and ran cdrecord -scanbus.  it only showed my cd drive, the desired results.  i looked at the listed modules, and ide-floppy was loaded for the zip drive.  so in my rc.local file where i installed the ide-scsi emulation, i first installed ide-floppy.   now the zip is recognized as ide, and the cdrw is scsi again.  AND as an added bonus, the system even shuts down properly :-)
0
 
LVL 14

Expert Comment

by:xberry
ID: 6305860
And as an extra bonus on top you obviously found an interesting & profound way how to mount an internal IDE zip drive to your system. I've read that IDE Zip drives are rare & no adequate solution given in the howtos. So your solution to mount it as ide-floppy device is a nice surprise & sure a precious contribution to the pool of solutions at EE.  
All in all I'd call that a success, wouldn't you ?

I'm happy because it worked out fine for you.
Thanks a lot.

xberry
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses
Course of the Month14 days, 19 hours left to enroll

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question