Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Login the same database

Posted on 2001-07-22
6
Medium Priority
?
283 Views
Last Modified: 2013-12-18
In my server settings.. the authentication is session based, login will use a custom based form, a default database is specified as home database.. so if the user enters http://servername then the custom form authenticates the user.

But I want to provide access to a database inside the server from IIS server... If the user clicks the URL from IIS's webpage (for eg http://servername/dbname.nsf?Login).. it opens the custom login form and if the user enters the username and password correctly it opens the database... BUT if the username/password is incorrect then the URL automatically changed to the Names database of the server (like http://servername/names.nsf?login)...

We do not want to change the HOME page settings of our server.

How can I maintain the authentication resides on the same database till the user authenticates succesfully ?

Regards,
Kumar
0
Comment
Question by:mkumaran
  • 4
  • 2
6 Comments
 
LVL 10

Expert Comment

by:zvonko
ID: 6305873
Hello Kumar,

is not your customized $$LoginUserForm form in the database domcfg.nsf ?

When in this domcfg.nsf you can create two config documents:
Mapping a Login Form
Mapping Error Messages

I tested for this "Mapping Error Messages" to place the database and form for "Authentication Failure", but I got allways the form dedicated for:
Login Form/Target Database file name:/Target Form name:

This is also the behaviour when you do not create one of this config documents but simple create the domcfg.nsf from the template domcfg.ntf
Therin you simply adapt the allready present form: $$LoginUserForm

But still your question: How to make disapear: /names.nsf?Login
is not solved. My assumption is, that is hardcoded.

Try this all on your servers instalation. Be warned that "tell http restart" is not enough. Best choice is to stop and start the srever (not simply: restart server).

Good luck,
zvonko
0
 

Author Comment

by:mkumaran
ID: 6305888
Hi zvonko,

Thanks for your quciker response.
I've checked the domcfg.nsf... the it has two documents already created.. one for mapping the custom login form.. which is pointing to DCLF.nsf (from Lotus Sandbox) and the other is created with default values.. so the "Error Message and Response Mapping" form contains the default entries only.. which is same as the database name "Domcfg.nsf".

Since we are using DCLF.nsf we didn't change anything in $$LoginUserForm.
Names.nsf is no where hardcoded (even I checked the server document).. Server document's default home page is a different notes application and not Names.nsf

Do we need to remove the default Domcfg.nsf from the error message form ?

Regards,
Kumar
0
 
LVL 10

Accepted Solution

by:
zvonko earned 200 total points
ID: 6306007
Sorry, my fault (:-)),

I assumed hardcoded not in any of your definitions, but hardcoded in LotusDomino behaviour.

So now I have better picture how you customized your login form,
but still I do not understand why it is a problem for you to see in the URL:
http://servername/names.nsf?Login

when you still below this URL see the form from:
http://servername/DCLF.nsf/CustomLoginForm

By the way; I tried to do the same and sow the content from CustomLoginForm and in the URL this .../names.nsf?Login
I gived up because today is Sunday  (the seventh day) but I think it could be something wrong with the ACL (Anonymous has to have: ReadAccess) even if the form has the field "$PublicAccess" with the content "1".
Check also this in your forms (on Monday)...

Regards,
zvonko
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mkumaran
ID: 6307170
Hi Zvonko,

I found that the DCLF's custom form's action tag includes "Names.nsf?login"... which gives the problem...

Anyhow thanks a lot for your valuable suggestions.

Regards,
Suresh
0
 
LVL 10

Expert Comment

by:zvonko
ID: 6307937
Hello Suresh,

tahnk you for the feedback ;-)
but wath about my points <|;-)

Regards,
zvonko
0
 
LVL 10

Expert Comment

by:zvonko
ID: 6308052
Sorry :-)

thank you for the points.

Regards,
zvonko
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question