Delphi Help Index Is Blank

I've obviously installed too many 3rd party libraries, because now my D5 Help Index is blank.

Any ideas on how to fix it?

Thanks

Jo
LVL 3
nnbbb09Asked:
Who is Participating?
 
kretzschmarConnect With a Mentor Commented:
from my paq

--- paste begin

i've resolved my problem (maybe partial),
maybe it works for you too

edit the file delphi5.cnt in the help directory (make  a save-copy first)

i have deleted lines which patterns

:Include AName.cnt

the index seems now to be ok
(maybe i will miss sometimes something, but not yet)
after saving the file and opening the delphi help

meikl ;-)

-- paste end

further details in q:
http://www.experts-exchange.com/jsp/qShow.jsp?ta=delphi&qid=20140168

meikl ;-)
0
 
ITugayCommented:
Hi nnbbb09,

there is Delphi Object Help (oh.exe) manager. You can use it to add or remove some help files. But it would be much easy to reinstall Delphi.

------
Igor
0
 
gemartiCommented:
Before reinstalling try this:

Open Delphi
Click Help
Click Customize...

The OpenHelp application will start

Click File
Click Clean Registry

If there are any invalid paths in the registry the application will display them to you and you can delete them.

Click Save
Let it overwrite the delphi5.ohp

BTW - You should see all the help files for your D5 sytem with this app start up.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
CrazyOneCommented:
Yeah I had a similar problem and I had to unistall and then reinstall Delphi to get it back. Reinstalling didn't help me until I unistalled it first.


The Crazy One
0
 
CrazyOneCommented:
Hi gemarti I didn't see your comment until afer I posted mine. hehehe :>)
0
 
gemartiCommented:
Hey CrazyOne - You think we'll ever know who's code was best on that string question?

I suspect not....
0
 
nnbbb09Author Commented:

Thanks Meikl, that got me on the right track. What I eventually did was remove any references to 3rd party help files that were no longer installed. This on its own did not fix the problem, however when I clicked on the 'Index files' button and removed any obsolete references there, everything seemed OK.

Jo
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.