Home network and Win 98SE

I installed a home network to share my dsl connection.    I'm running a peer to peer network via a hub.  I installed a nic in each pc, Netbeui for the protocol and ICS on the host pc.  the network works good, ICS works fine too.  my problem now is that both of the pc's will not shut down.  I've installed the shutdown patch and checked msconfig.  I've heard something about adding lines to the system/win.ini files for terminating running programs but cant remember where I heard that.  I checked my IRQ's and I have 4 devices sharing IRQ 9, two of which are IRQ Steering.  will disabling this and letting the bios choose help me?
i'm handing out 300 points because i will be very happy if some of you experts can help on this.
Ask if you need more info.

Who is Participating?
stevenlewisConnect With a Mentor Commented:
Turn off all power down and wake up options in the BIOS !

try these:

 See the Windows 98 Startup and Shutdown Troubleshooter at
                     Additional information is available in the article titled "How to Troubleshoot
                    Windows 98 Second Edition Shutdown Problems" (Article ID: Q238096) at

I hope this helps !

ocitmanAuthor Commented:
I have already disabled all power down and wake up options in the bios and have been to the control panel and disabled the standby/shut off monitor and hdd options by choosing "never".

Also have been to the Windows troubleshooter online as SysExpert suggested but i found that it will help identify a problem but does not provide much of a solution.

The problem, i believe, lies with either the NIC or the Netbeui protocol.  everything worked fine until i installed these items.  Oh yeah, there is the ICS i installed also.  However, the other pc that shares the internet connection does not shut down either and that did not have ICS installed.  this needs to be installed only on the host pc.

i will still be checking the IRQ thing later tonight and going back to the troubleshooter to help further identify and pinpoint the problem.

Sysexpert.  i tried the links you provided but both gave me the ole ERROR 404, just so you know.
We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

1) Get the latest NIC drivers for all computers.

2) Do the same for all other hardware drivers.

It could be a combination of things causing the problem. This is not the first time I have seen this.

Have you also tried disabling your anti-virus as a test.

Check/disable all the startup stuff in msconfig - startup tab.

I hope this helps !
ocitmanAuthor Commented:

Already have the latest drivers for all my hardware.
i dont run an anti virus program all the time.  only when i'm on the net downloading and installing downloaded programs
the only thing i have in the startup folder is my dsl logon window.
i will check out your other links

No mapped drives.  i did have some mapped but found it was unnecessary.  i have also installed the latest windows updates and the mapped drive shutdown update also.  the only thing besides shared folders is that the client pc is mapped to my printer (which needs ink)
No ipx/spx installed
already have and installed the latest shutdown patch v4756us8.
i will also check out you links.

Also suggest booting to safe mode, and check device manager for duplicate entries (these will not show up in normal mode) If found delete all, and reboot and reinstall
You also have disabled wake on LAN?

Check if you have anything in your startup. Remove it.
Then go to WIN.INI and comment out(put a ; before it) the load and run options. Now re-start the machine and attempt to shutdown. If it shuts down then the problem is the program loaded at startup.

Also your CONFIG.SYS or AUTOEXEC.BAT file may execute a command that causes your shutdown problem. Check these if the problem still exists.

The problem may also be due to bad device drivers.

Good luck.
ocitmanAuthor Commented:

I don't know what exactly fixed the problem but I will tell you what I did.

First thing i tried was to disable IRQ steering and manually set the bios.  that was a nightmare and weraked havoc on my system. restored IRQ steering
I uninstalled ICS, Netbeui and my NIC and rebooted.  still would not shut down.  I used a program called Clean System Directory http://www.theabsolute.net/sware/index.html#clnsys

that program scans your pc for DLL calls from the windows\system folder and gives you a list of all uncalled DLL files.  it removes them from the system folder and puts them in a backup folder.

rebooted and would still not shutdown.  I manually cleaned the registry, searching for entries pertaining to Netbeui, ICS and my NIC and deleted them.  rebooted to no avail.

Used RegClean after manually cleaning out the registry and rebooted.  pc did not shut down that time.  after the pc came back up, i shut it down again thinking the NEW registry (so to speak) would now be initialized and it worked.

I reinstalled the NIC and it shutdown.  I reinstalled Netbeui and it still shut down.  I reinstalled ICS and it still shut down.

I'm guessing that there was some sort of corrupted, incorrect, duplicate or invalid registry entry.

I'm going to award the points to stevelewis because his first answer provided links to some articles that alone did not cure the problem but they got me thinking in the right direction.  i'm grading it good because it was very helpful but was not the absolute answer

Thanks to all who answered, I really appreciate all the timely and sincere help.
ocitman I'm glad you're up and running
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.