?
Solved

startup ftp server

Posted on 2001-07-24
9
Medium Priority
?
269 Views
Last Modified: 2010-03-18
Dear all,

   I've installed Red Hat 7.1.However, when I use a win2k machine to make ftp connection to the Red Hat machine, it said: connection reset by peers.How can I start the ftp server on Red Hat?Thanks!
0
Comment
Question by:hpchong7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 3

Expert Comment

by:tdaoud
ID: 6316188

Check /etc/xinet.d directory for the wu-ftpd file and make sure that in it it has disable=no

Other than that did you install maximum security option during install or medium or none?

Tarik
0
 
LVL 2

Author Comment

by:hpchong7
ID: 6320499
I've checked the file, I've set back the disable=no, however, I still cannot to the ftp server....BTW, I've forgot what security option i've set, how can I change it now?Thanks!
0
 
LVL 3

Expert Comment

by:tdaoud
ID: 6320614

Oh if yo changed the disable to no and it was yes, you need to reboot or restart xinetd.

What do you mean by security option you changed?

Tarik
0
Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

 
LVL 2

Author Comment

by:hpchong7
ID: 6320670
Of course I've rebooted, but still in vain.

0
 
LVL 3

Accepted Solution

by:
tdaoud earned 80 total points
ID: 6320809

Then check /etc/hosts.allow and /etc/hosts.deny

If you have the line

All:All

in /etc/hosts.deny then you will need to enable ftp access from your network in /etc/hosts.allow by adding the line

in.ftpd: your.win2k.ip.address.here

Let me know how it goes.

Tarik
0
 
LVL 2

Author Comment

by:hpchong7
ID: 6321075
there is nothing except comments in both hosts.allow and hosts.deny
0
 
LVL 3

Expert Comment

by:tdaoud
ID: 6321097

You may then need to install the wu-ftp package, you may not have the server or it could not be complete or corrupted.

Try to install the ftp server again (wu-ftpxxx.xxx.xxx.rpm)

Hope this helps.

Tarik
0
 
LVL 5

Expert Comment

by:garboua
ID: 6330228
well, your ftp could be installed, but not started automatically.

type setup on your console
choose your startup services and make sure your ftp server is enabled to start automatically.
part of your setup menu is the firewall configurations, go into that and customize your firewall configurations, to allow ftp users.
if you want anonymous ftp on linux machine, look in the cd for ano*ftp*.rpm and install it
"rpm -Uvh an*ftp*.rpm " and you should be good to go.
to configure you ftp server you can use  your linuxconf and totally change permission of all users, guest, and anonymous
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question