running the applet and servlet

got tired of figuring this out..
but where do i put my applets and servlets on
resin??
(im attempting to make it work under webapp dir..
but
failed). didnt get any info on caucho.com.
the applet talks with the servlets but can not
reside
on the same directory. can u guys give me a
detailed
guide on how do i go about this one? is there any
environment variable i need to set?

on an unrelated note :
why does the java console doesnt appear on my
task bar
even if i already checked the checkbox "display
java
console"?
i have two java plugin icons on my control panel.
one
is version 1.3.0_01 and 1.31. which one is being
used
by my browser by default? if at least i can see
the
java console, id know what the goddamn the error
was
so that i can fix it. but i cant.

im using jdk 1.3.1
LVL 3
iboAsked:
Who is Participating?
 
rdovConnect With a Mentor Commented:
you should put the applet in the Root directory of Resin or the server local host, and the servlet in the classes directory.
those are the default configuration:
Applet-
<Resin path>\doc\
Servlet-
<Resin path>\doc\WEB-INF\classes

you can change those path by redefine resin.conf.
for more information
http://www.caucho.com/products/resin/ref/servlet-config.xtp

to run a servlet you should use port 8080:
http://localhost:8080/servlet/MyServlet (<Resin path>\doc\WEB-INF\classes\MyServlet.class)
to run the applet use:
http://localhost/MyApplet

Note: if you need to perform applet-server communication, the applet should be placed in the same machine where the servlet is placed. they should be called from the same server URL (for example: http://localhost)

0
 
rrzCommented:
I also had problems with multiple Dukes in my control panel. I got it working now. But I don't know if I can fix yours. In your Java Plug-in Control Panel Dialog Box, on the Basic tab, I checked Enable and show(like you did),on the Advanced tab the JRE entry I selected was "Use Java Plug-in Default". Also, I JUST LOOKED in my registry to see if I had every thing in agreement.
Maybe some other Expert can tell us how to make changes(I have 3 Dukes in my Control Panel).
0
 
iboAuthor Commented:
just to add some info,
lets say my resin installation is in c:\resin (im using resin 2.0.1)

so i created a directory "project", so my files now is located at "c:\resin\webapps\project"

i placed my applets and html file at
c:\resin\webapps\project

i placed my servlets, and other classes (rmi stub/skel) and other beans at
c:\resin\webapps\project\web-inf\classes

i was able to run this once but for some unknown and weird reason, i wasnt able to run it now. maybe i was poking on the webstart (which has also jre version, installing new jre, or whatever.)

0
 
iboAuthor Commented:
i got the problem now.
the java plugin 1.3.1 that comes with jdk or even the
jre with plugin v1.3.1 does not work correctly.

i used java plugin version 1.3.0_2
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.