DateTime Picker

Hi,

I'm using the Date/Time Picker control and I would like to eliminate the strange spacing that seems to occur in the display of the date.  I'm using the short date format as follows.

The date should display like this in the DTPicker:
1/7/01

But instead display's like this:
1 /7 /01

This forces the control to be larger than it should be, taking up extra space and it looks just plain goofy compared to the rest of the neatly formatted info in the window.

I've noticed that Microsoft seems to have avoided this problem in the Date section of the Find tool...As in Start -> Find -> File or Folders...It displays the short date just fine and without the goofy spacing.

Any ideas on how to get rid of the extra spaces would be appreciated.  Please note that I've tried using custom format with a M/d/yy variation without success.

Thanks,

Jim
syntelAsked:
Who is Participating?
 
Ryan ChongConnect With a Mentor Commented:
Hi syntel,

Try to set the CustomFormat Property in Data/Time Picker control.

Set the Format Property to 3 - dtpCustom,

then

Set the CustomFormat Property as dd/mm/yyyy

'Hope this will solve your problem, regards.
0
 
TimCotteeHead of Software ServicesCommented:
Neither the standard control nor the CCRP version of this control seem to have the ability to remove these spaces. Unless you choose a date format that fills the gaps such as suggested by ryancys (though this is more easily selected using  .Format = dtpShortDate) you have to live with the extra spacing.

I would either stick with the standard short date format (check what you have for this under control panel settings though) or go with CustomFormat = "dd/MM/yyyy"

0
 
syntelAuthor Commented:
Ineresting that Microsoft seems to get the control to work without the spacing.  I'd like to think there's another option.
0
 
DanRollinsCommented:
Hi syntel,
It appears that you have forgotten this question. I will ask Community Support to close it unless you finalize it within 7 days. I will ask a Community Support Moderator to:

    Accept ryancys's comment(s) as an answer.

syntel, if you think your question was not answered at all or if you need help, just post a new comment here; Community Support will help you.  DO NOT accept this comment as an answer.

EXPERTS: If you disagree with that recommendation, please post an explanatory comment.
==========
DanRollins -- EE database cleanup volunteer
0
 
Computer101Commented:
Comment from expert accepted as answer

Computer101
E-E Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.