Solved

USB device can't connect

Posted on 2001-07-30
11
734 Views
Last Modified: 2013-11-09
I just purchased new USB scanner (Visioneer 7700) and all the installing process seemed to be fine. After that it was found that the scanner was not connected and the software seemed unable to find the scanner.

I checked the Device Manager and found:

 Universal Serial Bus Controllers
 --- Generic USB Hub
 --- Intel(r) 82801AA USB Universal Host Control
 -!- USB Device  <--- ****
 --- USB Root Hub
 --- Visioneer PhotoPort 7700 CardReader(s)

Every one seems to be fine, except the USB Device, as marked, has a "!" with it. I tried to reinstall that driver, but in the end of the installing process, it said:

    ================
    An error occurred during the installation
    of the device.

    The installation failed because a function
    driver was not specified for this device
    instance.
    ================

What is wrong and how to fix ???

****
I am using Celeron 833 (I think) with 128 MB RAM;
The OS is Windows 2000 professional English version

0
Comment
Question by:shapeless
  • 2
  • 2
  • 2
  • +4
11 Comments
 
LVL 3

Expert Comment

by:andysalih
ID: 6333317
you need to remoce the driver completly and device out of windows,

then you need to search the net for the most up todate drivers for OS 2000 professional.

the drivers your using are not liking win 2000

cheers
Andy
ps.

or you cut get a LARGE pair of scissors and cut the CD in half and bin it.

fdisk the drive

and go back to win98. you'll find itll worth with that no problem :op

only joking about cutting ya cd up
0
 
LVL 4

Expert Comment

by:shaharidzal
ID: 6333329
Hi,
Have you tried updating the USB device from the scanner CD. Some USB devices needs the accompanying device drivers from the manufacturer. In your case, try looking for the drivers from the Scanner CD not from Windows drivers (the drivers are for the root hub)
0
 
LVL 7

Expert Comment

by:WiZaRd
ID: 6334831
seen this many times & usually one of two things

1. Using the wrong drivers
2. Not compatible with operating system

Does the packaging say it is Win2K compatible ?
0
 
LVL 7

Expert Comment

by:WiZaRd
ID: 6334868
http://www.visioneer.com/products/flatbed/7700usb/

Just been to the above site & yes it is Win2K compatible

In your device manager is there anything listed under Imaging Devices ?
shaharidzal may be on the right track here. try to update the driver for the item listed as a USB device but choose select from list rather than having windows detect it.
choose category imaging devices then browse scanner CD to the Win2000 driver folder
0
 
LVL 7

Expert Comment

by:pbessman
ID: 6334989
A good number of USB devices prefer their "driver" programs be loaded before you plug in the USB device.  Following the manufacturers instructions is of utmost importance, especially when trying to configure USB devices.  I would unplug the scanner, remove the software and reboot.  Then, I would try to load the drivers as most of these will tell you exactly when they are expecting to see the device plugged in.  Plug it in when prompted and follow the onscreen directions.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 7

Expert Comment

by:pbessman
ID: 6335040
These are the directions for the 7600, but most USB devices behave the same way.  Take a look on your "README" file and see if it is similar.  Like I was saying, INSTALL SOFTWARE then install Hardware.  You need to prepare your system for this sopecial configuration.  I consider it special as the USB port is being assigned properties normally associated with other port types in your system.  I have been using USB devices for over two years now and they all recommend that the drivers be installed prior to hardware,  This hold true for the following devices I have installed on my systems, Game controllers, Scanners, Camera, Network adapters, disk drives and USB speakers.  As you can see these devices normally would all use a seperate port.  With USB the USB port has to be configured to act like the port that it is being used instead of.

" Install the PaperPort software by following the steps below.

To copy the required file from the CD to the computer, please follow these steps:

Insert the PaperPort CD into the CD-ROM drive.

Once the PaperPort banner comes up on the screen, click on EXIT to close the window.

Then Double Click on MY COMPUTER, this will open a window, displaying all of
the drives on your computer. Find the CD-ROM drive. Right click on the CD-ROM drive and then left click on OPEN.

This will display the contents of the PaperPort CD.

Double click on the VISION folder on the CD.

Right click on the BASE folder on the CD and left click on COPY, then move your cursor to a blank area on your desktop, right click and then left click on PASTE.

After the Base Folder has been copied to your desktop, remove the CD from the drive, close all open windows.

Double-click on the BASE folder.

Locate and single click on the SCANNERS.INI file. From the File menu select Delete.

Click YES when ask if you want to move this file to recycling bin.

Double-click on SETUP.EXE or the SETUP with the computer screen icon in front of it.
Follow the on-screen instructions to install the software. When prompted to select the type of the scanner click the plus "+" sign in front of Twain Scanners and highlight Other then click Next.

When you come to the Register Now screen, you will want to click on Next and then Cancel, to get out of the Registration screens.

Now double click on the 7600usb_2k.exe file that you downloaded. Follow the on screen instructions to install the scanner driver.(SEE THIS? SEE THIS?? SEE THIS??) Connect the scanner to the USB port when prompted.


0
 
LVL 3

Expert Comment

by:andysalih
ID: 6337048
click on thread below, it has your full installation instructions to install a 7700 visioneer scanner.

http://support.visioneer.com/customer/manuals/7700.pdf


many thanks

Andy
0
 

Author Comment

by:shapeless
ID: 6340779
Hi all,

Thank you all very much for your precious comments. The problem has been solved, after spending 1.5 hr on the phone with the technical team of visioneer.

This is how it works :

======[ Problem solving for the Visioneer PhotoPort 7700 USB scanner ]======

1) In the Device Manager uninstall the following items:

   -!- USB Device  <--- ****
   --- Visioneer PhotoPort 7700 CardReader(s)
   --- Visioneer OneTouch 7700 internal Hub

2) Now, make sure you can view all of the files including Hidden and System files:

  >From the Tools Menu select Folder Options ---

   Click the View Tab;
   Make sure "Show Hidden files and folders" has a dot in front of it;
   Make sure "Hide file extensions for known file types" does NOT have a check mark in front of it;
   Make all necessary changes and click Apply then OK button.

3) Go to the INF folder of your Windows folder (lets say, c:\winnt). Delete the following files and folders, if any:

   c:\winnt\inf\OT77002.inf
   c:\winnt\inf\OT77002.pnf
   c:\winnt\inf\OT77003.inf
   c:\winnt\inf\OT77003.pnf
   c:\winnt\inf\VIZPNPIN.EXE
   c:\winnt\inf\VISIONEER.PNF
   c:\winnt\inf\VISIONEER.INF
   c:\winnt\inf\VIZPNP (Folder)
   c:\winnt\inf\I386 (Folder)

3) In the same folder:

   1. click on Search icon.
   2. Under "Search for file or folder names " enter *.inf
   3. Under "Containing text" enter visioneer
   4. Make sure "Look in" shows c:\winnt\inf
   5. Click the "Search Now" button.
   6. This will find all of the INF files associated with
      Visioneer. Delete all of the files found by the
      search feature EXCEPT for the apcompat.inf file.
   7. For every INF file there is a corresponding PNF file that must also be deleted.

4) Delete the folder "c:\winnt\twain_32\vizscan";

5) Delete all files in the folder "c:\winnt\temp" ;

6) Delete all files in the folder "c:\winnt\Temporary Internet Files" ;

7) Empty the recycle bin;

8) Do a disk cleanup on c: drive and delete unnecessary files (in my case I deleted all files);

9) Unplug the USB cord of the scanner, and disconnect the power line of the scanner (yes, both);

10) Reboot;

11) After the rebooting, click and run the file F:\ScanSoft\Drives\7700.exe --- when it is asked to plug in the scanner, plug in the USB cord first, and then connect the power line of the scanner.

=========================================

This protocol takes less than 10 min and it does work --- about 20 min after I got it to work, the scanner suddenly lost connection again in the middle of a scanning. I followed the procedure above and got it back alive again. It has been working properly since then ( > 36 hrs now).

It looks like that the problematic driver I mentioned above,

   -!- USB Device  <--- ****

is NOT needed for this scanner to work properly.

------------------
pbessman,

The CD that came with the PhotoPort 7700 is completely different from the CD you mentioned (the one for 7600);


0
 

Expert Comment

by:ComTech
ID: 6703810
Hi all,

This question has been open for quite awhile. I am going to allow feedback from the questioner and experts. If it is not resolved, I will delete or accept an answer based on the info I have been given. Experts, feel free to offer input, or even suggest who you  think is correct. I will monitor this question for a period of 5-7 days and come back and evaluate this question.

Questioner, if you were helped, chooses whom you would like to award the question to, and Accept Comment.

Thank you,
ComTech
Community Support

PLEASE DO NOT ACCET THIS COMMENT AS AN ANSWER
0
 

Accepted Solution

by:
ComTech earned 0 total points
ID: 6744569
Coustomer solved, will place question in PAQ.

Regards,
ComTech
Community Support
0
 

Expert Comment

by:athersz
ID: 10721715
Hi

I had the same problem with my HP 3970 scanner, it shows yellow mark on USB and when i wanted to update the driver it gives the error message saying

The installation failed because a function
    driver was not specified for this device
    instance.

The simple solution to this is

1) Uninstall the Driver
2) Goto program files and manually remove the installation (eg Hewlett Packard) folder
3) Goto %systemroot%\winnt\inf folder which is hidden so click tool view select show hidden files and folders
4)remove all files related to the device eg search for hp*.inf
5) disconnect the power supply to the device ( scanner or any other USB device)
6) restart the PC and now connect the USB device it will be detected and instal the software

let me tell you one thing this problem is not with the driver CD from the company and 100% it  works

0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now