Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 801
  • Last Modified:

LINKER Problem - LNK2001 unresolved external symbol _endthreadex

Greetings:

I'm trying to compile a program and the 3 linker errors I get are:

Linking...
nafxcwd.lib(thrdcore.obj) : error LNK2001: unresolved external symbol __endthreadex
nafxcwd.lib(thrdcore.obj) : error LNK2001: unresolved external symbol __beginthreadex

Any clues here?
0
John500
Asked:
John500
  • 2
  • 2
1 Solution
 
nietodCommented:
that means you are linking to the single-threaded run-time libraries.  You need to link to either the multi-threaded static link run time libraries or the molti-threaded DLL run-time library.

continues.
0
 
jkrCommented:
See http://support.microsoft.com/support/kb/articles/Q126/6/46.asp ('PRB: Error Msg: LNK2001 on __beginthreadex and __endthreadex')
0
 
nietodCommented:
to link ot the right run-time library,

Go to the "Project" menu
"Project settings" menu option
Then in the dialog that appears go to the "C/C++' tab.
In the "category" list, go to "code generation"

Then you want change the "Use run-time library" list option to one of the multi-threaded options.

Note that you need to do this with both the debug and the release versions.  this is controlled by highlighting one version or the other in the list on the left.   Be sure to choose the debug libraries when settting it for a debug version and the release libraries when you set it for a release version.

Note that EE's E-mail notification is not working.  If you post a comment, I will not be notified about it--at this time anyways.  But you can e-mail me at nietod@journey. to notify me directly.
0
 
jkrCommented:
Ooops...
0
 
John500Author Commented:
nietod,

That was the ticket.  Glad to see you are still out here on EE.

I should have known this was the answer because I asked this questin once before and you answered it.  It was actually the first place I looked, however, I was ensuring that it was set to 'single' instead of 'multiple'.

Thanks again!

0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now