Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 273
  • Last Modified:

the trouble with cd roms

Hello!

I got a REALLY big problem. My CD rom shows up in bios, but when i go to windows, its not in explorer, or my computer. I have checked all the settings, and I know everything is alright INSIDE the computer (the jumper is on the right setting, the ide cords in place, theres power, etc.) but somehow, windows doesn't seem to get it.

Here are the details: When I go to system properties and device manager, I can see it, well...a little bit. My hard drive is the primary ide controller, and cd rom is secondary ide controller.Device manager shows secondary and primary ide controllers, but they have exclamation points next to them, and they are dual fifo working under an intel pci bus master ide controller. Im not sure if the ARE working under a master controler, but that is what it says.

Another thing: when i click on the "!" next to the drives, it comes up with a message saying:

"device not present, not working, or working under wrong drivers".

Well, the device is there, so I figured to update the drivers, but the best drivers were already instaled. drivers.

Then, i attempt to disconnect the cdrom, and reboot, then reboot again and reconnect it and reboot again, thinking that it would pick up the cdrom the second time around. Well.....it didn't. I even removed the cdrom from the device maganer and then tried it again, but that was no good.

WHAT CAN I POSSIBLY ACCOMPLISH WITH NO CDROM DRIVE!!!!!!!!!!

Basically, my question is: how can i get my puny little Panisonic cr-585b cdrom to work!


Please, if you have any information, reply to this question or e-mail me at benmc@garden.net


THANKS!
0
Operative3
Asked:
Operative3
1 Solution
 
SysExpertCommented:
You probably need newer IDE drivers for your motherboard.

BIOS
http://www.ping.be/bios/numbersami.shtml
http://www.motherboards.org/ubb/Forum2/HTML/
or check the motherboard manufacturers website.
To ID it go to http://www.sysopt.com/mboard.html

Find the website for your motherboard and download all the newest drivers.

Also do a Start - windowsupdate and get any relevant drivers.

And of course - empty out your autoexec.bat and config.sys or disable them using msconfig ( win 98/ME )

I hope this helps !
0
 
ridCommented:
Try going into safe mode - control panel - system applet - device manager. Remove IDE controllers. Reboot and let windows re-detect them. To check CD-unit function, boot with 98 bootdisk with CD support and try to access a CD.
Regards
/RID
0
 
Don ThomsonCommented:
Check and see if the device manager shows the CDrom drive
If not then the Motherboard driver updates are required - What model of MB do you have?
0
[Video] Oticon Case Study

Open office environments can create the dynamics for innovation, but they also bring some challenges. With over 1,000 employees in an open office, Oticon needed a solution that would preserve the environment while mitigating disruptive background noises.

Watch how they did it.

 
pbessmanCommented:
If it is a VIA chipset follow SySexperts advice and go to http://www.viahardware.com/download/index.shtm
and see what is there.

Can you tell us what MOTHERBOARD,CPU, OS and other DRIVES attached to the motherboard are?

How is this CDROM connected?  Is it the only drive on its ribbon cable?  
0
 
pbessmanCommented:
"My hard drive is the primary ide controller, and cd rom is secondary ide controller.Device manager
shows secondary and primary ide controllers, but they have exclamation points next to them"

Try removing the IDE controllers in the safe mode.  Rather than the disk drives as they should work once you have the proper IDE controllers.  Are these things all enabled in your BIOS.  What has changed recently?  Did you update device drivers or something?
0
 
kahleanCommented:
Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS]
Name: NoIDE

To cause Windows to attempt to reinitialize the protected-mode IDE driver, remove the 'NoIDE' entry
from the registry key above.

After you update the registry, restart Windows. Windows will then attempt to initialize the protected-mode
driver for the controller.

If no problems are encountered, the file system and virtual memory will operate in 32-bit mode, and
Device Manager will not display an exclamation point in a yellow circle for the IDE channels.


THe above will definately solve the problem. however if you are unsure on how to modify your registry
can update all your chipset driver

Here are a few

For via: www.via.com.tw
For intel: www.intel.com
For sis: www.sis.com.tw
For ali: www.ali.com.tw

Regards
0
 
bparnesCommented:
Kahlean has given you good advice. Please eliminate the NOIDE entry in the registry first. If you don't know how to do that, find someone in your neighborhood who does. A mistake in editing the registry can be catastrophic to your ability to boot up into Windows, and you don't want your computer to serve as your learning platform.
0
 
marcelomferreiraCommented:
I have experienced this problem in an old 486 computer with no CDROM drives. When I installed CDROM drive, Windows didn't recognized it.

The only way I found to fix the problem was formatting HD and reinstalling Windows with CD drive installed and turnned on.

I don't know why, but, in that case, when I removed CD drive from the machine and restart Windows, the yellow marks in Device Manager disappeared. When I reinstalled CD drive, they appeared again. I don't know if I could fix it correcting Windows Registry, because I didn't know where to change. May be kahlean's comment solves the problem, or may be you find any other registry key to change, if there is another one.

Anyway, if it didn't solve the problem, try to delete all Windows and reinstall it again. If you could get another empty HD, try to install Windows on that HD first. If it works or not, you will find out with no need to format your HD.
0
 
pbessmanCommented:
"the best drivers were already instaled"  Not always the case, especially if this is the message WINDOWS is telling you.  It is best to obtain the LATEST drivers which may NOT be WINDOWS COMPATIBILITY LABS CERTIFIED and you will get that message even though the newer drivers are the better ones.  In reading about driver upgrades for stuff like sound and graphics cards this issue has been discussed with full explanation that after a "deadline" Microsoft stops certifying drivers, this can cause this errant message to be displayed.

Rather than tamper in the registry if you don't feel comfortable there, you can possibly change the driver by performing a driver update and using the "display a list of all drivers in a specific location, so you can select the driver you want"  Then select the "show all hardware" and finally choose the device manufacturers or use the "have disk" option if you have a set of drivers on a floppy.  

Are you trying to use a CD/RW in Windows 95???  Is it 95B?  Many CD/RW devices do not have Windows 95 support.  I am suspecting this may be your case given the difficulty this installation is presenting you.
0
 
ComTechCommented:
Hi all,

This question has been open for quite awhile. I am going to allow feedback from the questioner and experts. If it is not resolved, I will delete or accept an answer based on the info I have been given. Experts, feel free to offer input, or even suggest who you  think is correct. I will monitor this question for a period of 5-7 days and come back and evaluate this question.

Questioner, if you were helped, chooses whom you would like to award the question to, and Accept Comment.  It is your responsibility to complete this question.

Thank you,
ComTech
Community Support

PLEASE DO NOT ACCET THIS COMMENT AS AN ANSWER
0
 
ComTechCommented:
This question has been abandoned and will be placed in PAQ and points refunded.

Best regards,
ComTech
Community Support
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Tackle projects and never again get stuck behind a technical roadblock.
Join Now