Solved

the trouble with cd roms

Posted on 2001-08-04
11
265 Views
Last Modified: 2010-04-27
Hello!

I got a REALLY big problem. My CD rom shows up in bios, but when i go to windows, its not in explorer, or my computer. I have checked all the settings, and I know everything is alright INSIDE the computer (the jumper is on the right setting, the ide cords in place, theres power, etc.) but somehow, windows doesn't seem to get it.

Here are the details: When I go to system properties and device manager, I can see it, well...a little bit. My hard drive is the primary ide controller, and cd rom is secondary ide controller.Device manager shows secondary and primary ide controllers, but they have exclamation points next to them, and they are dual fifo working under an intel pci bus master ide controller. Im not sure if the ARE working under a master controler, but that is what it says.

Another thing: when i click on the "!" next to the drives, it comes up with a message saying:

"device not present, not working, or working under wrong drivers".

Well, the device is there, so I figured to update the drivers, but the best drivers were already instaled. drivers.

Then, i attempt to disconnect the cdrom, and reboot, then reboot again and reconnect it and reboot again, thinking that it would pick up the cdrom the second time around. Well.....it didn't. I even removed the cdrom from the device maganer and then tried it again, but that was no good.

WHAT CAN I POSSIBLY ACCOMPLISH WITH NO CDROM DRIVE!!!!!!!!!!

Basically, my question is: how can i get my puny little Panisonic cr-585b cdrom to work!


Please, if you have any information, reply to this question or e-mail me at benmc@garden.net


THANKS!
0
Comment
Question by:Operative3
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 6352075
You probably need newer IDE drivers for your motherboard.

BIOS
http://www.ping.be/bios/numbersami.shtml
http://www.motherboards.org/ubb/Forum2/HTML/
or check the motherboard manufacturers website.
To ID it go to http://www.sysopt.com/mboard.html

Find the website for your motherboard and download all the newest drivers.

Also do a Start - windowsupdate and get any relevant drivers.

And of course - empty out your autoexec.bat and config.sys or disable them using msconfig ( win 98/ME )

I hope this helps !
0
 
LVL 31

Expert Comment

by:rid
ID: 6352089
Try going into safe mode - control panel - system applet - device manager. Remove IDE controllers. Reboot and let windows re-detect them. To check CD-unit function, boot with 98 bootdisk with CD support and try to access a CD.
Regards
/RID
0
 
LVL 14

Expert Comment

by:Don Thomson
ID: 6352273
Check and see if the device manager shows the CDrom drive
If not then the Motherboard driver updates are required - What model of MB do you have?
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 7

Expert Comment

by:pbessman
ID: 6352467
If it is a VIA chipset follow SySexperts advice and go to http://www.viahardware.com/download/index.shtm
and see what is there.

Can you tell us what MOTHERBOARD,CPU, OS and other DRIVES attached to the motherboard are?

How is this CDROM connected?  Is it the only drive on its ribbon cable?  
0
 
LVL 7

Expert Comment

by:pbessman
ID: 6352470
"My hard drive is the primary ide controller, and cd rom is secondary ide controller.Device manager
shows secondary and primary ide controllers, but they have exclamation points next to them"

Try removing the IDE controllers in the safe mode.  Rather than the disk drives as they should work once you have the proper IDE controllers.  Are these things all enabled in your BIOS.  What has changed recently?  Did you update device drivers or something?
0
 
LVL 6

Expert Comment

by:kahlean
ID: 6352506
Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS]
Name: NoIDE

To cause Windows to attempt to reinitialize the protected-mode IDE driver, remove the 'NoIDE' entry
from the registry key above.

After you update the registry, restart Windows. Windows will then attempt to initialize the protected-mode
driver for the controller.

If no problems are encountered, the file system and virtual memory will operate in 32-bit mode, and
Device Manager will not display an exclamation point in a yellow circle for the IDE channels.


THe above will definately solve the problem. however if you are unsure on how to modify your registry
can update all your chipset driver

Here are a few

For via: www.via.com.tw
For intel: www.intel.com
For sis: www.sis.com.tw
For ali: www.ali.com.tw

Regards
0
 
LVL 5

Expert Comment

by:bparnes
ID: 6354681
Kahlean has given you good advice. Please eliminate the NOIDE entry in the registry first. If you don't know how to do that, find someone in your neighborhood who does. A mistake in editing the registry can be catastrophic to your ability to boot up into Windows, and you don't want your computer to serve as your learning platform.
0
 

Expert Comment

by:marcelomferreira
ID: 6355504
I have experienced this problem in an old 486 computer with no CDROM drives. When I installed CDROM drive, Windows didn't recognized it.

The only way I found to fix the problem was formatting HD and reinstalling Windows with CD drive installed and turnned on.

I don't know why, but, in that case, when I removed CD drive from the machine and restart Windows, the yellow marks in Device Manager disappeared. When I reinstalled CD drive, they appeared again. I don't know if I could fix it correcting Windows Registry, because I didn't know where to change. May be kahlean's comment solves the problem, or may be you find any other registry key to change, if there is another one.

Anyway, if it didn't solve the problem, try to delete all Windows and reinstall it again. If you could get another empty HD, try to install Windows on that HD first. If it works or not, you will find out with no need to format your HD.
0
 
LVL 7

Expert Comment

by:pbessman
ID: 6355625
"the best drivers were already instaled"  Not always the case, especially if this is the message WINDOWS is telling you.  It is best to obtain the LATEST drivers which may NOT be WINDOWS COMPATIBILITY LABS CERTIFIED and you will get that message even though the newer drivers are the better ones.  In reading about driver upgrades for stuff like sound and graphics cards this issue has been discussed with full explanation that after a "deadline" Microsoft stops certifying drivers, this can cause this errant message to be displayed.

Rather than tamper in the registry if you don't feel comfortable there, you can possibly change the driver by performing a driver update and using the "display a list of all drivers in a specific location, so you can select the driver you want"  Then select the "show all hardware" and finally choose the device manufacturers or use the "have disk" option if you have a set of drivers on a floppy.  

Are you trying to use a CD/RW in Windows 95???  Is it 95B?  Many CD/RW devices do not have Windows 95 support.  I am suspecting this may be your case given the difficulty this installation is presenting you.
0
 

Expert Comment

by:ComTech
ID: 6703855
Hi all,

This question has been open for quite awhile. I am going to allow feedback from the questioner and experts. If it is not resolved, I will delete or accept an answer based on the info I have been given. Experts, feel free to offer input, or even suggest who you  think is correct. I will monitor this question for a period of 5-7 days and come back and evaluate this question.

Questioner, if you were helped, chooses whom you would like to award the question to, and Accept Comment.  It is your responsibility to complete this question.

Thank you,
ComTech
Community Support

PLEASE DO NOT ACCET THIS COMMENT AS AN ANSWER
0
 

Accepted Solution

by:
ComTech earned 0 total points
ID: 7038022
This question has been abandoned and will be placed in PAQ and points refunded.

Best regards,
ComTech
Community Support
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question